This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 69337 - up2date traceback when using proxy
up2date traceback when using proxy
Status: CLOSED DUPLICATE of bug 68437
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
:
Depends On:
Blocks: 67217 68104
  Show dependency treegraph
 
Reported: 2002-07-21 11:50 EDT by Michael Schwendt
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-24 00:18:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-21 11:50:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020712

Description of problem:
rhn_register through proxy server crashes with Python traceback.


Version-Release number of selected component (if applicable):
rhnlib up to and including 0.8-7


How reproducible:
Always

Steps to Reproduce:
1. configure rhn_register to use proxy
2. try to register at RHN


** (rhn_register:815): WARNING **: could not find handler `onPackagePageBack'

** (rhn_register:815): WARNING **: could not find handler `onStartPagePrepare'
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 228, in ?
    main()
  File "/usr/sbin/rhn_register", line 197, in main
    gui.main()
  File "/usr/share/rhn/register/gui.py", line 804, in main
    gui = Gui()
  File "/usr/share/rhn/register/gui.py", line 214, in __init__
    text = rhnreg.welcomeText()
  File "/usr/share/rhn/register/rhnreg.py", line 432, in welcomeText
    s = getServer()
  File "/usr/share/rhn/register/rhnreg.py", line 422, in getServer
    password=proxyPassword)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 89, in __init__
    self._transport.add_header("X-Info",
AttributeError: 'str' object has no attribute 'add_header'

** (rhn_register:815): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
Comment 1 Mihai Ibanescu 2002-07-22 12:49:13 EDT
Changing component to rhn_register, where the bug originally was, and was fixed
a couple of days ago.
Comment 2 Michael Schwendt 2002-07-22 14:29:40 EDT
A couple of days ago?

Is rhnlib-0.8-8.noarch.rpm supposed to fix it? If so, it doesn't.

Or is an updated rhn_register package available anywhere?
Comment 3 Mihai Ibanescu 2002-07-22 15:39:29 EDT
The bug is not in rhnlib, it's in rhn_register
Check out ftp://people.redhat.com/misa/fixes, there should be a newer up2date
there as well now.
Comment 4 Michael Schwendt 2002-07-22 17:24:44 EDT
No rhn_register there. Sorry for bugging you. ;)
Comment 5 Michael Schwendt 2002-07-22 17:38:11 EDT
# rpm -q up2date
up2date-2.9.16-7.x.9
# rpm -q rhn_register
package rhn_register is not installed

* Thu Jul 18 2002 Adrian Likins <alikins@redhat.com>

- obsolete rhn_register 

* Wed Jul 17 2002 Adrian Likins <alikins@redhat.com>

- merge in rhn_register

But:

# up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 801, in ?
    main()
  File "/usr/sbin/up2date", line 579, in main
    from up2date_client import gui
  File "/usr/share/rhn/up2date_client/gui.py", line 46, in ?
    import rhnreg
ImportError: No module named rhnreg

** (up2date:1061): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
Comment 6 Adrian Likins 2002-07-22 18:11:41 EDT
> File "/usr/share/rhn/up2date_client/gui.py", line 46, in ?
>    import rhnreg

doh, fixed. 2.9.17 should fixed it. should be on misa's link
shortly
Comment 7 Michael Schwendt 2002-07-22 18:55:54 EDT
# rpm -e up2date up2date-gnome
# rm -rf /etc/sysconfig/rhn
# rpm -i up2date*2.9.17-7.x.9*

# rpm -q rhnlib
rhnlib-0.8-8

# rpm -q up2date up2date-gnome
up2date-2.9.17-7.x.9
up2date-gnome-2.9.17-7.x.9

# up2date-config
[change to use Proxy server]
/etc/sysconfig/rhn/up2date reads:
enableProxy=1
httpProxy=host.domain:3128

# up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 17, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth 
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 113, in ?
    psc = PackageSourceConfig()
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 83, in __init__
    self.serverSettings = ServerSettings()
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 62, in __init__
    if cfg.readEntry("enableProxy") and rpcServer.getProxySetting():
AttributeError: 'module' object has no attribute 'getProxySetting'
Comment 8 Need Real Name 2002-07-23 00:14:22 EDT
I had a bit of trouble installing these updates. I removed up2date and
up2date-gnome from my machine using 'rpm -e up2date up2date-gnome'. Then tried
to install the newer version of up2date, and I got the following error:

[root@deepthought richard]# rpm -Uvh up2date-2.9.17-7.x.9.i386.rpm
error: cannot open Packages index using db3 - No such file or directory (2)
error: Failed dependencies:
        rhn_register = 2.9.6 is needed by rhn_register-gnome-2.9.6-7.x.9

Which seems a bit odd to me. The error seems to be because of a manual entry in
the RPM...

[root@deepthought richard]# rpm -i up2date*2.9.17-7.x.9*
file /usr/sbin/rhnreg_ks from install of up2date-2.9.17-7.x.9 conflicts with
file from package rhn_register-2.9.6-7.x.9
file /usr/share/man/man8/rhnreg_ks.8.gz from install of up2date-2.9.17-7.x.9
conflicts with file from package rhn_register-2.9.6-7.x.9

However, when I did: 'rpm -Uvh up2date*2.9.17-7.x.9*' it all installed properly
- or at least I didn't get any warnings.

Do both of these packages provide this same man entry?
Comment 9 Michael Schwendt 2002-07-23 13:11:37 EDT
@ leenookx : When upgrading packages, always upgrade all packages at once with
-Uvh or -Fvh, respectively.

[...]

Anyway, just for the record, traceback from 2002-07-22 18:55:54 is also with:

# rpm -q rhnlib
rhnlib-0.8-9

# rpm -qa |  grep ^up2date
up2date-gnome-2.9.20-7.x.9
up2date-2.9.20-7.x.9

The traceback comes also when running "up2date-config" after up2date has been
configured for proxy usage:

# up2date-config 
Traceback (most recent call last):
  File "/usr/sbin/up2date-config", line 17, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth 
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 113, in ?
    psc = PackageSourceConfig()
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 83, in __init__
    self.serverSettings = ServerSettings()
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 62, in __init__
    if cfg.readEntry("enableProxy") and rpcServer.getProxySetting():
AttributeError: 'module' object has no attribute 'getProxySetting'

[...]

Changing component to "up2date" since rhn_register has been integrated.
Comment 10 Michael Young 2002-07-23 14:51:29 EDT
This bug is now the same as bug 68437 .
Comment 11 Michael Schwendt 2002-07-24 00:23:17 EDT

*** This bug has been marked as a duplicate of 68437 ***

Note You need to log in before you can comment on or make changes to this bug.