Bug 693458 - Regression: .so bar.1 no longer works
Regression: .so bar.1 no longer works
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
14
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Schiffer
Fedora Extras Quality Assurance
: Reopened
: 713144 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-04 14:08 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2012-05-04 16:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: man-db-2.6.0.2-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:38:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2011-04-04 14:08:15 EDT
Description of problem:
With the old man package, one could put .so bar.1 into a man page file (say, foo.1) and man foo would display the manpage for bar. This no longer works, as man is looking for the target manpage file in /usr/share/man instead of the same location as the original file.

Version-Release number of selected component (if applicable):
2.5.7-7.fc14

How reproducible:
Always

Steps to Reproduce:
1. echo ".so w.1" >/usr/share/man/man1/foo.1
2. man foo
  
Actual results:
man: can't open /usr/share/man/w.1: No such file or directory
No manual entry for foo

Expected results:
same as man w
Comment 1 Colin Watson 2011-04-04 14:22:50 EDT
I've already fixed this in the man-db 2.6.0 development branch.  I expect to release 2.6.0 in a week or two.
Comment 2 Ivana Varekova 2011-04-21 07:19:37 EDT
Thanks, now the rawhide version (man-db-2.6.0.2-1) fixes this problem.
Comment 3 Dominik 'Rathann' Mierzejewski 2011-04-21 08:15:24 EDT
Note that this bug was filed against Fedora 14, not rawhide. And I don't see any (even pending) updates for F-14. Please close it only after it is fixed in Fedora 14.
Comment 4 Colin Watson 2011-04-21 08:42:17 EDT
Well, the upstream change was http://bazaar.launchpad.net/~cjwatson/man-db/trunk/revision/1287 if somebody wants to attempt a backport.  It was a fairly substantial rearrangement though.
Comment 5 Ivana Varekova 2011-06-17 03:24:26 EDT
*** Bug 713144 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2011-06-17 04:11:45 EDT
man-db-2.5.7-8.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/man-db-2.5.7-8.fc14
Comment 7 Fedora Update System 2011-06-17 04:17:47 EDT
man-db-2.5.9-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/man-db-2.5.9-5.fc15
Comment 8 Ivana Varekova 2011-06-17 04:22:01 EDT
Hello Colin, 
I just try to reproduce the problem with 2.6.0 which should be fixed but the version and reproduce the bug there too (reproducer is described in bz 713144).
I patch the problem in f14 and f15 there is more possibilities how to add the feature thus I'm not sure whether the one I have used is the preferred one for upstream. The patch is in git now, if you want some other version I can change it.
Comment 9 Fedora Update System 2011-06-21 13:06:28 EDT
Package man-db-2.5.9-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.5.9-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/man-db-2.5.9-5.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-06-23 23:32:59 EDT
man-db-2.5.9-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-06-26 14:51:07 EDT
man-db-2.5.7-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Lorenzo Buzzi 2011-12-01 05:34:43 EST
Problem still present in Fedora 16

$ man reboot
man: can't open /usr/share/man/halt.8: No such file or directory
Comment 13 Charles Butterfield 2012-01-04 11:08:07 EST
Although this bug is still present in Fedora-16, it is marked closed.  Can somebody reopen it?
Comment 14 Peter Schiffer 2012-04-24 13:47:36 EDT
Hello guys,

could you try this build which should fix this issue?
man-db-2.6.1-4.fc18
http://koji.fedoraproject.org/koji/buildinfo?buildID=315116


Thanks,

peter
Comment 15 Fedora Update System 2012-04-25 14:00:55 EDT
man-db-2.6.0.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/man-db-2.6.0.2-5.fc17
Comment 16 Fedora Update System 2012-04-26 09:28:35 EDT
man-db-2.6.0.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/man-db-2.6.0.2-3.fc16
Comment 17 Fedora Update System 2012-04-26 15:28:20 EDT
Package man-db-2.6.0.2-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.6.0.2-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6672/man-db-2.6.0.2-5.fc17
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-05-02 00:38:05 EDT
man-db-2.6.0.2-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-05-04 16:32:39 EDT
man-db-2.6.0.2-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.