Bug 713144 - Some phantom manpages include wrong paths of true ones
Some phantom manpages include wrong paths of true ones
Status: CLOSED DUPLICATE of bug 693458
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-14 09:24 EDT by Robin Lee
Modified: 2011-06-17 03:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-17 03:24:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Lee 2011-06-14 09:24:13 EDT
Description of problem:
$ zcat /usr/share/man/man1/init.1.gz 
.so systemd.1

init.1 contains a single line and includes a wrong path of the true manpage.
Other similar phantom manpages include reboot.1, poweroff.1.

Version-Release number of selected component (if applicable):
systemd-26-2.fc15.i686

How reproducible:


Steps to Reproduce:
1. man init
2. man reboot
3. man poweroff
  
Actual results:
$ man init
man: can't open /usr/share/man/systemd.1: No such file or directory
$ man reboot
man: can't open /usr/share/man/halt.8: No such file or directory
$ man poweroff
man: can't open /usr/share/man/halt.8: No such file or directory
man: can't open /usr/share/man/halt.8: No such file or directory
man: can't open /usr/share/man/halt.8: No such file or directory
No manual entry for poweroff

Expected results:
No warning and show the proper manpage.

Additional info:
Comment 1 Lennart Poettering 2011-06-14 15:21:36 EDT
Uh, this works fine here. Which version of man-db do you have installed?

My guess would be that this is a problem within man-db. Tentatively reassigning.
Comment 2 Robin Lee 2011-06-14 22:40:33 EDT
man-db-2.5.9-4.fc15
Comment 3 Colin Watson 2011-06-15 05:06:48 EDT
I added support for this in man-db 2.6.0.

  http://bzr.savannah.gnu.org/lh/man-db/trunk/revision/1287
Comment 4 Ivana Varekova 2011-06-17 03:24:26 EDT

*** This bug has been marked as a duplicate of bug 693458 ***

Note You need to log in before you can comment on or make changes to this bug.