Bug 6941 - ncurses 5.0 isn't really backward-compatible
Summary: ncurses 5.0 isn't really backward-compatible
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses
Version: 6.1
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL: ftp://rawhide.redhat.com/pub/rawhide/...
Whiteboard:
Depends On:
Blocks: 7835
TreeView+ depends on / blocked
 
Reported: 1999-11-12 07:16 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-12 17:59:36 UTC


Attachments (Terms of Use)

Description Pekka Savola 1999-11-12 07:16:32 UTC
I upgraded to ncurses-5.0-1 and every curses-program stopped
working complaining missing shared libraries.

Adding symlinks for old ncurses versions in /usr/lib by hand fixed the
problem.

----
rpm -V ncurses
missing    /usr/lib/libform.so.4
missing    /usr/lib/libmenu.so.4
....L...   /usr/lib/libncurses.so.4
missing    /usr/lib/libpanel.so.4
----

Comment 1 Bernhard Rosenkraenzer 1999-11-12 17:59:59 UTC
Thanks for reporting - fixed in 5.0-2.


Note You need to log in before you can comment on or make changes to this bug.