This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 7835 - ncurses-5.0-2 still screwing up ncurses-4 compatibility
ncurses-5.0-2 still screwing up ncurses-4 compatibility
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On: 6941
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-16 06:45 EST by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-06 12:21:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 1999-12-16 06:45:16 EST
But number 6941 reports that when ncurses 5.0 is installed, the ncurses 4.0
libraries disappear.  The bug is marked resolved, and there's a claim in it
that the problem is fixed in ncurses-5.0-2. I did not find that to be the
case.  I just installed ncurses-5.0 and it blew away my ncurses 4
libraries, as reported by "rpm --verify ncurses".  I had to install the
symbolic links by hand after unpacking the ncurses 5 source RPM to figure
out what they were supposed to be.

Speaking of which, the links created in the install rules of the spec file
for ncurses 5.0 shouldn't be absolute.  That is, rather than linking
libncurses.4, libpanel.4, etc., to /usr/lib/libncurses.5,
/usr/lib/libpanel.5, etc., the links should just point to
"lib<whatever>.so.5" in the same directory.
Comment 1 Kostas Georgiou 1999-12-17 05:25:59 EST
I found out that ldconfig was killing the ncurses 4 links for some reason,
after rebuilding ldconfig (same version) the problem went away.
All this under a powerpc machine so it might be unrelated
Comment 2 Bernhard Rosenkraenzer 2000-01-06 12:21:59 EST
It's fixed now (the .so.5 has just been renamed to .so.4, there are no API
changes).
Comment 3 Kriang Lerdsuwanakij 2000-02-01 19:19:59 EST
Although the API is the same, the ABI is different.  The data structures that
ncurses library and applications use depends on the definition of 'bool' in
curses.h.  'bool' is defined to be 'char' on ncurses-5.0 (on i386 platform) while
it can vary on ncurses-4.2 depending on whether a C++ compiler is present on the
building host.  This problem has already triggered the bug number 4573.

So I think sharing the same library files for ncurses 5.0  and ncurses 4.2 is a
bad idea.  Binaries compiled on RH6.1 will dump core on the next version of RH.

Note You need to log in before you can comment on or make changes to this bug.