Bug 694294 - curl AND nss need to be able to use pem files interchangeably in a single process
Summary: curl AND nss need to be able to use pem files interchangeably in a single pro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: curl
Version: 6.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: Miroslav Vadkerti
URL:
Whiteboard:
: 693252 (view as bug list)
Depends On: 689031 765921 806043
Blocks: 568421 693252 695747 696665
TreeView+ depends on / blocked
 
Reported: 2011-04-06 21:19 UTC by Denise Dumas
Modified: 2018-02-09 13:17 UTC (History)
14 users (show)

Fixed In Version: curl-7.19.7-26.el6
Doc Type: Bug Fix
Doc Text:
It was not possible to use two distinct client certificates to connect two times in a row to the same SSL server. This is now fixed to allow two different client certifications to connect to the same SSL server.
Clone Of: 689031
: 695747 696665 (view as bug list)
Environment:
Last Closed: 2011-05-19 13:12:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 761086 None None None 2019-02-28 08:45:50 UTC
Red Hat Product Errata RHBA-2011:0573 normal SHIPPED_LIVE curl bug fix update 2011-05-18 17:57:02 UTC

Internal Links: 761086

Comment 3 Kamil Dudka 2011-04-07 06:06:32 UTC
*** Bug 693252 has been marked as a duplicate of this bug. ***

Comment 4 Kamil Dudka 2011-04-07 13:13:20 UTC
This is the current version of the patch for libcurl:

    attachment #489418 [details]

Comment 9 seth vidal 2011-04-08 04:01:19 UTC
I don't believe this requires a yum rebuild at all. just curl/nss

Comment 11 Kamil Dudka 2011-04-08 11:40:03 UTC
pushed upstream:

https://github.com/bagder/curl/commit/1a6e7da

Comment 15 Misha H. Ali 2011-04-20 06:14:24 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
It was not possible to use two distinct client certificates to connect two times in a row to the same SSL server. This is now fixed to allow two different client certifications to connect to the same SSL server.

Comment 16 errata-xmlrpc 2011-05-19 13:12:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0573.html


Note You need to log in before you can comment on or make changes to this bug.