Bug 694518 - /sbin/shutdown is missing in the installation image for s390x
/sbin/shutdown is missing in the installation image for s390x
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
15
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2011-04-07 10:38 EDT by Jan Stodola
Modified: 2013-07-04 08:54 EDT (History)
7 users (show)

See Also:
Fixed In Version: lorax-0.4.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-28 08:38:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2011-04-07 10:38:18 EDT
Description of problem:
When the installation is finished and user wants to shutdown the system (reboot is not possible at this moment, bug 694499), init try to run /sbin/shutdown which is not included in the installation image:


about to exec shutdown 
01: HCPGSP2629I The virtual machine is placed in CP mode due to a SIGP stop from
 CPU 00.
/init: line 110: /sbin/shutdown: No such file or directory 
Ý 5578.667456¨ Kernel panic - not syncing: Attempted to kill init! 
Ý 5578.667464¨ CPU: 0 Not tainted 2.6.38.2-9.fc15.s390x #1 
Ý 5578.667469¨ Process init (pid: 1, task: 000000002f640000, ksp: 000000002f64ba
20) 
Ý 5578.667474¨ 0000000000000000 000000002f64bce8 0000000000000002 00000000000000
00  
Ý 5578.667482¨        000000002f64bd88 000000002f64bd00 000000002f64bd00 0000000
000602f20  
Ý 5578.667495¨        0000000000a071c4 0000000000000000 00000000000003e0 0000000
00000000b  
Ý 5578.667510¨        000000000000000c 000000002f64bd50 0000000000000000 0000000
000000000  
Ý 5578.667526¨        0000000000618e58 00000000001009ce 000000002f64bce8 0000000
02f64bd30  
Ý 5578.667547¨ Call Trace: 
Ý 5578.667553¨ (Ý<0000000080000000>¨ 0x80000000) 
00: HCPGIR450W CP entered; disabled wait PSW 00020001 80000000 00000000 0010F2FE


Version-Release number of selected component (if applicable):
anaconda-15.25

How reproducible:
always

Steps to Reproduce:
1. run installation
2. shutdown at the end of the install
  
Actual results:
/init: line 110: /sbin/shutdown: No such file or directory
...

Expected results:
correct shutdown/reboot
Comment 1 Dan Horák 2011-04-13 09:46:13 EDT
fixed in images prepared with lorax-0.4.2-1.fc15

Note You need to log in before you can comment on or make changes to this bug.