This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 694682 - Transparent background issues under gnome-shell
Transparent background issues under gnome-shell
Status: CLOSED DUPLICATE of bug 681926
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
15
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-07 20:43 EDT by Vallimar
Modified: 2011-04-22 07:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-22 07:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vallimar 2011-04-07 20:43:29 EDT
Description of problem:
When enabling the transparent background option, transparency is blocked.
At first, I didn't think it worked at all, but in the overview, you can see it working, kinda. Also, works fine in fallback mode. Further testing, I noticed the very left edge was allowing transparency so I deduced that a large shadow or solid pixmap of the background colour is blocking the composited transparency effect while in gnome-shell. I'm unsure if this problem needs to be fixed in gnome-shell or gnome-terminal but it is there. The blockage changes when you set the background colour property.


Version-Release number of selected component (if applicable):
First noticed this in early alpha's, though it would be fixed by now.
But currently tested with gnome-terminal-3.0.0-1.fc15.x86_64.


How reproducible:
Always, under gnome-shell.


Steps to Reproduce:
1. Start gnome-terminal under gnome-shell.
2. Change settings to use transparent background.

  
Actual results:
Transparency effect isn't very transparent


Expected results:
More transparent transparency.


Additional info:
Comment 1 Robert 2011-04-07 22:56:48 EDT
I see this as well but for me at least the transparency is OK when maximised.
Comment 2 Brian Cook 2011-04-21 22:31:18 EDT
Confirmed, this also happens in gnome-terminal.x86_64 2.32.0-1.fc14 running latest gnome-shell built from source.  Transparency works only when maximized.
Comment 3 Benjamín Valero Espinosa 2011-04-22 07:29:13 EDT

*** This bug has been marked as a duplicate of bug 681926 ***

Note You need to log in before you can comment on or make changes to this bug.