Bug 681926 - Transparent background does not work properly in gnome-terminal
Transparent background does not work properly in gnome-terminal
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
: 681425 683274 694682 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-03 10:47 EST by Thorsten Leemhuis
Modified: 2011-11-25 05:21 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 05:21:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 635268 None None None Never

  None (edit)
Description Thorsten Leemhuis 2011-03-03 10:47:47 EST
Description of problem:
Transparent background does not work properly in gnome-terminal; it is only transparent at the left and right edges when in window mode; works fine after going to fullscreen mode by hitting F11

See
http://www.leemhuis.info/files/misc/g3-problem-window.png
http://www.leemhuis.info/files/misc/g3-problem-fs.png

Version-Release number of selected component (if applicable):
clutter-1.6.6-2.fc15.x86_64
gnome-terminal-2.33.90-1.fc15.x86_64
gtk3-3.0.1-2.fc15.i686
gtk3-3.0.1-2.fc15.x86_64
mutter-2.91.90-2.fc15.x86_64
xorg-x11-drv-ati-6.14.0-2.20110204gita27b5dbd9.fc15.x86_64

How reproducible:
Always; problem showed up after updating from F14 to rawhide a few weeks ago but I never got around to report it

Additional info:
Not sure if this is a bug in either mutter, gnome-terminal oder xorg-x11-drv-ati; going for gnome-terminal, please reassign if you think that's wrong

01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f]

X.org-Log:
http://www.leemhuis.info/files/misc/g3-Xorg.0.log
Comment 1 Michel Alexandre Salim 2011-03-26 07:13:08 EDT
*** Bug 681425 has been marked as a duplicate of this bug. ***
Comment 2 Michel Alexandre Salim 2011-03-26 07:13:36 EDT
*** Bug 683274 has been marked as a duplicate of this bug. ***
Comment 3 Benjamín Valero Espinosa 2011-04-22 07:29:13 EDT
*** Bug 694682 has been marked as a duplicate of this bug. ***
Comment 4 Remi Marechal 2011-05-12 18:24:10 EDT
I have same problem with an Intel graphics card.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Comment 5 Sergio Pascual 2011-05-13 06:35:33 EDT
The same with an nvidia card

lspci | grep VGA
03:00.0 VGA compatible controller: nVidia Corporation G96 [Quadro FX 580] (rev a1)
Comment 6 Andrey Arapov 2011-05-28 04:40:26 EDT
Hi, I've got same problem.

Laptop Lenovo ThinkPad T400

$  lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

$ uname -a
Linux fedora 2.6.38.6-27.fc15.x86_64 #1 SMP Sun May 15 17:23:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/fedora-release 
Fedora release 15 (Lovelock)
Comment 7 Bapf 2011-05-28 07:34:53 EDT
Same here on both Desktop (using the proprietary NVIDIA driver)

[bapf@urd ~]$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Device 0dc4 (rev a1)
[bapf@urd ~]$ uname -a
Linux urd 2.6.38.6-27.fc15.i686.PAE #1 SMP Sun May 15 17:39:47 UTC 2011 i686 i686 i386 GNU/Linux
[bapf@urd ~]$ cat /etc/fedora-release 
Fedora release 15 (Lovelock)

and on my Laptop

[bapf@kahlan ~]$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
[bapf@kahlan ~]$ uname -a
Linux kahlan 2.6.38.6-27.fc15.i686.PAE #1 SMP Sun May 15 17:39:47 UTC 2011 i686 i686 i386 GNU/Linux
[bapf@kahlan ~]$ cat /etc/fedora-release
Fedora release 15 (Lovelock)

Both coming from a clean FC15-beta install.

As with the previous posters, if I got to full screen with the terminal (or go into expose mode) the transparency works.
Comment 8 Tore H. Larsen 2011-06-07 03:15:18 EDT
cc
Comment 9 Leon Keijser 2011-06-07 06:40:06 EDT
confirmed here on f15 (preupgraded from f14):

porcaria ~ # lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G98M [Quadro NVS 160M] (rev a1)
porcaria ~ # uname -a
Linux porcaria 2.6.38.6-27.fc15.x86_64 #1 SMP Sun May 15 17:23:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
porcaria ~ # rpm -q gnome-terminal
gnome-terminal-3.0.1-1.fc15.x86_64
Comment 10 Paul Visco 2011-06-08 00:07:01 EDT
Clean F15 install on Dell M4500 using nouveau drivers and have the same issue.  The terminal does not support transparency in gnome shell, unless full screen.  When windowed, the background becomes opaque.

[paolo@svelt15 ~]$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation GT216 [Quadro FX 880M] (rev a2)
[paolo@svelt15 ~]$ uname -a
Linux svelt15.sv 2.6.38.6-27.fc15.x86_64 #1 SMP Sun May 15 17:23:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
[paolo@svelt15 ~]$ rpm -q gnome-terminal
gnome-terminal-3.0.1-1.fc15.x86_64
[paolo@svelt15 ~]$ rpm -q gnome-shell
gnome-shell-3.0.2-1.fc15.x86_64
[paolo@svelt15 ~]$ rpm -q mutter
mutter-3.0.2.1-1.fc15.x86_64
[paolo@svelt15 ~]$ rpm -q clutter
clutter-1.6.14-1.fc15.x86_64
Comment 11 Noris Datum 2011-06-08 15:08:41 EDT
confirmed from alpha to date with below hw;

01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350] (prog-if 00 [VGA controller])

&

01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series (prog-if 00 [VGA controller])

&

00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (prog-if 00 [VGA controller])
Comment 12 Euphoria 2011-06-09 10:26:27 EDT
Same problem here... Any updates on this?


[euphoria@nemo ~]$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation NV44 [Quadro NVS 285] (rev a1)
[euphoria@nemo ~]$ uname -a
Linux nemo 2.6.38.7-30.fc15.x86_64 #1 SMP Fri May 27 05:15:53 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
[euphoria@nemo ~]$ rpm -q gnome-terminal
gnome-terminal-3.0.1-1.fc15.x86_64
[euphoria@nemo ~]$ rpm -q gnome-shell
gnome-shell-3.0.2-1.fc15.x86_64
Comment 13 Paul Visco 2011-06-11 10:55:57 EDT
Its clearly not a card issue because the trasnparency is working when the terminal window is shown in activities mode and when it is full screen.
Comment 14 Paul Visco 2011-06-11 11:10:34 EDT
I think this explains the problem https://bugzilla.gnome.org/show_bug.cgi?id=635268 - apparently it is caused by the drop shadow blocking.  That is why the left few pixels are still transparent.
Comment 15 Euphoria 2011-06-13 14:03:42 EDT
Yeah, I guess it's a know issue, at least for the last five months.. but no official patches or fixes have been released...
Comment 16 Andrey Arapov 2011-06-14 03:20:54 EDT
In Linux, this is a feature, not a bug :D
Comment 17 Paul Visco 2011-06-14 19:00:31 EDT
In the screenshot on this blog, the guy running gnome shell with a terminal, drop shadows and a transparent background http://joneslee85.wordpress.com/2010/02/28/howto-customize-gnome-shell-theme/ so it must have been working at some point.
Comment 18 Euphoria 2011-06-23 09:03:38 EDT
Wow, no updates on this bug....
Comment 19 Andrey Arapov 2011-06-23 09:51:47 EDT
Maybe coz of summer time, vacations, girls, sea... :D
Comment 20 Thorsten Leemhuis 2011-06-23 10:12:16 EDT
<sigh/>

Afaics everything looks like this is a general problem that is not specific to Fedora, hence it's best dealt with upstream -- that's what the reference in "External Trackers" indicates. Once it's fixed upstream we can start talking about backporting the fix, so I for one (as the reporter) don't expect any updates here for now.
Comment 21 Paul Visco 2011-06-28 19:43:47 EDT
It appears that the people reporting this same bug on the gentoo bug report site say it is solved in mutter 3.0.2 https://bugs.gentoo.org/show_bug.cgi?id=367139 but according to fedora 15, I am using mutter 3.0.2.1 and it is not solved for me. 

[paul@svelt4 ~]$ mutter --version
mutter 3.0.2.1

I can't seem to tell the current status on https://bugzilla.gnome.org/show_bug.cgi?id=635268 It looks like it was fixed and then came back.
Comment 22 Bapf 2011-06-29 16:10:30 EDT
Let's hope todays change (https://bugzilla.gnome.org/show_bug.cgi?id=635268#c35) will fix it once commited and live.
Comment 23 Paul Visco 2011-07-18 18:48:20 EDT
Looks like it was corrected upstream https://bugzilla.gnome.org/show_bug.cgi?id=635268#c35 as the link above shows but the changes have no yet been picked up by Fedora 15?  I am updated with yum and still the drop shadow on all windows on gnome 3 is a solid black rectangle. Any idea on a timeline for this?  I would be happy to help testing if needed.  Also does anyone else no how to just get rid of the drop shadow in the mean time.
Comment 24 Paul Visco 2011-07-18 18:53:18 EDT
The fix is specifically listed in the changelog as * Don't draw a shadow under windows with an alpha-channel - this fixes transparency for GNOME Terminal [Owen, Jasper; #635268]  http://git.gnome.org/browse/mutter/commit/?id=3209e88c6f08c4e7b349b9384717e98eab55deeb

Sounds like exactly what we need.  I guess we just have to wait for mutter 3.1.3 to hit Fedora 15.
Comment 25 Paul Visco 2011-07-26 23:27:54 EDT
I upgraded to mutter 3.1.3.1 (3.1.3.1-2.fc16) and it works fine.

sudo yum install fedora-release-rawhide
sudo yum update clutter mutter

Afterwards, I got perfectly normal transparency on windows.  Now we just have to wait for someone to backport mutter 3.1.3.1 to fedora 15.
Comment 26 Paul Visco 2011-07-26 23:48:23 EDT
You can see an example of it working here http://estrip.org/articles/read/paul/54795/Fedora-15-Terminal-Transparency-Gnome-3.html
Comment 27 Leon Keijser 2011-07-27 02:01:28 EDT
(In reply to comment #26)
> You can see an example of it working here
> http://estrip.org/articles/read/paul/54795/Fedora-15-Terminal-Transparency-Gnome-3.html

Yep, works perfectly here. Thanks, Paul, for the pointer!
Comment 28 Euphoria 2011-07-27 08:42:00 EDT
Still black here.... :/
Comment 29 Euphoria 2011-07-27 09:34:05 EDT
Never mind guys.

Paul Visco forgot to but at the end of the second line: "--enablerepo=rawhide update"

So it should be like this:

sudo yum update clutter mutter --enablerepo=rawhide update

Then press 'alt + F2' and type 'r' and press Enter

After I installed the clutter & mutter from the rawhide, transparency worked.

Thanks!
Comment 30 G. Michael Carter 2011-07-27 09:58:37 EDT
I did the action from comment 29 and it worked good too.

Wish gnome-shell didn't upgrade have the system, I'd love to play around with it too.
Comment 31 Paul Visco 2011-08-05 23:35:42 EDT
Has anyone at Red Hat looked into this?

Its something that affects every F15 gnome 3 install, regardless of drivers, hardware, etc as it is just an extra black rectangle being drawn behind an otherwise transparent window.   It seems like there is a fix that can be backported and a working version in rawhide yet this still remains severity unspecified, priority unspecified, and status new 5 months after it was reported.  Can we at least get a status update or recognition that this is occurring?
Comment 32 starfall 2011-09-04 04:59:52 EDT
The current mutter in rawhide that requires the new clutter/cogl is unstable. Crashes with dialog boxes and has other major issues with stability.

Recommend the following version (mutter-3.1.3.1-1.fc16) from the build system -

http://koji.fedoraproject.org/koji/buildinfo?buildID=251606

This is the last version which fixes the transparent windows issue without the new clutter.
Comment 33 Bapf 2011-11-25 05:14:46 EST
fixed in Fedora 16
Comment 34 Thorsten Leemhuis 2011-11-25 05:21:30 EST
and unlikely to get fixed for f15, so closing it

Note You need to log in before you can comment on or make changes to this bug.