Bug 695184 - webkitgtk3 missing plugin support
Summary: webkitgtk3 missing plugin support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-11 03:54 UTC by Evandro Giovanini
Modified: 2011-05-03 04:53 UTC (History)
2 users (show)

Fixed In Version: webkitgtk3-1.4.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-03 04:53:29 UTC


Attachments (Terms of Use)

Description Evandro Giovanini 2011-04-11 03:54:52 UTC
Tested with GtkLauncher and epiphany. Plugin support doesn't seem to work with the GTK+3 version of WebKit ("Missing plugins"), but it does work with /usr/libexec/webkitgtk/GtkLauncher provided by the GTK+2 version.

I noticed webkitgtk3 applies "webkit-1.1.14-nspluginwrapper.patch" while webkitgtk applies a newer, "webkit-1.3.10-nspluginwrapper.patch" version.

Comment 1 Peter Hatina 2011-04-21 08:23:42 UTC
If you look inside those patches, their content is the same. Also, when I try to run epiphany, all the plugins load correctly (when talking about NPAPI based plugins)

** (epiphany:15890): DEBUG: NP_Initialize
** (epiphany:15890): DEBUG: NP_Initialize succeeded

...

repeated several times.

But I can not get your error, maybe more specific description would be helpful.

Comment 2 Evandro Giovanini 2011-04-27 23:38:44 UTC
Test case:

1) Make sure gnash-plugin (or Adobe's flash plugin) is installed.

2) Use /usr/libexec/webkit/GtkLauncher (gtk2) and go to Youtube or some other Flash website. It works.

3) Use /usr/libexec/webkitgtk3/GtkLauncher or Epiphany (gtk3) to watch a Youtube video. Instead of displaying the flash content, the plugin isn't initialized and simply displays a "Missing plugins" error.

I thought this might have been a Fedora bug but it's not. A workaround for the issue can be found in this blog entry: http://debarshiray.wordpress.com/2011/04/12/gnash-and-epiphany/. That link references GNOME bug #647516, which is a duplicate of GNOME bug #647096 and that in turn is fixed with a WebKit patch referenced there.

I'll try applying that WebKit patch against webkitgtk3-1.3.13-1.fc15 and I'll report back here if I can get gnash to work.

Comment 3 Evandro Giovanini 2011-04-28 03:39:21 UTC
Just to confirm: gnash works with the patched webkitgtk3. A simple update to webkitgtk3 1.4.0 provides the fix, but the patch should also be compatible with the version in Fedora 15. It can be found here: https://bugs.webkit.org/show_bug.cgi?id=58297

Epiphany must be updated to version 3.0.1 as well, 3.0.0 manually blocks gnash and flash instead of letting WebKit block the incompatible versions.

Comment 4 Fedora Update System 2011-04-28 21:11:43 UTC
webkitgtk3-1.4.0-1.fc15, epiphany-3.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/webkitgtk3-1.4.0-1.fc15,epiphany-3.0.1-1.fc15

Comment 5 Fedora Update System 2011-05-03 04:53:24 UTC
webkitgtk3-1.4.0-1.fc15, epiphany-3.0.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.