Bug 69526 - up2date wont work with proxy (no username/password)
up2date wont work with proxy (no username/password)
Status: CLOSED DUPLICATE of bug 68437
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 19:32 EDT by Stephen Moore
Modified: 2015-01-07 18:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 22:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Moore 2002-07-22 19:32:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020721

Description of problem:
up2date wont work with proxy, configuration as used with 7.3

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run up2date
2.
3.
	

Actual Results:  [root@toy stephen]# up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 17, in ?
    from up2date_client import rpcServer
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 7, in ?
    import up2dateAuth
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 4, in ?
    import rpmSource
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 113, in ?
    psc = PackageSourceConfig()
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 83, in __init__
    self.serverSettings = ServerSettings()
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 62, in __init__
    if cfg.readEntry("enableProxy") and rpcServer.getProxySetting():
NameError: global name 'rpcServer' is not defined
[root@toy stephen]#


Expected Results:  update system

Additional info:

My home system has the same problem, I configured out the proxy at home, an
option not available at work, and up2date worked.
Comment 1 Stephen Moore 2002-07-22 20:50:08 EDT
Sorry, this is happening on limbo. (I choose poorly)
Comment 2 Adrian Likins 2002-07-22 21:53:21 EDT
this should be fixed from versions about 2.9.15 an on
Comment 3 Michael Schwendt 2002-07-22 22:11:48 EDT
Yep, this is duplicate of bug #68437.

2.9.15 may fix it, but proxy still doesn't work. See bug #69337 which is about
the combined up2date/rhnreg application.
Comment 4 Bill Nottingham 2002-07-22 23:30:22 EDT

*** This bug has been marked as a duplicate of 68437 ***

Note You need to log in before you can comment on or make changes to this bug.