Bug 695555 - Transaction failed error when registering a user
Transaction failed error when registering a user
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Authentication-Internal (Show other bugs)
1.3-alpha-1
All Linux
low Severity high
: ---
: ---
Assigned To: Carlos Munoz
Alex Eng
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-04-11 20:19 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kenichi Takemura 2011-04-11 20:19:43 EDT
Description of problem:

After having registered a user, I can see 'Transaction failed error' if I add a new user that have same name and email but different Username.

Version-Release number of selected component (if applicable):
Zanata version 1.3-alpha-1 (20110330-1649). 

How reproducible:
always

Steps to Reproduce:
1. Add a new user and complete email activation
2. Add a new user whose name and email are the same but Username is different
3.
  
Actual results:
Error

    * Transaction failed
    * Unexpected error. Please try again. 

Expected results:
The system will accept the user added or 'User already registered' depending on Zanata spec.

Additional info:
Comment 1 Sean Flanigan 2011-09-07 00:32:59 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Runa Bhattacharjee 2011-09-08 13:54:41 EDT
There should ideally be a check to ensure that an email address is mapped to only one user. The email address would be used for various purposes including account reset if required and should not be duplicated.
Comment 3 Sean Flanigan 2011-09-08 20:26:59 EDT
This error is generated because UI validation logic fails to check for duplicate email addresses, but the database *is* preventing the duplicate email address from being stored, thus causing an error.

Note that this hasn't been a high priority before now because internal authentication is only used in test environments, not in production.
Comment 5 Ding-Yi Chen 2011-09-08 22:05:30 EDT
Bug reproduced with Verion 1.4-SNAPSHOT (20110906-1403), internal authentication.
Comment 6 Carlos Munoz 2012-02-13 00:22:18 EST
Added email validation when registering a new user with internal authentication. Zanata will now validate that the email address is well formed, as well as that the address is not already taken by another user before allowing the registration attempt to continue.

https://github.com/zanata/zanata/commit/0ac42cc809e5ea988978c55767b2bec54782787b
Comment 7 Alex Eng 2012-02-20 17:44:13 EST
VERIFIED in Zanata version 1.5.0-alpha-2-SNAPSHOT (20120220-1431). Validation on duplicate email triggers to prevent this bug from happening.

Note You need to log in before you can comment on or make changes to this bug.