Bug 719176 - Edit profile: "duplicate email" is shown even if user press save without changing email
Summary: Edit profile: "duplicate email" is shown even if user press save without chan...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 1.4.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Carlos Munoz
QA Contact: Alex Eng
URL:
Whiteboard:
Keywords:
: 741804 (view as bug list)
Depends On:
Blocks: zanata-1.5.0
TreeView+ depends on / blocked
 
Reported: 2011-07-06 00:42 UTC by Ding-Yi Chen
Modified: 2012-03-07 00:06 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-03-07 00:06:51 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 695555 None None None Never
Red Hat Bugzilla 741804 None None None Never

Internal Trackers: 695555 741804

Description Ding-Yi Chen 2011-07-06 00:42:49 UTC
Description of problem:
When editing profile, if a user hasn't changed email but click "Save",
then error message "duplicate email" is shown.

This is somewhat misleading.

Version-Release number of selected component (if applicable):
Zanata version 1.4-SNAPSHOT (20110706-0602)

How reproducible:
Always

Steps to Reproduce:
1. Login zanata server 
2. Click "My Profile"
3. Click "Edit profile"
4. Click "Save"
  
Actual results:
Error message "duplicate email"

Expected results:
Either 
1) save name without triggering "email verification"; or 
2) showing "nothing changed" if name is not changed either.


Additional info:

Comment 1 Sean Flanigan 2011-07-06 05:19:00 UTC
Yes, it should save the change regardless, sending an email if and only if the address has changed.  I don't think we need to detect "nothing changed" as such.

Comment 2 Sean Flanigan 2011-09-07 04:32:56 UTC
Assigning to Scrum product owner for prioritisation.

Comment 3 Sean Flanigan 2011-09-28 03:31:39 UTC
*** Bug 741804 has been marked as a duplicate of this bug. ***

Comment 4 David Mason 2011-10-31 00:45:16 UTC
This bug is still present in 1.4.2 deployed on https://translate.zanata.org

Comment 5 Carlos Munoz 2012-02-14 05:40:06 UTC
Removed annotation based validation for the profile case, replacing it with "manual" validation in the ProfileAction class. The annotation based validation was moved to the registration page where it made more sense to use it.

See:
https://github.com/zanata/zanata/commit/e4863365d85f32af1eb67c5098a983f4b1ceb866

Comment 6 Alex Eng 2012-02-20 22:36:01 UTC
VERIFIED in Zanata version 1.5.0-alpha-2-SNAPSHOT (20120220-1431)


Note You need to log in before you can comment on or make changes to this bug.