This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 696506 - Python client commands should accept --help/-h
Python client commands should accept --help/-h
Status: CLOSED DUPLICATE of bug 738510
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
unspecified
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-14 03:43 EDT by Sean Flanigan
Modified: 2011-10-18 00:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 00:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-04-14 03:43:45 EDT
You can get help for the python client's various commands using:
  zanata help <command>

But unlike a lot of other tools (eg svn), you can't use
  zanata <command> --help
  zanata <command> -h

We should add these options as synonyms for the corresponding help commands.
Comment 1 Kenichi Takemura 2011-05-05 19:39:30 EDT
I need this feature literally.
Comment 2 Sean Flanigan 2011-05-05 20:55:43 EDT
Kenichi, why is this enhancement high priority for you?  Can't you just type "zanata help <command>" ?
Comment 3 Kenichi Takemura 2011-05-05 21:03:20 EDT
Oh sorry i neglected the first part of Comment 0.

You can get help for the python client's various commands using:
  zanata help <command>

This is what I wanted but how to get to know above? zanata help does not explain so.
Comment 4 James Ni 2011-05-09 21:31:01 EDT
I add this feature in commit 6e5e728 in devel branch of zanata client on github. You can check out and test it. This feature will include in next release version of zanata client.
Comment 5 Ding-Yi Chen 2011-10-18 00:16:59 EDT

*** This bug has been marked as a duplicate of bug 738510 ***

Note You need to log in before you can comment on or make changes to this bug.