Bug 738510 - --help does not list commands
--help does not list commands
Status: CLOSED NEXTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
1.3
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
: 696506 742843 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-14 23:02 EDT by Joshua Wulf
Modified: 2014-10-19 18:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2011-09-14 23:02:12 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.220 Safari/535.1

Running zanata --help does not return a list of valid commands.


Reproducible: Always

Steps to Reproduce:
1.Run zanata --help
2.
3.
Actual Results:  


usage: zanata [PROGRAM_OPTIONS] COMMAND [OPTIONS] ARGS

Try zanata COMMAND --help' for help on a specific command.


Expected Results:  


usage: zanata [PROGRAM_OPTIONS] COMMAND [OPTIONS] ARGS

Try zanata COMMAND --help' for help on a specific command.
The following are valid zanata commands:
push 
pull

(etc...)
Comment 1 James Ni 2011-10-12 22:44:48 EDT
Hi Joshua,

Sorry for late response, i have add this to source code, please check commit 750d0674fa3. I will make a new package for zanata-python-client, version 1.3.2. That version will include this fix. Thanks
Comment 2 James Ni 2011-10-13 22:32:17 EDT
*** Bug 742843 has been marked as a duplicate of this bug. ***
Comment 3 Ding-Yi Chen 2011-10-16 23:26:17 EDT
VERIFIED with commit 654368bb1a87b90973b2b78da615e9e40ae6422c
Comment 4 Ding-Yi Chen 2011-10-18 00:16:59 EDT
*** Bug 696506 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.