Bug 69680 - Traceback attempting to run hwbrowser
Traceback attempting to run hwbrowser
Status: CLOSED DUPLICATE of bug 67957
Product: Red Hat Public Beta
Classification: Retired
Component: hwbrowser (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
:
: 70054 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-24 09:33 EDT by Jay Turner
Modified: 2015-01-07 18:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 23:46:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2002-07-24 09:33:27 EDT
Description of Problem:
Getting a traceback when attempting to run this routine on my desktop machine. 
The traceback is:

Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 163, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 156, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 485, in initialize
    populate (tree_view, disks, graph)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 379, in populate
    raise RuntimeError, ("can't handle more than "
RuntimeError: can't handle more than one extended partition per disk

Which is all the more interesting when you consider this:
[root@kokopelli root]# fdisk -l /dev/hda

Disk /dev/hda: 255 heads, 63 sectors, 2489 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        17    136521   83  Linux
/dev/hda2            18      2489  19856340    5  Extended
/dev/hda5            18       655   5124703+  83  Linux
/dev/hda6           656      1293   5124703+  83  Linux
/dev/hda7          1294      1485   1542208+  83  Linux
/dev/hda8          1486      1518    265041   82  Linux swap
/dev/hda9          1519      2489   7799526   83  Linux

[root@kokopelli root]# fdisk -l /dev/hdb

Disk /dev/hdb: 255 heads, 63 sectors, 784 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1       784   6297448+  83  Linux


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bill Nottingham 2002-07-29 23:46:43 EDT
*** Bug 70054 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2002-08-19 18:37:36 EDT

*** This bug has been marked as a duplicate of 67957 ***

Note You need to log in before you can comment on or make changes to this bug.