Bug 67957 - won't start
won't start
Status: CLOSED DUPLICATE of bug 61917
Product: Red Hat Public Beta
Classification: Retired
Component: hwbrowser (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
: 68110 69680 70234 71900 72699 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-04 15:59 EDT by Tammy Fox
Modified: 2013-04-02 00:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 04:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2002-07-04 15:59:42 EDT
(DeviceList.py:2850): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:2850): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:2850): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 163, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 156, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 485, in initialize
    populate (tree_view, disks, graph)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 379, in populate
    raise RuntimeError, ("can't handle more than "
RuntimeError: can't handle more than one extended partition per disk

** (DeviceList.py:2850): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.

My partition tables look like:
[root@goofy tfox]# fdisk -l

Disk /dev/hda: 255 heads, 63 sectors, 4982 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       510   4096543+   6  FAT16
/dev/hda3           513      4982  35905275    5  Extended
/dev/hda5          4440      4949   4096543+   6  FAT16
/dev/hda6          1819      4439  21053151   83  Linux
/dev/hda7           519       583    522081   82  Linux swap
/dev/hda8           584      1818   9920106   83  Linux
/dev/hda9          4950      4959     80293+  83  Linux

Partition table entries are not in disk order

Disk /dev/hdb: 255 heads, 63 sectors, 4982 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1      4982  40017883+  83  Linux
Comment 1 Bill Nottingham 2002-07-08 01:29:37 EDT
*** Bug 68110 has been marked as a duplicate of this bug. ***
Comment 2 tom georgoulias 2002-07-31 20:46:20 EDT
I'm also seeing this bug:

[root@gemini root]# hwbrowser

(DeviceList.py:2996): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:2996): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:2996): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:2996): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 163, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 156, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 485, in initialize
    populate (tree_view, disks, graph)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 379, in populate
    raise RuntimeError, ("can't handle more than "
RuntimeError: can't handle more than one extended partition per disk

** (DeviceList.py:2996): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
[root@gemini root]# umount /mnt/cdrom
[root@gemini root]# fdisk -l

Disk /dev/hda: 255 heads, 63 sectors, 5005 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1        16    128488+  83  Linux
/dev/hda2            17      2076  16546950   83  Linux
/dev/hda3          2077      3381  10482412+  83  Linux
/dev/hda4          3382      5005  13044780    f  Win95 Ext'd (LBA)
/dev/hda5          3382      4425   8385898+  83  Linux
/dev/hda6          4426      4751   2618563+  83  Linux
/dev/hda7          4752      5005   2040223+  82  Linux swap

[root@gemini root]# gdb hwbrowser
GNU gdb Red Hat Linux (5.2.1-1)

(no debugging symbols found)...
(gdb) run
Starting program: /usr/bin/consolehelper

Program received signal SIGTRAP, Trace/breakpoint trap.
0x40000b00 in _start () from /lib/ld-linux.so.2
(gdb)
Comment 3 Peter van Egdom 2002-08-03 11:21:06 EDT
I'm experiencing this bug also on Red Hat Linux 7.3.93 Limbo beta 2.

[root@limbo-pc root]# rpm -qa |grep -i hwbrows
hwbrowser-0.4.1-2
[root@limbo-pc root]#


[root@limbo-pc root]# hwbrowser

(DeviceList.py:1602): Gtk-WARNING **: Whoever translated default:LTR did so wrongly.

(DeviceList.py:1601): Gtk-WARNING **: Whoever translated default:LTR did so wrongly.


(DeviceList.py:1601): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1601): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1601): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:1601): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 163, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 156, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 485, in initialize
    populate (tree_view, disks, graph)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 379, in populate
    raise RuntimeError, ("can't handle more than "
RuntimeError: can't handle more than one extended partition per disk

** (DeviceList.py:1601): WARNING **: CORBA_ORB_destroy: ORB still has 2 refs.
[root@limbo-pc root]#


here's my partition information :


root@limbo-pc root]# fdisk -l

Disk /dev/hda: 255 heads, 63 sectors, 1229 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       956   7679038+   7  HPFS/NTFS
/dev/hda2           957       969    104422+  83  Linux
/dev/hda3           970      1197   1831410   83  Linux
/dev/hda4          1198      1229    257040    f  Win95 Ext'd (LBA)
/dev/hda5          1198      1229    257008+  82  Linux swap
[root@limbo-pc root]#
Comment 4 Fabricio C Zuardi 2002-08-08 19:03:54 EDT
I'm having this too, just installed Red Hat limbo with the default Workstation
packages and tried to open the hardware browser from gnome menu.
Comment 5 Jay Turner 2002-08-13 21:03:23 EDT
*** Bug 70234 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2002-08-19 18:37:27 EDT
*** Bug 69680 has been marked as a duplicate of this bug. ***
Comment 7 Tim Waugh 2002-08-20 04:25:29 EDT
*** Bug 71900 has been marked as a duplicate of this bug. ***
Comment 8 Preston Brown 2002-08-20 15:02:25 EDT

*** This bug has been marked as a duplicate of 61917 ***
Comment 9 Bill Nottingham 2002-08-27 21:33:33 EDT
*** Bug 72617 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2002-08-27 21:57:58 EDT
*** Bug 72699 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.