Bug 696825 - Dependency error
Summary: Dependency error
Keywords:
Status: CLOSED DUPLICATE of bug 676441
Alias: None
Product: Fedora
Classification: Fedora
Component: js
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-14 22:52 UTC by rvcsaba
Modified: 2011-04-15 07:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-15 07:28:12 UTC


Attachments (Terms of Use)

Description rvcsaba 2011-04-14 22:52:10 UTC
Description of problem:

Yumex reported:

Dependency Resolution Errors:

Package: elinks-0.12-0.24.pre5.fc15.x86_64 (@anaconda-InstallationRepo-201104032318.x86_64)
    Requires: libjs.so.1()(64bit)
    Removing: js-1.70-13.fc15.x86_64 (@anaconda-InstallationRepo-201104032318.x86_64)
        libjs.so.1()(64bit)
    Updated By: 1:js-1.8.5-3.fc15.x86_64 (updates-testing)
        Not found


Version-Release number of selected component (if applicable):

elinks-0.12-0.24.pre5.fc15.x86_64
js-1.70-13.fc15.x86_64


How reproducible:

Update js to js-1.8.5-3.fc15.x86_64

  
Actual results:

Dependency error


Expected results:

Update successful

Comment 1 Ondrej Vasik 2011-04-15 05:58:43 UTC
Thanks for headsup, we know, that's caused by incompatible API in updated js - see e.g. upstream discussion - http://linuxfromscratch.org/pipermail/elinks-dev/2011-April/002034.html and http://article.gmane.org/gmane.linux.redhat.fedora.testers/89490/match=elinks  ... soname breaking update was done very late in release cycle, so should be reverted. Adopting new API in elinks is not that easy, so other possibility is to temporarily disable javascript support in elinks.

Comment 4 Pavel Alexeev 2011-04-15 07:28:12 UTC
Thank you for the bugreport. Problem known and that update already reverted.

*** This bug has been marked as a duplicate of bug 676441 ***


Note You need to log in before you can comment on or make changes to this bug.