Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 676441 - Update JS to 1.8.5
Update JS to 1.8.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: js (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
: Reopened
: 696673 696825 707544 708720 (view as bug list)
Depends On:
Blocks: 676437 698679
  Show dependency treegraph
 
Reported: 2011-02-09 16:07 EST by Christopher Aillon
Modified: 2018-04-11 07:11 EDT (History)
17 users (show)

See Also:
Fixed In Version: mongodb-1.8.0-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 698679 (view as bug list)
Environment:
Last Closed: 2011-05-30 18:35:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
devel subpackage needs to ask for the newly added epoch (1.38 KB, text/x-c++)
2011-04-12 13:27 EDT, Christopher Aillon
no flags Details

  None (edit)
Description Christopher Aillon 2011-02-09 16:07:35 EST
We need to make the GNOME 3 stack stop depending on Firefox.  See bug 676437 for full rationale.  We'd like to have GNOME 3 depend on the js package instead, but I'm told that in order to do that, we need to drop -DJS_C_STRINGS_ARE_UTF8.
Comment 1 Pavel Alexeev 2011-02-09 16:48:59 EST
Hm, it is very-very interesting, but to opposite your request it not so in the past was added due to the requirements f.e. for MongoDB - https://bugzilla.redhat.com/show_bug.cgi?id=576585

Also, not so long I have been asked to do this also for EPEL for some erlang package dependencies.

I think now it is not impossible if we will not find way to keep both variants or some kind of compromise.

So, now I close it as CANTFIX, but feel free to write or even reopen it if you have idea how it may be accompleashed.
Comment 2 Christopher Aillon 2011-02-09 17:48:03 EST
Well, the compile time option has gone away in JS 1.8+ so this will not exist in the next update.  Other programs should not be relying on it anyway.

However, things that need UTF8 support in 1.8+ can turn it on at runtime. See https://developer.mozilla.org/En/SpiderMonkey/JSAPI_Reference/JS_CStringsAreUTF8

I'd recommend updating to at the very least the 1.8.0 rc from here http://ftp.mozilla.org/pub/mozilla.org/js/

Or better yet, grab the mozilla/js source bit from Firefox 3.6.x (which would be JS 1.8.2.x).  Debian builds MongoDB against one of the newer Firefox JSAPIs, and I see no reason we shouldn't either especially since it's much faster.
Comment 3 Christopher Aillon 2011-02-09 17:52:53 EST
See also https://developer.mozilla.org/En/SpiderMonkey/1.8
Comment 4 Pavel Alexeev 2011-02-11 13:52:01 EST
May be then there have worth build js 1.8.5?
https://developer.mozilla.org/en/javascript
From mercurial repository http://hg.mozilla.org/mozilla-central/ ?
Comment 5 Christopher Aillon 2011-02-11 14:00:00 EST
Yeah, to be honest, I think building a 1.8.5 snapshot would actually be a great idea.  Though I'd suggest either waiting until a final FF 4.0 release, or building a snap now and then updating it when FF 4.0 is released.
Comment 6 Christopher Aillon 2011-02-11 16:18:18 EST
Actually, since we just branched F-15 off of rawhide, maybe it makes sense to update to a recent snapshot in rawhide first, let consumers such as mongodb, etc verify everything's fine, and then push it to F-15.
Comment 7 Pavel Alexeev 2011-02-12 04:52:07 EST
Off course I prepare now all changes and then make announce in devel ML for dependent package maintiners.
And off course It will in rawhide only first.
Comment 8 Pavel Alexeev 2011-02-16 09:21:05 EST
I have compleated built it in rawhide (in scratch now) - http://koji.fedoraproject.org/koji/taskinfo?taskID=2841219

But I also have several issues there:
Bundled software (libs):
1) They can be deleted in %prep:
src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8

2) But that:
src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
can not be deleted - build failed.

In most cases it is BSD license wich is compatable with GPL, but in our license page nothing say also about compatability with LGPL and others...

I don't know what to do now.
Comment 9 Pavel Alexeev 2011-02-20 13:21:15 EST
It think I can't make decision about licensing now.
Please, Spot can you solve it? Can we use such files in build and what license should be for package?
Comment 10 Colin Walters 2011-04-05 13:27:08 EDT
https://developer.mozilla.org/en/SpiderMonkey/1.8.5
Comment 11 Pavel Alexeev 2011-04-06 13:55:15 EDT
I'he build it in scratch mode:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2978943

But we still have the same licensing question to Spot.
Comment 12 Christopher Aillon 2011-04-06 14:10:42 EDT
Can you make it clearer what the license question is, and why you think it applies to this package but not Firefox, which presumably has the same sources?
Comment 13 Pavel Alexeev 2011-04-06 16:45:02 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=676441#c8

I'm not maintainer of Firefox.
Comment 14 Tom "spot" Callaway 2011-04-06 16:52:33 EDT
BSD (without advertising) is considered compatible with both GPL and LGPL, so I don't see an issue here.
Comment 15 Pavel Alexeev 2011-04-06 17:01:28 EDT
Can we safely bundle these files? Should it change package license on any manner like "GPLv2+ and BSD"?
Comment 16 Pavel Alexeev 2011-04-08 07:25:40 EDT
As there no answer I think it is not problem with licence (but It very strange for me meantime).

So all commited and built.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2983697
Comment 17 Christopher Aillon 2011-04-11 22:50:01 EDT
I think we also need this in F15.  See bug 676437.
Comment 18 Fedora Update System 2011-04-12 11:35:11 EDT
js-1.8.5-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/js-1.8.5-3.fc15
Comment 19 Pavel Alexeev 2011-04-12 11:37:42 EDT
Ok. Please test.

For dependencies on it be careful - epoch 1 used.
Comment 20 Christopher Aillon 2011-04-12 13:27:40 EDT
Created attachment 491531 [details]
devel subpackage needs to ask for the newly added epoch

(In reply to comment #19)
> Ok. Please test.
> 
> For dependencies on it be careful - epoch 1 used.

You too :-)  js-devel won't install since it requires the main package without the epoch.  I intentionally left the virtual provides of libjs{,-devel} alone.

Patch attached.  Please apply with

  git am 0001-devel-subpackage-needs-to-ask-for-the-newly-added-ep.patch
Comment 21 Christopher Aillon 2011-04-12 20:05:02 EDT
Since I want to play with getting gjs built against this package, I just went ahead and committed the above change and built it in rawhide and f15.  At least now -devel can be installed.

I wasn't sure if you wanted the virtual provides to be just an API level provide in which case the epoch isn't needed, or if you actually want it to get an epoch bump, so I'll leave that up to you.
Comment 22 Pavel Alexeev 2011-04-13 06:29:30 EDT
Ok, thanks for help.
Comment 23 Pavel Alexeev 2011-04-13 06:31:24 EDT
And epoch was added only to allow transition update 1.70 to 1.8.5, as 1.70 treated as greater version then 1.8.5, and I do not willing mangle upstream version enumeration to anything like 1.85 or so on...
Comment 24 Pavel Alexeev 2011-04-14 07:28:39 EDT
Oh, Christopher, why you do not push update for 1.8.5-4 to Fedora 15?? Is it intensionally, or I could do that??
Comment 25 Pavel Alexeev 2011-04-14 07:38:59 EDT
But kdudka in update reported that there no enough symbols present (https://admin.fedoraproject.org/updates/js-1.8.5-3.fc15).

So, we can't update this update to do not provide some capability layer or keep 2 versions of library stimulation.
Comment 26 Christopher Aillon 2011-04-14 11:10:41 EDT
(In reply to comment #24)
> Oh, Christopher, why you do not push update for 1.8.5-4 to Fedora 15?? Is it
> intensionally, or I could do that??

Because I expected we'd need to do rebuilds.  In fact, I didn't notice that you pushed an update, I would have expected things to fail since they'd need to be rebuilt at the very least for the change in UTF8 foo.  I already sent mail to you privately that we're going to do those rebuilds.  When they are done, we'll submit the update.
Comment 27 Pavel Alexeev 2011-04-14 12:15:03 EDT
Rebuilds is not single what necessary there. As we have fully incompatible stack.
It is my mistake, I had not read mozilla page carefully (really I had not read at at all, just grab url of new sources). Sorry to all.

So, now we have one chance got it In Fedora - add as separate library which does not conflict with old one.

There two options:
1) Add to package 2 sources and build and install both versions.
2) Make separate RPM package and name it something like js185, or js18, or may be mozjs (most preferable in on my choose). In this case separate review needed.

I think second is most correct way, and previous builds even in rawhide must be reverted.
If you want, I ready make such package and submit it on review.
Comment 28 Christopher Aillon 2011-04-14 12:19:42 EDT
I know that we need code updates, not just rebuilds.  We have patches for couchdb and elinks already.  Working on the others.
Comment 29 Pavel Alexeev 2011-04-14 12:20:12 EDT
*** Bug 696673 has been marked as a duplicate of this bug. ***
Comment 30 Pavel Alexeev 2011-04-14 12:21:26 EDT
You plan patch all dependencies?
Comment 31 Christopher Aillon 2011-04-14 12:27:04 EDT
(In reply to comment #30)
> You plan patch all dependencies?

I really wish you'd have read the email I sent you two days ago...  :-(

Yes.  The full list is not that big, we'll patch them all and submit the update afterward.
Comment 32 Pavel Alexeev 2011-04-15 03:28:12 EDT
*** Bug 696825 has been marked as a duplicate of this bug. ***
Comment 33 Pavel Alexeev 2011-04-15 03:49:29 EDT
Sorry, I found it.
I answer you by mail.
Comment 34 Kamil Dudka 2011-04-19 17:43:37 EDT
An upstream patch for elinks has just appeared in their git repo:

http://repo.or.cz/w/elinks.git/commitdiff/2844f8b

What is the current state of this bug?
Comment 35 Christopher Aillon 2011-04-19 17:56:56 EDT
Cool.  I know there are patches for erlang-js and callweaver already in Fedora.  And I think jhorak has a patch floating around for couchdb, and stransky's working on another package.  Not too many more packages left, so I'd say let's get elinks built with that patch!
Comment 36 Ondrej Vasik 2011-04-20 07:57:44 EDT
Well  - upstream comment about elinks patch is "It compiles, but not tested" ... I really don't like this API breakage so late in release cycle. 

If spidermonkey > 1.8 will be used in f15 (and it really seems so), maybe better way would be to disable js-devel buildrequires in elinks - at least for a while ... and to try get it stable before pushing f15 update with reenabled js support.
Comment 37 Kamil Dudka 2011-04-21 10:25:50 EDT
I have cloned this bug for elinks - bug 698679 - and prepared a rawhide build of elinks against js-1.8.5.  I am not sure how to test that it works properly, tried to enable ECMASCript, which is disabled by default, and went though some web pages.  It did not crash.
Comment 38 Kamil Dudka 2011-05-01 08:00:25 EDT
Is js-1.8.5 still going to appear in f15?

I am able to build elinks against it using the upstream patches, but such a build will not be installable against the old version of js.
Comment 39 Fedora Update System 2011-05-10 02:10:46 EDT
mongodb-1.8.0-3.fc15, mediatomb-0.12.1-10.fc15, gxine-0.5.905-6.fc15, erlang-js-0.5.0-4.fc15, couchdb-1.0.2-2.fc15, callweaver-1.2.1-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mongodb-1.8.0-3.fc15,mediatomb-0.12.1-10.fc15,gxine-0.5.905-6.fc15,erlang-js-0.5.0-4.fc15,couchdb-1.0.2-2.fc15,callweaver-1.2.1-9.fc15
Comment 40 Fedora Update System 2011-05-11 01:49:17 EDT
Package mongodb-1.8.0-3.fc15, mediatomb-0.12.1-10.fc15, gxine-0.5.905-6.fc15, erlang-js-0.5.0-4.fc15, couchdb-1.0.2-2.fc15, callweaver-1.2.1-9.fc15, elinks-0.12-0.25.pre5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mongodb-1.8.0-3.fc15 mediatomb-0.12.1-10.fc15 gxine-0.5.905-6.fc15 erlang-js-0.5.0-4.fc15 couchdb-1.0.2-2.fc15 callweaver-1.2.1-9.fc15 elinks-0.12-0.25.pre5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/elinks-0.12-0.25.pre5.fc15,mongodb-1.8.0-3.fc15,mediatomb-0.12.1-10.fc15,gxine-0.5.905-6.fc15,erlang-js-0.5.0-4.fc15,couchdb-1.0.2-2.fc15,callweaver-1.2.1-9.fc15
then log in and leave karma (feedback).
Comment 41 Kamil Dudka 2011-05-11 03:04:10 EDT
(In reply to comment #40)
> Package mongodb-1.8.0-3.fc15, mediatomb-0.12.1-10.fc15, gxine-0.5.905-6.fc15,
> erlang-js-0.5.0-4.fc15, couchdb-1.0.2-2.fc15, callweaver-1.2.1-9.fc15,
> elinks-0.12-0.25.pre5.fc15:
> * should fix your issue,

No js package here ^^^.  Switching back to MODIFIED.
Comment 42 Fedora Update System 2011-05-13 23:07:47 EDT
Package mongodb-1.8.0-3.fc15, mediatomb-0.12.1-10.fc15, gxine-0.5.905-6.fc15, erlang-js-0.5.0-4.fc15, couchdb-1.0.2-2.fc15, callweaver-1.2.1-9.fc15, elinks-0.12-0.25.pre5.fc15, js-1.8.5-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mongodb-1.8.0-3.fc15 mediatomb-0.12.1-10.fc15 gxine-0.5.905-6.fc15 erlang-js-0.5.0-4.fc15 couchdb-1.0.2-2.fc15 callweaver-1.2.1-9.fc15 elinks-0.12-0.25.pre5.fc15 js-1.8.5-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/js-1.8.5-4.fc15,elinks-0.12-0.25.pre5.fc15,mongodb-1.8.0-3.fc15,mediatomb-0.12.1-10.fc15,gxine-0.5.905-6.fc15,erlang-js-0.5.0-4.fc15,couchdb-1.0.2-2.fc15,callweaver-1.2.1-9.fc15
then log in and leave karma (feedback).
Comment 43 Thomas Vander Stichele 2011-05-18 11:20:16 EDT
I just filed https://bugzilla.redhat.com/show_bug.cgi?id=705816
which is a segfault that seems the consequence of the js update to 1.8.5
it works against the previous couchdb/js package.
Comment 44 Peter Lemenkov 2011-05-26 08:17:08 EDT
*** Bug 707544 has been marked as a duplicate of this bug. ***
Comment 45 Peter Lemenkov 2011-05-30 10:46:32 EDT
*** Bug 708720 has been marked as a duplicate of this bug. ***
Comment 46 Fedora Update System 2011-05-30 18:34:53 EDT
mongodb-1.8.0-3.fc15, mediatomb-0.12.1-10.fc15, gxine-0.5.905-6.fc15, erlang-js-0.5.0-4.fc15, callweaver-1.2.1-9.fc15, elinks-0.12-0.25.pre5.fc15, js-1.8.5-4.fc15, couchdb-1.0.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.