Bug 697168 - (qwt6) qwt-6.0.1 is available
qwt-6.0.1 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qwt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 837849 (view as bug list)
Depends On: qwt5
Blocks: 729078 F18Target-kde
  Show dependency treegraph
 
Reported: 2011-04-16 06:58 EDT by Upstream Release Monitoring
Modified: 2012-12-20 10:43 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:43:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Qwt specfile patch: update from 5.2.2 to 6.0.1 (2.21 KB, patch)
2012-03-20 12:29 EDT, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2011-04-16 06:58:23 EDT
Latest upstream release: 6.0.0
Current version in Fedora Rawhide: 5.2.1
URL: http://sourceforge.net/projects/qwt/files/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Fedora Admin XMLRPC Client 2011-06-21 13:47:18 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Upstream Release Monitoring 2011-08-01 06:44:19 EDT
Latest upstream release: 5.2.2
Current version in Fedora Rawhide: 5.2.1
URL: http://sourceforge.net/projects/qwt/files/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Upstream Release Monitoring 2011-08-03 06:38:58 EDT
Latest upstream release: 6.0.1
Current version in Fedora Rawhide: 5.2.1
URL: http://sourceforge.net/projects/qwt/files/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 4 Bruno Matos 2011-11-29 05:31:22 EST
Hi,

Are there any plans to add version 6.0.1 to fedora 15 repos?

Thank you.
Comment 5 Jose Pedro Oliveira 2012-03-20 12:29:38 EDT
Created attachment 571468 [details]
Qwt specfile patch: update from 5.2.2 to 6.0.1

Rex Dieter, 

The attached patch updates the qwt package to version 6.0.1. It may need a couple of corrections as I haven't much experience in packaging GUI related libraries/applications.

Notes:
 * upstream no longer ships man pages in the doc sub-directory
 * it no longer patches qwt files; it overrides paths in the qmake command line
 * dropped "CONFIG+=QwtSVGItem"
   (not sure if this is needed)
 * it installs a couple of files in %{_datadir}/%{name}
   (not sure if this is the better location for them).

Regards,
jpo
Comment 6 Rex Dieter 2012-03-20 16:35:29 EDT
Last I checked, pykde4 bindings still did not support qwt >= 6, but I'll try to double check.

On the other hand, it's not entirely fair to block updating qwt indefinitely on pykde4.

I'll try to recheck the situation soon.
Comment 7 Rex Dieter 2012-07-05 11:16:01 EDT
*** Bug 837849 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2012-07-31 12:45:56 EDT
first attempt at some parallel-installable qwt5/qwt(6) rpms:
http://rdieter.fedorapeople.org/rpms/qwt/

doing some build/run time testing
Comment 9 Rex Dieter 2012-10-19 11:11:01 EDT
With qwt5 review finally done and imported, got qwt-6.0.1 updated into rawhide today.

will do a small bit of testing and (re)builds, before working on f18...
Comment 10 Fedora Update System 2012-10-22 11:05:46 EDT
qwt-6.0.1-1.fc18,qwt5-5.2.2-21.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qwt-6.0.1-1.fc18,qwt5-5.2.2-21.fc18
Comment 11 Fedora Update System 2012-10-23 02:46:25 EDT
Package qwt-6.0.1-1.fc18, qwt5-5.2.2-21.fc18, PyQwt-5.2.0-19.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qwt-6.0.1-1.fc18 qwt5-5.2.2-21.fc18 PyQwt-5.2.0-19.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16708/PyQwt-5.2.0-19.fc18,qwt-6.0.1-1.fc18,qwt5-5.2.2-21.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-12-20 10:43:06 EST
qwt-6.0.1-1.fc18, qwt5-5.2.2-21.fc18, PyQwt-5.2.0-19.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.