This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 69738 - pegasus usb ethernet device not configured on reinsertion
pegasus usb ethernet device not configured on reinsertion
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-24 17:27 EDT by Mike McLean
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 14:46:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
section of /var/log/messages (3.83 KB, text/plain)
2002-07-24 17:35 EDT, Mike McLean
no flags Details

  None (edit)
Description Mike McLean 2002-07-24 17:27:28 EDT
* Milan-re0724.nightly
* kernel-2.4.8-7.80

In the initial insertion of the usb device everything goes well. (Well except
for an extraneous message on the console).  The module inserts, the device
works, and everything is happy.

If you unplug the device things also work as expected.  The ethernet device
disappears and life moves on.

BUT, if you then reinsert the device nothing happens (well the kernel detects
it, but the driver apparently does nothing).  No ethernet device appears.

otoh, if you rmmod pegasus before reinsertion, then things go smoothly.
Comment 1 Mike McLean 2002-07-24 17:35:05 EDT
see bug 69739 for details on the extraneous console messages.

The device in question is a Belkin F5D5050 USB Ethernet Adapter.
Comment 2 Mike McLean 2002-07-24 17:35:49 EDT
Created attachment 66865 [details]
section of /var/log/messages
Comment 3 Mike McLean 2002-07-24 17:45:42 EDT
I took the following actions during this syslog:

% insmod dummy   (testing something else)
% rmmod dummy
% ifdown eth0
(insert device)
% ifdown eth2 
% ifup eth2
% ping hank   (successful)
% ifdown eth2
(remove device)
% rmmod pegasus
(reinsert device)
% ping hank   (successful)
% ifdown eth2
(remove device)
(reinsert device)
% ip link list  (no eth2 visible)
Comment 4 Pete Zaitcev 2003-10-06 19:15:08 EDT
How is the situation now (RHL 9 w/ 2.4.20-20.9)?

Comment 5 Pete Zaitcev 2004-04-19 14:46:46 EDT
This was needinfo-ed since last October, Mike. I'll just close
for now then.
Comment 6 Mike McLean 2004-04-19 15:21:26 EDT
fwiw, this seems to be fixed in FC1.

Note You need to log in before you can comment on or make changes to this bug.