Bug 69739 - extraneous messages on pegasus usb ethernet insertion
Summary: extraneous messages on pegasus usb ethernet insertion
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-24 21:32 UTC by Mike McLean
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 18:47:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McLean 2002-07-24 21:32:58 UTC
* Milan-re0724.nightly
* kernel-2.4.8-7.80

When you insert the usb ethernet device, some extraneous messages appear on the
console.

kernel: usb.c: USB device 2 (vend/prod 0x50d/0x121) is not claimed by any active
driver.

And if there is an ifcfg-eth? file for the device, you also get:

kernel: pegasus.c: eth2: link NOT established (0x7849) - check the cable.

even though the connection does work.

The device is a Belkin F5D5050.

Comment 1 Pete Zaitcev 2002-07-24 22:05:29 UTC
Sure, I can take that. But I do not see how this can be helped,
honestly.

The first message appears when the device is connected, and
before the hotplug had a chance to work and load pegasus driver.
If we block khubd until the hotplug finishes, it's going to
give us a lot of grief with hanging.

Second one is annoying, because it seems like a pegasus's fault.
Surely it should be capable of waiting a little before complaining
about the missing link beat. It can be changed, but I'd rather not.
Too easy to fix the requestor's issue, but blow up it for someone
else (like with USB serial last time).


Comment 2 Mike McLean 2002-07-25 20:19:39 UTC
also see bug 69738

Comment 3 Mike McLean 2004-04-19 19:23:24 UTC
fwiw, this seems to be fixed in FC1


Note You need to log in before you can comment on or make changes to this bug.