Bug 697649 - Sugar Wireless Networking broken by NetworkManager 0.9 API
Sugar Wireless Networking broken by NetworkManager 0.9 API
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
15
All Linux
urgent Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F15Blocker-sugar
  Show dependency treegraph
 
Reported: 2011-04-18 16:17 EDT by Peter Robinson
Modified: 2011-09-17 07:55 EDT (History)
14 users (show)

See Also:
Fixed In Version: sugar-0.92.4-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-13 01:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
./desktop/meshbox.py (1.39 KB, patch)
2011-05-24 08:17 EDT, John Dulaney
jdulaney: review+
Details | Diff
/desktop/networkviews.py (5.10 KB, patch)
2011-05-24 08:17 EDT, John Dulaney
no flags Details | Diff
/deviceicon/network.py (9.49 KB, patch)
2011-05-24 08:18 EDT, John Dulaney
no flags Details | Diff
/model/adhoc.py (1.09 KB, patch)
2011-05-24 08:19 EDT, John Dulaney
no flags Details | Diff
/model/network.py (7.98 KB, patch)
2011-05-24 08:19 EDT, John Dulaney
no flags Details | Diff
/model/olpcmesh.py (3.32 KB, patch)
2011-05-24 08:20 EDT, John Dulaney
no flags Details | Diff
New /model/network.py (8.46 KB, patch)
2011-05-26 01:56 EDT, John Dulaney
no flags Details | Diff

  None (edit)
Description Peter Robinson 2011-04-18 16:17:50 EDT
The networking component of Sugar has been broken by the changes to the NetworkManager API.

The networking seems to marginally work when used with Wired networking but there still seems to be some regressions.

This makes the Sugar on a Stick spin pretty broken for the general use case scenario on NetBooks and similar style devices. 


1302106345.980828 ERROR dbus.connection: Unable to set arguments ('org.freedesktop.NetworkManagerUserSettings', '/org/freedesktop/NetworkManagerSettings/0', dbus.ObjectPath('/org/freedesktop/NetworkManager/Devices/1'), '/') according to signature u'ooo': <type 'exceptions.TypeError'>: Fewer items found in D-Bus signature than in Python arguments
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 391, in _introspect_reply_handler
    self._introspect_execute_queue()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 378, in _introspect_execute_queue
    proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 132, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 566, in call_async
    message.append(signature=signature, *args)
TypeError: Fewer items found in D-Bus signature than in Python arguments
/usr/lib/python2.7/site-packages/sugar/graphics/palette.py:378: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.menu.embed(self._menu_box)
/usr/lib/python2.7/site-packages/sugar/graphics/palette.py:375: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.menu.unembed()
1302106352.072300 ERROR dbus.connection: Unable to set arguments ('org.freedesktop.NetworkManagerUserSettings', '/org/freedesktop/NetworkManagerSettings/0', dbus.ObjectPath('/org/freedesktop/NetworkManager/Devices/1'), '/') according to signature u'ooo': <type 'exceptions.TypeError'>: Fewer items found in D-Bus signature than in Python arguments
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 391, in _introspect_reply_handler
    self._introspect_execute_queue()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 378, in _introspect_execute_queue
    proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 132, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 566, in call_async
    message.append(signature=signature, *args)
TypeError: Fewer items found in D-Bus signature than in Python arguments
1302106355.853311 ERROR dbus.connection: Unable to set arguments ('org.freedesktop.NetworkManagerUserSettings', '/org/freedesktop/NetworkManagerSettings/0', dbus.ObjectPath('/org/freedesktop/NetworkManager/Devices/1'), '/') according to signature u'ooo': <type 'exceptions.TypeError'>: Fewer items found in D-Bus signature than in Python arguments
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 391, in _introspect_reply_handler
    self._introspect_execute_queue()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 378, in _introspect_execute_queue
    proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 132, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 566, in call_async
    message.append(signature=signature, *args)
TypeError: Fewer items found in D-Bus signature than in Python arguments
1302106365.354448 ERROR dbus.connection: Unable to set arguments ('org.freedesktop.NetworkManagerUserSettings', '/org/freedesktop/NetworkManagerSettings/0', dbus.ObjectPath('/org/freedesktop/NetworkManager/Devices/1'), '/') according to signature u'ooo': <type 'exceptions.TypeError'>: Fewer items found in D-Bus signature than in Python arguments
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 586, in msg_reply_handler
    reply_handler(*message.get_args_list(**get_args_opts))
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 391, in _introspect_reply_handler
    self._introspect_execute_queue()
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 378, in _introspect_execute_queue
    proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 132, in __call__
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 566, in call_async
    message.append(signature=signature, *args)
TypeError: Fewer items found in D-Bus signature than in Python arguments
/usr/lib/python2.7/site-packages/jarabe/desktop/homewindow.py:177: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.add(self._home_box)
Comment 1 Peter Robinson 2011-04-18 18:53:23 EDT
Note Wired works at least in a KVM wired network environment. USB 3G modem connectivity not yet tested.
Comment 2 James Laska 2011-04-21 16:00:13 EDT
Discussed at 2011-04-21 blocker review meeting (http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-21/f15-blocker-review.2011-04-21-17.00.html) ...

AGREED: 697649 - AcceptedNTH - desktop issue affecting non-default desktop
Comment 3 Adam Williamson 2011-05-06 12:50:13 EDT
Move to the Sugar tracker.

Peter, as discussed via email, note that the NM 0.8 interface is in fact available in NM 0.9, this was done for knetworkmanager. I'd imagine KK could give you some pointers on the adjustments necessary to use the 0.8 compat API in 0.9. Adding him to CC.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Kevin Kofler 2011-05-06 13:18:07 EDT
(I'm changing the CC to the e-mail address set in FAS.)

The main limitation of the 0.8 compat API is that it only supports the exact feature set supported by the kde-plasma-networkmanagement-20110323 snapshot, anything else (e.g. system connections, bluetooth tethering) is just not supported.

The patches to support the compatibility API have been written by Dan Williams. The current patches we use can be found at:
http://pkgs.fedoraproject.org/gitweb/?p=kdebase-workspace.git;a=blob;f=kdebase-workspace-4.6.1-nm-09-compat.patch;hb=HEAD
http://pkgs.fedoraproject.org/gitweb/?p=kde-plasma-networkmanagement.git;a=blob;f=nm-09-compat.patch;hb=HEAD

I haven't really looked at those patches in detail though.
Comment 5 John Dulaney 2011-05-24 08:15:58 EDT
Ok, sorry I'm late with this.

I'll be attaching the individual *.py files, including those that I did not modify.  I used (1) as my primary reference in figuring this stuff out.




(1) http://projects.gnome.org/NetworkManager/developers/migrating-to-09/ref-migrating.html
Comment 6 John Dulaney 2011-05-24 08:17:18 EDT
Created attachment 500597 [details]
./desktop/meshbox.py
Comment 7 John Dulaney 2011-05-24 08:17:55 EDT
Created attachment 500598 [details]
/desktop/networkviews.py
Comment 8 John Dulaney 2011-05-24 08:18:31 EDT
Created attachment 500599 [details]
/deviceicon/network.py
Comment 9 John Dulaney 2011-05-24 08:19:13 EDT
Created attachment 500601 [details]
/model/adhoc.py
Comment 10 John Dulaney 2011-05-24 08:19:47 EDT
Created attachment 500602 [details]
/model/network.py
Comment 11 John Dulaney 2011-05-24 08:20:54 EDT
Created attachment 500603 [details]
/model/olpcmesh.py
Comment 12 Peter Robinson 2011-05-24 08:43:32 EDT
Thanks John! Most awesome. I'll create a patch from them this evening and then provide a test rpm linked here.
Comment 13 Peter Robinson 2011-05-24 18:26:18 EDT
initial test build here http://koji.fedoraproject.org/koji/taskinfo?taskID=3089758
Comment 14 John Dulaney 2011-05-24 18:49:47 EDT
Peter, is it running for you alright?  It works on my box, so I'm hopeful.
Comment 15 Peter Robinson 2011-05-24 19:05:15 EDT
(In reply to comment #14)
> Peter, is it running for you alright?  It works on my box, so I'm hopeful.

partially, but I'm not un sure its not my netbook, I need to do some more testing. If you hit F1 to get to the "neighbourhood" do you see a collection of APs in range? I'm not seeing any, the rest is looking good though :)

Thanks.
Comment 16 Peter Robinson 2011-05-24 19:06:41 EDT
I had a problem with a couple of the patches (the network.py files) so I also need to double check I didn't miss anything as part of the manual merge I did.
Comment 17 John Dulaney 2011-05-24 20:17:18 EDT
What sort of problem?

I have had no issues finding APs, but I'll go back over the code.
Comment 18 Adam Williamson 2011-05-25 02:26:52 EDT
well, I built a live image with that sugar package and it flat doesn't boot, gets stuck at what looks like the end of the boot sequence, error 'sed: can't read /etc/rc.d/init.d/halt: No such file or directory' looks odd.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2011-05-25 02:32:31 EDT
actually, after I wait a long time (5 mins or so?) for something to time out I guess it finally boots; I then get gdm, get prompted for a keyring passphrase, get an error window about a keyring three times, and find that on f1 screen I don't see any APs.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Peter Robinson 2011-05-25 04:12:00 EDT
(In reply to comment #19)
> actually, after I wait a long time (5 mins or so?) for something to time out I
> guess it finally boots; I then get gdm, get prompted for a keyring passphrase,
> get an error window about a keyring three times, and find that on f1 screen I
> don't see any APs.

I'm getting the later bit and I was afraid its been broken somehow. I wasn't getting the 5 min boot bit.

I was the later half. In the case of the passphrase its due to the livesys script hitting an exit part way through. I didn't think I changed that bit of the script but it could be that some variable that was previously depended upon disappeared. I need to check my changes overall.
Comment 21 satellitgo 2011-05-25 10:40:33 EDT
see: https://bugzilla.redhat.com/show_bug.cgi?id=702481 also
Comment 22 John Dulaney 2011-05-25 11:33:26 EDT
Alright, I think I know why there are no APs showing up (and why I got them).  It would seem that if one doesn't make a clean install, AP's that have been previously connected to are automatically connected.

I'll try to get a fix done tonight.

/me apologizes.

Adam or Peter, do you think the keyring issue might be dealing with my code?  If so, I'll try to figure out what's going on there, too.
Comment 23 Peter Robinson 2011-05-25 12:29:41 EDT
(In reply to comment #22)
> Alright, I think I know why there are no APs showing up (and why I got them). 
> It would seem that if one doesn't make a clean install, AP's that have been
> previously connected to are automatically connected.
> 
> I'll try to get a fix done tonight.
> 
> /me apologizes.

No issues!

> Adam or Peter, do you think the keyring issue might be dealing with my code? 
> If so, I'll try to figure out what's going on there, too.

No, its completely separate .
Comment 24 John Dulaney 2011-05-26 01:56:06 EDT
Created attachment 500984 [details]
New /model/network.py
Comment 25 Adam Williamson 2011-05-27 18:35:57 EDT
it looks like that network.py was already in the patch I tested on the 24th, right? it's not something new that might fix the problems?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Peter Robinson 2011-05-27 18:51:50 EDT
(In reply to comment #25)
> it looks like that network.py was already in the patch I tested on the 24th,
> right? it's not something new that might fix the problems?

It should be changed. I'm going to produce another package and fix the live cd issues tomorrow morning and publish a test livecd
Comment 27 Adam Williamson 2011-05-27 19:08:08 EDT
ah OK. I'll hang tight for that then.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 John Dulaney 2011-05-28 14:53:36 EDT
Adam, it is indeed changed.  I THINK that I've got everything covered, but we'll see once testing happens.  Right now I am discovering new networks on my system.
Comment 29 Adam Williamson 2011-05-31 15:14:44 EDT
I tried it with John's changed network.py copy/pasted into the patch, but still doesn't seem to work here. iwlist wlan0 scan returns results, but f1 screen doesn't show them.
Comment 30 Fedora Update System 2011-09-11 08:20:32 EDT
sugar-0.92.4-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/sugar-0.92.4-2.fc15
Comment 31 Fedora Update System 2011-09-11 17:49:18 EDT
Package sugar-0.92.4-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sugar-0.92.4-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/sugar-0.92.4-2.fc15
then log in and leave karma (feedback).
Comment 32 satellitgo 2011-09-12 08:51:41 EDT
TESTED SUCESSFULLY
Done on

http://wiki.sugarlabs.org/go/Community/Distributions/Fedora-SoaS#Soas-v5-Coconut-Test.28git.29_Remix

This is Remix built to test Soas-v5
08/01/2011 built on f15 gnome3-shell
sugar-terminal: 
su -c 'yum update --enablerepo=updates-testing sugar-0.92.4-2.fc15'

No f1 AP's

cp/about me change color restart

Wireless AP and Ad-hoc AP's appear

starts on Ad-hoc Network 1 click on My Wireless AP: answer asci wep passphrase;
connected fine
Comment 33 satellitgo 2011-09-12 16:10:13 EDT
Tested on new SoaSv5-20110912 versions:

 http://fedora.roving-it.com/SoaSv5-20110912-i686.iso [1]
 http://fedora.roving-it.com/SoaSv5-20110912-x86-64.iso

I am finding that Wireless AP connects but does not see avitars or Ad-hoc AP's on jabber if wired connection is not connected on boot. (right frame icon shows Ad-hoc 1 Connecting then connected in about 1 minute +) Once this occurs; f1 Neighborhood appears and by disconnecting from Ad-hoc 1 It is possible to connect to Wireless AP
Surf and IRC connect on Wireless AP (no wired connection)
once one of these is started. Jabber shows avitars
This whole process takes about 3 minutes and would cause some users to lose patience, thinking wireless was unavailable. tested on [1]

Also on restart of live CD (CP/About Me Color change-restart)
it does not show  ( ) on AP Icon autoconnect to previous AP (like previous versions) though it does show ( ) on the right bottom frame.
redo:Surf and IRC connect on Wireless AP (no wired connection)
once one of these is started.( ) appear on f1 AP  Jabber avitars do not return. Tested for over 10 minutes.

testing continues on [2] atm
Comment 34 satellitgo 2011-09-12 16:42:33 EDT
(In reply to comment #33)
> Tested on new SoaSv5-20110912 versions:
> 
>  http://fedora.roving-it.com/SoaSv5-20110912-i686.iso [1]
>  http://fedora.roving-it.com/SoaSv5-20110912-x86-64.iso [2]
> 
> I am finding that Wireless AP connects but does not see avitars or Ad-hoc AP's
> on jabber if wired connection is not connected on boot. (right frame icon shows
> Ad-hoc 1 Connecting then connected in about 1 minute +) Once this occurs; f1
> Neighborhood appears and It is possible to connect to Wireless AP
> Surf and IRC connect on Wireless AP (no wired connection)
> once one of these is started. Jabber shows avitars
> This whole process takes about 3 minutes and would cause some users to lose
> patience, thinking wireless was unavailable. tested on [1]
> 
> Also on restart of live CD (CP/About Me Color change-restart)
> it does not show  ( ) on AP Icon autoconnect to previous AP (like previous
> versions) though it does show ( ) on the right bottom frame.
> redo:Surf and IRC connect on Wireless AP (no wired connection)
> once one of these is started.( ) appear on f1 AP  Jabber avitars do not return.
> Tested for over 10 minutes.
> 
> testing on [2] with no wired connection :
(elapsed time)
frame icon grey circle 45 sec
Ad-hoc connects 1 min
f1 connect to AP 2 min
Jabber up in 7 minutes
retesting [1]atm
Comment 35 satellitgo 2011-09-12 16:57:13 EDT
(In reply to comment #34)
> (In reply to comment #33)
> > Tested on new SoaSv5-20110912 versions:
> > 
> >  http://fedora.roving-it.com/SoaSv5-20110912-i686.iso [1]
> >  http://fedora.roving-it.com/SoaSv5-20110912-x86-64.iso [2]
> > 
> > I am finding that Wireless AP connects but does not see avitars or Ad-hoc AP's
> > on jabber if wired connection is not connected on boot. (right frame icon shows
> > Ad-hoc 1 Connecting then connected in about 1 minute +) Once this occurs; f1
> > Neighborhood appears and It is possible to connect to Wireless AP
> > Surf and IRC connect on Wireless AP (no wired connection)
> > once one of these is started. Jabber shows avitars
> > This whole process takes about 3 minutes and would cause some users to lose
> > patience, thinking wireless was unavailable. tested on [1]
> > 
> > Also on restart of live CD (CP/About Me Color change-restart)
> > it does not show  ( ) on AP Icon autoconnect to previous AP (like previous
> > versions) though it does show ( ) on the right bottom frame.
> > redo:Surf and IRC connect on Wireless AP (no wired connection)
> > once one of these is started.( ) appear on f1 AP  Jabber avitars do not return after 10 minutes-(Not retested)
> > 
> > testing on [2] with no wired connection :
> (elapsed time)
> frame icon grey circle 45 sec
> Ad-hoc connects 1 min
> f1 connect to AP 2 min
> Jabber up in 7 minutes
> retesting [1]atm
Same behavior seen on [2]
starting surf and/or irc not required for jabber
Comment 36 satellitgo 2011-09-12 21:27:51 EDT
Tested on last f15 nightly soas build
Fedora-15-Nightly-20110605.17-i686-Live-soas.iso
 (lots of old bugs show up*)
 *long wait for dbus before boot
 *keying problems
 su -c 'yum update --enablerepo=updates-testing sugar-0.92.4-2.fc15'
 0.92.1-3.fc15.noarch to 0.92.4-2.fc15.noarch
 cp/about me color change restart
 connects to wireless AP 
 disconnect wired connection
 cp/about me color change - restart
 shows AP ( ) on frame but not in f1
 surf starts
 jabber never connects on wireless only connection; works on wired
Comment 37 Fedora Update System 2011-09-13 01:50:40 EDT
sugar-0.92.4-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 38 satellitgo 2011-09-17 07:55:38 EDT
sugar 0.93.4-1 is in f16 networking works fine on wired connection
 jabber never connects on wireless only connection
shows Ad-hoc and wireless AP's connects fine

(Fedora-16-Nightly-20110916.10-i686-Live-desktop installed to USB with liveinst;
yum groupinstall sugar-desktop)

Note You need to log in before you can comment on or make changes to this bug.