Bug 69767 - Gedit can't save with Korean filename &....
Gedit can't save with Korean filename &....
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gedit (Show other bugs)
beta3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-25 01:48 EDT by David Joo
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 02:51:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Joo 2002-07-25 01:48:01 EDT
Description of Problem:
Gedit can't save a file with Korean filename.
Nor can't open files that has been created with touch and vi on gnome-terminal
(actually, it won't even show in "Open") And if you run gedit from terminal you
will be able to see an error message saying (Invalid Utf-8) with all other
strange chars.

Version-Release number of selected component (if applicable):


How Reproducible:
Always!

Steps to Reproduce:
1. Open a gnome-terminal
2. gedit &
3. type Korean (using Ami and shift+space)
4. try to save it with Korean filename (gksrmf-> in korean it will be "korean")

Actual Results:
The program will hang

Expected Results:
Saves it with Korean name and should be able to be seen on gnome-terminal with "ls"

Additional Information:
for not showing Korean directories and files that has been created with "touch",
"vi" and "mkdir" can be seen by;
#export G_BROKEN_FILENAMES=1
Comment 1 Owen Taylor 2002-08-13 19:20:27 EDT

*** This bug has been marked as a duplicate of 70228 ***
Comment 2 Owen Taylor 2002-08-13 19:22:29 EDT
(actually, I'm not *entirely* sure this is a duplicate; part of it
is, but it may not all be duplicate. Unfortunately, even with
G_BROKEN_FILENAMES set, gtkfilesel doesn't work very well with
non-UTF-8 fileanmes, and there is no way that is going be able
to be fixed in just a few days.)
Comment 3 Owen Taylor 2002-08-14 02:51:07 EDT
Reopening, after reproducing with G_BROKEN_FILENAMES set
Comment 4 Owen Taylor 2002-08-15 15:43:08 EDT
This was fixed in gedit-2.0.2.

Note You need to log in before you can comment on or make changes to this bug.