Bug 70228 - G_BROKEN_FILES=1?
Status: CLOSED DUPLICATE of bug 70686
Product: Red Hat Linux Beta
Classification: Retired
Component: glib (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Jay Turner
Depends On:
Blocks: 67218
  Show dependency treegraph
Reported: 2002-07-31 01:45 EDT by David Joo
Modified: 2015-01-07 18:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-13 21:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
set G_BROKEN_FILENAMES for CJK locales (872 bytes, patch)
2002-08-13 21:18 EDT, Paul Gampe
no flags Details | Diff

  None (edit)
Description David Joo 2002-07-31 01:45:04 EDT
Description of Problem:
Because CJK is not going to use UTF-8, there is problem showing file names and
directories in native languages.

Version-Release number of selected component (if applicable):

How Reproducible:

Steps to Reproduce:
1. creat a file in terminals (using native languages)
2. try to open it using gedit

Actual Results:
The filename or directory name is not shown

Expected Results:

Additional Information:
G_BROKEN_LANGUAGES=1 should be exported as default
Comment 1 Owen Taylor 2002-08-02 11:50:50 EDT
(Making public)
Comment 2 Owen Taylor 2002-08-13 19:20:22 EDT
*** Bug 69767 has been marked as a duplicate of this bug. ***
Comment 3 Paul Gampe 2002-08-13 21:18:16 EDT
Created attachment 70444 [details]
set G_BROKEN_FILENAMES for CJK locales
Comment 4 Paul Gampe 2002-08-13 21:21:43 EDT
The attached patch sets G_BROKEN_FILENAMES for the CJK locales.  I have  
confirmed that filenames created in native encoding via touch in 
gnome-terminal and gedit via file->save, are inter-operable and can be 
displayed via nautilus correctly.
Comment 5 Owen Taylor 2002-08-13 22:45:27 EDT
Havoc fixed this by installing  profile.d file that sets G_BROKEN_FILENAMES
(for all locales, doesn't matter for UTF-8 locales) from GLib ...
see bug #70686.

*** This bug has been marked as a duplicate of 70686 ***

Note You need to log in before you can comment on or make changes to this bug.