Bug 698020 - powertop complains about file
powertop complains about file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
: 751578 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-19 19:55 EDT by Mohammed Arafa
Modified: 2012-01-02 16:49 EST (History)
4 users (show)

See Also:
Fixed In Version: powertop-1.98-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-11 16:52:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.12 KB, patch)
2011-12-02 14:28 EST, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Mohammed Arafa 2011-04-19 19:55:35 EDT
Description of problem:
everytime i start powertop it complains like this:

Loaded 75 prior measurements
Cannot load from file /var/cache/powertop/saved_parameters.powertop

i checked the file. its there but it isnt.
ll /var/cache/powertop/saved_parameters.powertop
ls: cannot access /var/cache/powertop/saved_parameters.powertop: No such file or directory
[root@laptop powertop]# cd /var/cache/powertop/
[root@laptop powertop]# ll
total 92K
-rw-r--r-- 1 root root 92K Apr 19 19:47 saved_results.powertop

and
drwx------   2 root      root      4.0K Apr 19 19:00 powertop


Version-Release number of selected component (if applicable):

1.97
How reproducible:
everytime

Steps to Reproduce:
1.start powertop
2.quit to view full error message
3.
  
Actual results:
no idea if it is harmful to the program

Expected results:
no error messages

Additional info:
Comment 1 Mohammed Arafa 2011-04-19 20:11:19 EDT
ok - so the file is missing - why is powertop asking for a non-existent file ?
Comment 2 Phoenix 2011-11-30 20:26:11 EST
I have the problem too.
Comment 3 Jaroslav Škarvada 2011-12-02 13:25:28 EST
It seems you didn't run the initial calibration. If you are running on NB, disconnect AC and run:
# powertop --calibrate
Then let the powertop to collect enough data (approx. 1 hour). After then it will show approx. wattage for each process / device. When you exit, it saves its state and the message should gone.

It is only warning and it should be ignored, if it annoy you and you can't/don't want to run the calibration just:
# touch /var/cache/powertop/saved_parameters.powertop

Maybe the wording of the message is a bit confusing, I will forward this to upstream.
Comment 4 Jaroslav Škarvada 2011-12-02 13:27:49 EST
> It is only warning and it should be ignored

Of course s/should/can/
Comment 5 Jaroslav Škarvada 2011-12-02 14:28:13 EST
Created attachment 539750 [details]
Proposed patch
Comment 6 Fedora Update System 2011-12-02 15:08:24 EST
powertop-1.98-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/powertop-1.98-2.fc16
Comment 7 Fedora Update System 2011-12-02 15:10:54 EST
powertop-1.98-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/powertop-1.98-2.fc15
Comment 8 Fedora Update System 2011-12-03 21:40:02 EST
Package powertop-1.98-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing powertop-1.98-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16704/powertop-1.98-2.fc16
then log in and leave karma (feedback).
Comment 9 Jaroslav Škarvada 2011-12-07 05:09:53 EST
*** Bug 751578 has been marked as a duplicate of this bug. ***
Comment 10 Onuralp SEZER 2011-12-07 11:06:55 EST
Calibration Now Working Thank you

root@Fedora16Verne onuralp# powertop --calibrate
Loaded 0 prior measurements
Starting PowerTOP power estimate calibration 
Calibrating idle
Calibrating: disk usage 
Calibrating backlight
.... device /sys/class/backlight/intel_backlight/brightness 
.... device /sys/class/backlight/acpi_video0/brightness 
.... device /sys/class/backlight/acpi_video1/brightness 
.... device /sys/class/backlight/acpi_video2/brightness 
Calibrating idle
Calibrating: CPU usage on 1 threads
Calibrating: CPU usage on 4 threads
Calibrating: CPU wakeup power consumption
Calibrating: CPU wakeup power consumption
Calibrating: CPU wakeup power consumption
Calibrating USB devices
.... device /sys/bus/usb/devices/usb1/power/control 
.... device /sys/bus/usb/devices/usb2/power/control 
.... device /sys/bus/usb/devices/1-1/power/control 
.... device /sys/bus/usb/devices/2-1/power/control 
.... device /sys/bus/usb/devices/1-1.3/power/control 
.... device /sys/bus/usb/devices/1-1.4/power/control 
.... device /sys/bus/usb/devices/2-1.5/power/control 
.... device /sys/bus/usb/devices/2-1.1/power/control 
Calibrating radio devices
.... device /sys/class/rfkill/rfkill4/soft 
.... device /sys/class/rfkill/rfkill0/soft 
.... device /sys/class/rfkill/rfkill1/soft 
.... device /sys/class/rfkill/rfkill4/soft 
.... device /sys/class/rfkill/rfkill0/soft 
.... device /sys/class/rfkill/rfkill1/soft 
Finishing PowerTOP power estimate calibration 
Parameters after calibration:


Parameter state 
----------------------------------
Value		Name
 0.50		alsa-codec-power (15)
 0.00		backlight (4)
 0.00		backlight-boost-100 (8)
 0.00		backlight-boost-40 (6)
 0.00		backlight-boost-80 (7)
 0.00		backlight-power (5)
100.00		base power (45)
 1.56		cpu-consumption (3)
39.50		cpu-wakeups (2)
 0.00		disk-operations (48)
 0.20		disk-operations-hard (47)
 0.56		gpu-operations (46)
 0.00		p1p1-link-100 (21)
 0.00		p1p1-link-1000 (22)
 0.00		p1p1-link-high (23)
 0.00		p1p1-packets (24)
 0.00		p1p1-powerunsave (20)
 0.00		p1p1-up (19)
 0.00		radio:hci0 (16)
 0.00		radio:hp-wifi (17)
 0.00		radio:phy0 (18)
 0.00		runtime-0000:00:00.0 (31)
 0.00		runtime-0000:00:01.0 (32)
 0.00		runtime-0000:00:02.0 (33)
 0.00		runtime-0000:00:1a.0 (34)
 0.00		runtime-0000:00:1b.0 (35)
 0.00		runtime-0000:00:1c.0 (36)
 0.00		runtime-0000:00:1c.1 (37)
 0.00		runtime-0000:00:1d.0 (38)
 0.00		runtime-0000:00:1f.2 (39)
 0.00		runtime-0000:00:1f.3 (40)
 0.00		runtime-0000:00:1f.6 (41)
 0.00		runtime-0000:01:00.1 (42)
 0.00		runtime-0000:02:00.0 (43)
 0.00		runtime-0000:03:00.0 (44)
 0.10		usb-device-0408-03b2 (13)
 0.10		usb-device-046d-c526 (12)
 0.10		usb-device-12d1-1037 (14)
 0.10		usb-device-148f-1000 (11)
 0.10		usb-device-1d6b-0002 (9)
 0.10		usb-device-8087-0020 (10)
 0.00		wlan0-link-100 (27)
 0.00		wlan0-link-1000 (28)
 0.00		wlan0-link-high (29)
 0.00		wlan0-packets (30)
 0.00		wlan0-powerunsave (26)
 0.00		wlan0-up (25)

Score:    0.0  (  0.0)
Guess:  102.6
Actual:   0.0
----------------------------------
Leaving PowerTOP
Comment 11 Fedora Update System 2011-12-11 16:52:34 EST
powertop-1.98-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-01-02 16:49:02 EST
powertop-1.98-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.