Bug 751578 - Powertop Calibrate Problem
Powertop Calibrate Problem
Status: CLOSED DUPLICATE of bug 698020
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-05 16:47 EDT by Onuralp SEZER
Modified: 2011-12-07 05:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-07 05:09:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Onuralp SEZER 2011-11-05 16:47:18 EDT
Description of problem
Powertop doesn't calibrate and give this error ; 

Cannot load from file /var/cache/powertop/saved_parameters.powertop

All Calibrate Result ;

Cannot load from file /var/cache/powertop/saved_results.powertop
Cannot load from file /var/cache/powertop/saved_parameters.powertop
Starting PowerTOP power estimate calibration 
Calibrating idle
Calibrating: disk usage 
Calibrating backlight
.... device /sys/class/backlight/intel_backlight/brightness 
.... device /sys/class/backlight/acpi_video0/brightness 
.... device /sys/class/backlight/acpi_video1/brightness 
.... device /sys/class/backlight/acpi_video2/brightness 
Calibrating idle
Calibrating: CPU usage on 1 threads
Calibrating: CPU usage on 4 threads
Calibrating: CPU wakeup power consumption
Calibrating: CPU wakeup power consumption
Calibrating: CPU wakeup power consumption
Calibrating USB devices
.... device /sys/bus/usb/devices/usb1/power/control 
.... device /sys/bus/usb/devices/usb2/power/control 
.... device /sys/bus/usb/devices/1-1/power/control 
.... device /sys/bus/usb/devices/2-1/power/control 
.... device /sys/bus/usb/devices/1-1.3/power/control 
.... device /sys/bus/usb/devices/1-1.4/power/control 
.... device /sys/bus/usb/devices/2-1.5/power/control 
Calibrating radio devices
.... device /sys/class/rfkill/rfkill0/soft 
.... device /sys/class/rfkill/rfkill1/soft 
.... device /sys/class/rfkill/rfkill2/soft 
.... device /sys/class/rfkill/rfkill0/soft 
.... device /sys/class/rfkill/rfkill1/soft 
.... device /sys/class/rfkill/rfkill2/soft 
Finishing PowerTOP power estimate calibration 
Parameters after calibration:


Parameter state 
----------------------------------
Value		Name
 0.50		alsa-codec-power (14)
 0.00		backlight (4)
 0.00		backlight-boost-100 (8)
 0.00		backlight-boost-40 (6)
 0.00		backlight-boost-80 (7)
 0.00		backlight-power (5)
100.00		base power (45)
 1.56		cpu-consumption (3)
39.50		cpu-wakeups (2)
 0.00		disk-operations (48)
 0.20		disk-operations-hard (47)
 0.56		gpu-operations (46)
 0.00		p1p1-link-100 (20)
 0.00		p1p1-link-1000 (21)
 0.00		p1p1-link-high (22)
 0.00		p1p1-packets (23)
 0.00		p1p1-powerunsave (19)
 0.00		p1p1-up (18)
 0.00		radio:hci0 (17)
 0.00		radio:hp-wifi (15)
 0.00		radio:phy0 (16)
 0.00		runtime-0000:00:00.0 (30)
 0.00		runtime-0000:00:01.0 (31)
 0.00		runtime-0000:00:02.0 (32)
 0.00		runtime-0000:00:1a.0 (33)
 0.00		runtime-0000:00:1b.0 (34)
 0.00		runtime-0000:00:1c.0 (35)
 0.00		runtime-0000:00:1c.1 (36)
 0.00		runtime-0000:00:1d.0 (37)
 0.00		runtime-0000:00:1f.2 (38)
 0.00		runtime-0000:00:1f.3 (39)
 0.00		runtime-0000:00:1f.6 (40)
 0.00		runtime-0000:01:00.0 (41)
 0.00		runtime-0000:01:00.1 (42)
 0.00		runtime-0000:02:00.0 (43)
 0.00		runtime-0000:03:00.0 (44)
 0.10		usb-device-0408-03b2 (13)
 0.10		usb-device-046d-c526 (12)
 0.10		usb-device-148f-1000 (11)
 0.10		usb-device-1d6b-0002 (9)
 0.10		usb-device-8087-0020 (10)
 0.00		wlan0-link-100 (26)
 0.00		wlan0-link-1000 (27)
 0.00		wlan0-link-high (28)
 0.00		wlan0-packets (29)
 0.00		wlan0-powerunsave (25)
 0.00		wlan0-up (24)

Score:    0.0  (  0.0)
Guess:  104.1
Actual:   0.0
----------------------------------
Leaving PowerTOP



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.su
2.powertop --calibrate,
3.give error result 
  
Actual results:
Give error
Cannot load from file /var/cache/powertop/saved_parameters.powertop

Expected results:
Powertop has calibrate machine

Additional info:
Comment 1 Jaroslav Škarvada 2011-12-06 12:12:38 EST
AFAIK you need to run it for a while (approx. one hour) to collect enough data. Regarding the error message there was bug 698020.
Comment 2 Onuralp SEZER 2011-12-06 12:35:30 EST
Thank you , According to you first I will update to powertop from testing repo and calibrate again.
Comment 3 Jaroslav Škarvada 2011-12-07 05:09:53 EST
After calibration let it run for a while on battery (according to my tests approx. one hour) and it will show wattage estimation for each process / device. Then, if you exit, the estimation engine will save its state.

I think this together with the above mentioned update should resolve your problem. If the problem persists, please let me know.

*** This bug has been marked as a duplicate of bug 698020 ***

Note You need to log in before you can comment on or make changes to this bug.