This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 698184 - Enabling session saving with Gnome shell makes GUI login unusable
Enabling session saving with Gnome shell makes GUI login unusable
Status: CLOSED DUPLICATE of bug 700276
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
15
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Blocker/F15FinalBlocker 700276
  Show dependency treegraph
 
Reported: 2011-04-20 07:40 EDT by Andre Robatino
Modified: 2011-04-29 14:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 700276 (view as bug list)
Environment:
Last Closed: 2011-04-29 14:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
$HOME/.config/gnome-session/saved-session/gnome-shell.desktop (1.45 KB, text/plain)
2011-04-26 07:55 EDT, James Laska
no flags Details

  None (edit)
Description Andre Robatino 2011-04-20 07:40:30 EDT
Description of problem:
Boot from a F15 live image (such as one of those posted at https://fedoraproject.org/wiki/Test_Day:2011-04-21_GNOME3_Final ), log in as liveuser, open a terminal, run gnome-session-properties, check the box "Automatically remember running applications when logging out", log out and back in. Although running applications in the first workspace are still there, there is no trace of the top panel, the Super key doesn't work, and no obvious way to fix things.

Version-Release number of selected component (if applicable):
any recent version (such as the one in F15 Beta)

How reproducible:
always

Additional info:
Reproduced in two different machines which are Gnome shell-capable. Oddly, seems to work fine in fallback mode (for example in a VM). I also saw this earlier with the F15 Beta desktop live image (see http://lists.fedoraproject.org/pipermail/test/2011-April/098797.html ). At the time, there were a large number of updates, and I didn't have enough memory to apply them all in a live session, so thought maybe it was already fixed. Appears now that it's not.
Comment 1 Adam Williamson 2011-04-20 11:02:07 EDT
Adjusted summary: it's not using g-s-p that's the problem, but session saving (you also hit the bug if you enable session saving without using g-s-p, and you *don't* hit the bug if you just use g-s-p to set up autostart).

Proposing as F15 blocker; importantly, we should check what happens if you upgrade with this preference set.
Comment 2 James Laska 2011-04-21 15:50:12 EDT
Discussed at 2011-04-21 blocker review meeting (http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-21/f15-blocker-review.2011-04-21-17.00.html) ...

AGREED: 698184 - AcceptedNTH - further testing of F14->F15 upgrades may elevate to AcceptedBlocker
ACTION: jlaska - test F14->F15 upgrade 698184
Comment 3 Andre Robatino 2011-04-22 04:11:44 EDT
If this isn't fixed by Final, I hope there will be well-publicized instructions so people hit by this can recover a usable system. I still don't know how to do it. (Presumably it's a matter of going to a VT and deleting/editing some files, I don't know which ones, and most casual users wouldn't either.)
Comment 4 Adam Williamson 2011-04-22 11:19:09 EDT
you have to poke some setting in gconf or dconf/gsettings, I believe.
Comment 5 Andre Robatino 2011-04-22 12:44:31 EDT
This was recently reported upstream at https://bugzilla.gnome.org/show_bug.cgi?id=647359 and the same fix works here: go to a VT, rm ~/.config/gnome-session-saved-session/*, go back to the GUI, restart X with Ctrl-Alt-Backspace, log in again.
Comment 6 Andre Robatino 2011-04-22 12:53:14 EDT
Sorry, I meant "rm ~/.config/gnome-session/saved-session/*".
Comment 7 Andre Robatino 2011-04-22 13:31:21 EDT
Jlaska: Note that https://bugzilla.gnome.org/show_bug.cgi?id=647359#c1 says "this happens when upgrading from gnome 2.32 to gnome 3.0.0" so it will probably happen on a F14->F15 upgrade as well. I'd test it but it requires gnome shell (not fallback) which I can't get in a VM.
Comment 8 James Laska 2011-04-26 07:36:32 EDT
I just tested this issue and wasn't able to reproduce the failure on upgrade.

= Steps to Reproduce =

1) Installed F-14 with updates
2) Configured session auto-saving and saved firefox and gnome-terminal so they start on login
3) Logout and login to confirm session savings works
4) Ran preupgrade to get to F15
5) Logged in after preupgrade

= Actual Results =

* Gnome-shell starts and launches firefox and gnome-terminal

= Additional information =

* install.log:Installing gnome-session-2.32.0-1.fc14.x86_64
* upgrade.log:Upgrading gnome-session-3.0.0-1.fc15.x86_64
Comment 9 James Laska 2011-04-26 07:55:52 EDT
Created attachment 494887 [details]
$HOME/.config/gnome-session/saved-session/gnome-shell.desktop

(In reply to comment #8)
> I just tested this issue and wasn't able to reproduce the failure on upgrade.

I take that back.  The first login after upgrade works just fine.  Any subsequent logins are impacted by this issue.  The only way I can get a working desktop *after* the first successful login is to remove $HOME/.config/gnome-session/saved-session/gnome-shell.desktop

Attaching $HOME/.config/gnome-session/saved-session/gnome-shell.desktop for inspection.  According to upstream GNOME bug#647359 (see https://bugzilla.gnome.org/show_bug.cgi?id=647359#c7), the problem is that the attached file calls mutter, not gnome-shell.
Comment 10 James Laska 2011-04-26 08:06:03 EDT
Given that this bug is impacted by upgrades (F14->F15), and according to the Beta criteria [1] "...The upgraded system must meet all release criteria".  I think this issue is worth considering as a Final release blocker.  

During the last blocker review [2], there were mixed votes on whether this would be considered a release blocker if it was impacting upgrades.  Given that we know upgrades are impacted by this issue ... should this be considered a release blocker?

[1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
[2] http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-21/f15-blocker-review.2011-04-21-17.00.html
Comment 11 Jared Smith 2011-04-27 05:16:44 EDT
This certainly looks like a blocker to me.  It's got my vote to find itself on the blocker list.
Comment 12 Adam Williamson 2011-04-27 10:59:00 EDT
given the consequences on upgrade with what's likely to be a reasonably common option, +1 blocker.
Comment 13 Matthias Clasen 2011-04-27 12:40:04 EDT
See https://bugzilla.gnome.org/show_bug.cgi?id=645539 for the proposed workaround
Comment 14 Matthias Clasen 2011-04-27 21:21:50 EDT
Ah, turns out that the workaround doesn't actually work around anything...
The problem is that the libmutter conversion of gnome-shell did not update the session management support. So you now start /usr/bin/gnome-shell, but it still sets a restart command that runs /usr/bin/mutter
Comment 15 Adam Williamson 2011-04-29 13:54:51 EDT
Discussed at 2011-04-29 blocker review meeting, as testing showed it affects upgrades, accepted as a blocker. mclasen is pushing a fix.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2011-04-29 14:12:34 EDT
discussion of this issue continued in the clone, though a clone wasn't really needed; so close this as a dupe of that.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 700276 ***

Note You need to log in before you can comment on or make changes to this bug.