Bug 700276 - Enabling session saving with Gnome shell makes GUI login unusable
Enabling session saving with Gnome shell makes GUI login unusable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
15
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 698184 (view as bug list)
Depends On: 698184
Blocks: F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-04-27 21:22 EDT by Matthias Clasen
Modified: 2011-05-02 16:53 EDT (History)
13 users (show)

See Also:
Fixed In Version: mutter-3.0.1-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 698184
Environment:
Last Closed: 2011-04-29 21:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
$HOME/.config/gnome-session/saved-session/* (4.04 KB, application/x-gzip)
2011-04-29 12:01 EDT, James Laska
no flags Details
Screenshot.png (138.54 KB, image/png)
2011-04-29 12:06 EDT, James Laska
no flags Details

  None (edit)
Description Matthias Clasen 2011-04-27 21:22:40 EDT
+++ This bug was initially created as a clone of Bug #698184 +++

Description of problem:
Boot from a F15 live image (such as one of those posted at https://fedoraproject.org/wiki/Test_Day:2011-04-21_GNOME3_Final ), log in as liveuser, open a terminal, run gnome-session-properties, check the box "Automatically remember running applications when logging out", log out and back in. Although running applications in the first workspace are still there, there is no trace of the top panel, the Super key doesn't work, and no obvious way to fix things.

Version-Release number of selected component (if applicable):
any recent version (such as the one in F15 Beta)

How reproducible:
always

Additional info:
Reproduced in two different machines which are Gnome shell-capable. Oddly, seems to work fine in fallback mode (for example in a VM). I also saw this earlier with the F15 Beta desktop live image (see http://lists.fedoraproject.org/pipermail/test/2011-April/098797.html ). At the time, there were a large number of updates, and I didn't have enough memory to apply them all in a live session, so thought maybe it was already fixed. Appears now that it's not.

--- Additional comment from awilliam@redhat.com on 2011-04-20 11:02:07 EDT ---

Adjusted summary: it's not using g-s-p that's the problem, but session saving (you also hit the bug if you enable session saving without using g-s-p, and you *don't* hit the bug if you just use g-s-p to set up autostart).

Proposing as F15 blocker; importantly, we should check what happens if you upgrade with this preference set.

--- Additional comment from jlaska@redhat.com on 2011-04-21 15:50:12 EDT ---

Discussed at 2011-04-21 blocker review meeting (http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-21/f15-blocker-review.2011-04-21-17.00.html) ...

AGREED: 698184 - AcceptedNTH - further testing of F14->F15 upgrades may elevate to AcceptedBlocker
ACTION: jlaska - test F14->F15 upgrade 698184

--- Additional comment from robatino@fedoraproject.org on 2011-04-22 04:11:44 EDT ---

If this isn't fixed by Final, I hope there will be well-publicized instructions so people hit by this can recover a usable system. I still don't know how to do it. (Presumably it's a matter of going to a VT and deleting/editing some files, I don't know which ones, and most casual users wouldn't either.)

--- Additional comment from awilliam@redhat.com on 2011-04-22 11:19:09 EDT ---

you have to poke some setting in gconf or dconf/gsettings, I believe.

--- Additional comment from robatino@fedoraproject.org on 2011-04-22 12:44:31 EDT ---

This was recently reported upstream at https://bugzilla.gnome.org/show_bug.cgi?id=647359 and the same fix works here: go to a VT, rm ~/.config/gnome-session-saved-session/*, go back to the GUI, restart X with Ctrl-Alt-Backspace, log in again.

--- Additional comment from robatino@fedoraproject.org on 2011-04-22 12:53:14 EDT ---

Sorry, I meant "rm ~/.config/gnome-session/saved-session/*".

--- Additional comment from robatino@fedoraproject.org on 2011-04-22 13:31:21 EDT ---

Jlaska: Note that https://bugzilla.gnome.org/show_bug.cgi?id=647359#c1 says "this happens when upgrading from gnome 2.32 to gnome 3.0.0" so it will probably happen on a F14->F15 upgrade as well. I'd test it but it requires gnome shell (not fallback) which I can't get in a VM.

--- Additional comment from jlaska@redhat.com on 2011-04-26 07:36:32 EDT ---

I just tested this issue and wasn't able to reproduce the failure on upgrade.

= Steps to Reproduce =

1) Installed F-14 with updates
2) Configured session auto-saving and saved firefox and gnome-terminal so they start on login
3) Logout and login to confirm session savings works
4) Ran preupgrade to get to F15
5) Logged in after preupgrade

= Actual Results =

* Gnome-shell starts and launches firefox and gnome-terminal

= Additional information =

* install.log:Installing gnome-session-2.32.0-1.fc14.x86_64
* upgrade.log:Upgrading gnome-session-3.0.0-1.fc15.x86_64

--- Additional comment from jlaska@redhat.com on 2011-04-26 07:55:52 EDT ---

Created attachment 494887 [details]
$HOME/.config/gnome-session/saved-session/gnome-shell.desktop

(In reply to comment #8)
> I just tested this issue and wasn't able to reproduce the failure on upgrade.

I take that back.  The first login after upgrade works just fine.  Any subsequent logins are impacted by this issue.  The only way I can get a working desktop *after* the first successful login is to remove $HOME/.config/gnome-session/saved-session/gnome-shell.desktop

Attaching $HOME/.config/gnome-session/saved-session/gnome-shell.desktop for inspection.  According to upstream GNOME bug#647359 (see https://bugzilla.gnome.org/show_bug.cgi?id=647359#c7), the problem is that the attached file calls mutter, not gnome-shell.

--- Additional comment from jlaska@redhat.com on 2011-04-26 08:06:03 EDT ---

Given that this bug is impacted by upgrades (F14->F15), and according to the Beta criteria [1] "...The upgraded system must meet all release criteria".  I think this issue is worth considering as a Final release blocker.  

During the last blocker review [2], there were mixed votes on whether this would be considered a release blocker if it was impacting upgrades.  Given that we know upgrades are impacted by this issue ... should this be considered a release blocker?

[1] https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria
[2] http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-21/f15-blocker-review.2011-04-21-17.00.html

--- Additional comment from jaredsmith@jaredsmith.net on 2011-04-27 05:16:44 EDT ---

This certainly looks like a blocker to me.  It's got my vote to find itself on the blocker list.

--- Additional comment from awilliam@redhat.com on 2011-04-27 10:59:00 EDT ---

given the consequences on upgrade with what's likely to be a reasonably common option, +1 blocker.

--- Additional comment from mclasen@redhat.com on 2011-04-27 12:40:04 EDT ---

See https://bugzilla.gnome.org/show_bug.cgi?id=645539 for the proposed workaround

--- Additional comment from mclasen@redhat.com on 2011-04-27 21:21:50 EDT ---

Ah, turns out that the workaround doesn't actually work around anything...
The problem is that the libmutter conversion of gnome-shell did not update the session management support. So you now start /usr/bin/gnome-shell, but it still sets a restart command that runs /usr/bin/mutter
Comment 1 Adam Williamson 2011-04-27 21:47:30 EDT
why the clone?
Comment 2 Matthias Clasen 2011-04-27 21:59:25 EDT
See https://bugzilla.gnome.org/show_bug.cgi?id=648828 for a proposed (and tested) fix.
Comment 3 Fedora Update System 2011-04-28 17:03:50 EDT
mutter-3.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mutter-3.0.1-2.fc15
Comment 4 Fedora Update System 2011-04-29 00:31:57 EDT
Package mutter-3.0.1-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mutter-3.0.1-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mutter-3.0.1-2.fc15
then log in and leave karma (feedback).
Comment 5 Andre Robatino 2011-04-29 08:10:22 EDT
I booted the GNOME3 test day live image and updated just mutter (that's the best I can do in a live session) and it didn't fix it. Can someone else with more memory or a bare metal install test this?
Comment 6 James Laska 2011-04-29 12:01:28 EDT
Created attachment 495808 [details]
$HOME/.config/gnome-session/saved-session/*

(In reply to comment #5)
> I booted the GNOME3 test day live image and updated just mutter (that's the
> best I can do in a live session) and it didn't fix it. Can someone else with
> more memory or a bare metal install test this?

It changed the behavior, but it doesn't appear to have resolved the issue.  Any saved windows are started when I attempt to login ... however, the shell panel never starts.

Attaching files included in $HOME/.config/gnome-session/saved-session/

# tar -ztvf /tmp/saved-session-files.tgz 
-rw-rw-r-- guset/guset     396 2011-04-29 11:56 home/guset/.config/gnome-session/saved-session/10b1f02395c6440ce130409257985508100000014940036.desktop
-rw-rw-r-- guset/guset    6863 2011-04-29 11:56 home/guset/.config/gnome-session/saved-session/10b1f02395c6440ce130409256313976300000014940035.desktop
-rw-rw-r-- guset/guset    1528 2011-04-29 11:56 home/guset/.config/gnome-session/saved-session/gnome-shell.desktop
Comment 7 James Laska 2011-04-29 12:01:48 EDT
Moving back to ASSIGNED.  Perhaps more work is needed to properly resolve this issue?
Comment 8 James Laska 2011-04-29 12:06:10 EDT
Created attachment 495810 [details]
Screenshot.png

(In reply to comment #7)
> Moving back to ASSIGNED.  Perhaps more work is needed to properly resolve this
> issue?

With the updated mutter, I can get it behavior properly, if I manually run 'gnome-shell --replace', logout, then login again.  

However, if I logout and login another time, I'm greeted with just mutter (no shell).
Comment 9 Matthias Clasen 2011-04-29 12:19:54 EDT
What is the contents of the desktop files in saved-session when it breaks again ?
Is there one that runs gnome-shell ? Or is there one that runs mutter ?
Comment 10 James Laska 2011-04-29 12:38:52 EDT
(In reply to comment #9)
> What is the contents of the desktop files in saved-session when it breaks again
> ?
> Is there one that runs gnome-shell ? Or is there one that runs mutter ?

Appears like there are two .desktop files for my saved applications, and then the gnome-shell.desktop seems to run mutter.

# grep -n ^Exec *.desktop
102c6c6c1f76494d96130409298663030400000020380036.desktop:177:Exec=gnome-terminal --sm-client-id 102c6c6c1f76494d96130409298663030400000020380036 --sm-client-state-file /home/guset/.config/session-state/gnome-terminal-1304093054.desktop

10b1f02395c6440ce130409257985508100000014940036.desktop:9:Exec=/usr/bin/firefox --sm-config-prefix /xulrunner-bin-9iH2WR/ --sm-client-id 10b1f02395c6440ce130409257985508100000014940036 --screen 0

gnome-shell.desktop:52:Exec=mutter --sm-client-id 10b04a994531db2436130409300283611000000026160000
Comment 11 Matthias Clasen 2011-04-29 13:44:22 EDT
This is a case of forgotten patch :-(

New update coming
Comment 12 Adam Williamson 2011-04-29 14:12:34 EDT
*** Bug 698184 has been marked as a duplicate of this bug. ***
Comment 13 Adam Williamson 2011-04-29 14:14:17 EDT
698184 was accepted as a blocker, but discussion and work continued in this clone, so closed that one as a dupe and marking this as a blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 James Laska 2011-04-29 15:35:13 EDT
A new mutter update that appears to resolve this issue for robatino & I is available for testing ...

https://admin.fedoraproject.org/updates/mutter-3.0.1-3.fc15
Comment 15 Fedora Update System 2011-04-29 21:37:21 EDT
mutter-3.0.1-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Andre Robatino 2011-05-02 08:03:05 EDT
During Final TC1 upgrade testing, it would probably be a good idea to check if there are temporary problems with session saving caused by having it enabled before the upgrade. After updating mutter, I had to struggle a while before it would work.
Comment 17 James Laska 2011-05-02 15:06:36 EDT
I just completed a F14 -> F15 preupgrade.  Prior to upgrade, I enabled gnome-sesion autosaving and ensured that firefox and gnome-terminal were saved.  After upgrade, I can login without error, and my saved firefox and gnome-terminal applications start without error.  This was tested on bare-metal.  The mutter installed during the upgrade was mutter-3.0.1-3.fc15.x86_64.

NOTE: There appear to be some applications that do not support session saving.  This doesn't seem to be specific to F15.  For example, gcalctool and shotwell would not automatically start after login on F14, or in F15.  I don't think this issue is specific to the reported bug, and can be tracked separately.
Comment 18 Matthias Clasen 2011-05-02 16:53:54 EDT
> NOTE: There appear to be some applications that do not support session saving. 
> This doesn't seem to be specific to F15.  For example, gcalctool and shotwell
> would not automatically start after login on F14, or in F15.  I don't think
> this issue is specific to the reported bug, and can be tracked separately.

Yes, that is not new, and unrelated to the problem tracked here.

Note You need to log in before you can comment on or make changes to this bug.