Bug 698196 - google gadgets can't start
google gadgets can't start
Status: CLOSED DUPLICATE of bug 660937
Product: Fedora
Classification: Fedora
Component: google-gadgets (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 08:12 EDT by Brian G. Anderson
Modified: 2011-05-07 15:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-07 15:13:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2011-04-20 08:12:58 EDT
Description of problem:
I installed google gadgets to compensate for the lack of various desktop widgets that used to show important system information that are now gone with the new gnome-shell.  However,  ggl-gtk fails with the following console message:

(ggl-gtk:2521): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
Failed to find proper Gecko Runtime Environment!

gtk_flash_element.cc:66: Finalize gtk_flash_element extension.
browser_element.cc:71: Finalize gtkmoz_browser_element extension.
google_gadget_manager_init.cc:32: Finalize google_gadget_manager extension.
analytics_usage_collector.cc:254: Finalize analytics_usage_collector extension.
linux_system_framework.cc:125: Finalize linux_system_framework extension.
gst_audio_framework.cc:480: Finalize gst_audio_framework extension.
gtk_system_framework.cc:344: Finalize gtk_system_framework extension.
gst_video_element.cc:47: Finalize gst_video_element extension.
gtk_edit_element.cc:42: Finalize gtk_edit_element extension.
dbus_script_class.cc:65: Finalize dbus_script_class extension.
default_options.cc:487: Finalize default_options extension.
libxml2_xml_parser.cc:866: Finalize libxml2_xml_parser extension.
default_framework.cc:413: Finalize default_framework extension.
curl_xml_http_request.cc:1156: Finalize curl_xml_http_request extension.

and also shows a pop-up that displays:

Program can't start because it failed to load the following module(s):
js-script-runtime

if I start it using ggl-qt -s qt it will start, but it crashes when I add new gadgets.

Version-Release number of selected component (if applicable):
google-gadgets-qt-0.11.2-2.fc14.x86_64
google-gadgets-0.11.2-2.fc14.x86_64
google-gadgets-gtk-0.11.2-2.fc14.x86_64


How reproducible:
always

Steps to Reproduce:
1. start ggl-gtk
2.
3.
  
Actual results:
crash

Expected results:


Additional info:
Comment 1 Peter Robinson 2011-05-07 15:13:39 EDT

*** This bug has been marked as a duplicate of bug 660937 ***

Note You need to log in before you can comment on or make changes to this bug.