Bug 69825 - Partitioning error: cannot import name Main Bootloader Window
Partitioning error: cannot import name Main Bootloader Window
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-25 15:31 EDT by Jim Wiedman
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 16:18:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Wiedman 2002-07-25 15:31:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020618 Netscape/7.0b1

Description of problem:
When clicking next after setting up the partition table, an unhandled exception
is reported.  I am trying to keep an ext2 partition during a new install, that
could be the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose Partition with DiskDruid during the install.
2. Delete most existing partitions and add an LVM.
3.  Click next.
	

Actual Results:  I get an error message, then the system reboots.

Expected Results:  A new partition table with an LVM should be created.

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 552, in next Clicked
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 704, in setScreen
     exec s
  File "<string>", line 1, in ?
ImportError:  cannot import name MainBootloaderWindow
Comment 1 Michael Fulbright 2002-07-30 15:15:13 EDT
Is this a CD based install?

Have you run the mediacheck?
Comment 2 Jim Wiedman 2002-07-30 15:19:22 EDT
Yes, it was a CD based install and I did run the CD check.  When I completely
deleted all partitions and started again, it worked just fine.  I haven't tried
to partition with a preexisting ext2 now that the latest beta has been released,
but I will try to reproduce the error.
Comment 3 Jim Wiedman 2002-07-30 15:58:32 EDT
I reinstalled RedHat 7.1, then installed the latest beta version keeping the 7.1
version intact (adding an LVM and ext3 partitions).  The error was not
reproduced.  I don't know if the problem was fixed with the most recent beta, or
if there was something wrong with my partition table or original install disk.
Comment 4 Jim Wiedman 2002-07-30 16:18:20 EDT
I just tried to load Limbo again (leaving the 7.1 install).  This time, unlike
the second time I tried, I deleted old partitions in DiskDruid (but not all the
partitions) and created new ones including an LVM.  

Another exception occured.  The message is:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 613, in nextClicked
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 779, in setScreen
    exec s
  File "<string>", line 1, in ?
ImportError: cannot import name MainBootloaderWindow
Comment 5 Michael Fulbright 2002-08-14 01:43:36 EDT
This is almost certainly CDs which are marginal so they work sometimes and dont
other times.
Comment 6 Jim Wiedman 2002-08-14 09:15:25 EDT
If this is a poor CD creation:

1)  The disk check utility is not working because it reports all my
         CDs in good working order.
2)  Two different CD burners created bad disks where the only problem
         created was with the partitioning program.

Note You need to log in before you can comment on or make changes to this bug.