This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 698461 - [Dell Latitude E5520] Touchpad mis-detected as PS/2 mouse
[Dell Latitude E5520] Touchpad mis-detected as PS/2 mouse
Status: CLOSED DUPLICATE of bug 698794
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-20 18:08 EDT by Mark Watts
Modified: 2011-06-24 08:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-24 08:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Watts 2011-04-20 18:08:58 EDT
(Note: this also affects Fedora 15 Beta LiveCD)

Dell Latitude E5520 laptop; touchpad is detected as a PS/2 mouse, so none of the touchpad specific settings appear.

Tap to click does work although simulated middle clicking and side-scrolling do not work.

/proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name="PS/2 Generic Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event6 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=3

/etc/Xorg.0.log:

[   113.166] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event6)
[   113.166] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[   113.166] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[   113.166] (**) PS/2 Generic Mouse: always reports core events
[   113.166] (**) PS/2 Generic Mouse: Device: "/dev/input/event6"
[   113.166] (--) PS/2 Generic Mouse: Found 3 mouse buttons
[   113.166] (--) PS/2 Generic Mouse: Found relative axes
[   113.166] (--) PS/2 Generic Mouse: Found x and y relative axes
[   113.166] (II) PS/2 Generic Mouse: Configuring as mouse
[   113.166] (**) PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[   113.166] (**) PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   113.166] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event6"
[   113.166] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE)
[   113.166] (II) PS/2 Generic Mouse: initialized for relative axes.
[   113.166] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[   113.166] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[   113.166] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[   113.166] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[   113.166] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse0)
[   113.166] (II) No input driver/identifier specified (ignoring)
Comment 1 Chuck Ebbert 2011-06-24 08:40:36 EDT

*** This bug has been marked as a duplicate of bug 698794 ***

Note You need to log in before you can comment on or make changes to this bug.