Bug 698794 - Touchpad seen as generic mouse on Dell Inspiron 15R model N5110
Touchpad seen as generic mouse on Dell Inspiron 15R model N5110
Status: CLOSED DUPLICATE of bug 590880
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 698461 698805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-21 15:47 EDT by Jef Spaleta
Modified: 2011-09-27 15:27 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-27 15:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contents of /proc/bus/input/devices (2.66 KB, text/plain)
2011-04-21 15:47 EDT, Jef Spaleta
no flags Details
Patch from http://thread.gmane.org/gmane.linux.kernel.input/16626 (8.13 KB, patch)
2011-07-12 15:56 EDT, Matěj Cepl
no flags Details | Diff
Xorg config Files and Log (10.13 KB, application/x-gzip)
2011-07-12 22:36 EDT, Bruno Rodrigues
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 14660 None None None Never

  None (edit)
Description Jef Spaleta 2011-04-21 15:47:20 EDT
Created attachment 493969 [details]
contents of /proc/bus/input/devices

Description of problem:
touchpad seen as generic device in Fedora 15 Beta as listed in
/proc/bus/input/devices
see attached file for full contents.

uname -a
Linux localhost.localdomain 2.6.38.2-9.fc15.x86_64 #1 SMP Wed Mar 30 16:55:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

rpm -q kernel
kernel-2.6.38.2-9.fc15.x86_64


Due to being listed as a generic device I'm not seeing the touchpad configuration dialogs in Gnome3 nor am I getting scroll handling as I would expect.


Please let me know if you need anything further information of task specific testing.  

I followed the instructions at 
https://fedoraproject.org/wiki/Xorg/Input_Triage_Algorithm and concluded this was a kernel level issue in recognizing the device.

I believe there are similar bugs reported against F14 for different Inspiron models.  But I thought it best to file anew for the Beta
Comment 1 Christopher Hirschmann 2011-05-20 05:10:03 EDT
Same here, on a Dell Latitude E5420.

According to "xinput list" this touchpad was seen as "Generic PS/2 Mouse", but it should be seen as an ALPS touchpad.

I searched the internet for a solution, since this was bugging me a lot and I found this:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/760142

It looks like Dell is using these ALPS Glidepoint touchpads a lot in recent models and therefore this bug has the potential to affect a lot of people.

In one of the last posts in this Ubuntu bug report is a link to the LKML archive: http://www.spinics.net/lists/linux-input/msg12507.html

Apparently there is a patch for the kernel that fixes these problems, but I hasn't been accepted into the mainline kernel because it looks like it only fixes this for Dell laptops and not for every other laptop with this touchpad. (I have no idea if this is correct)

Since the touchpad worked with a Ubuntu 11.04 Live system booted from a stick, I took a look at their kernel source and they integrate the above mentioned patch (without changes). So I rebuild the kernel SRPM (2.6.38.5-24) and included this patch. This custom build kernel recognizes the touchpad correctly:

$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ImPS/2 ALPS GlidePoint                  	id=12	[slave  pointer  (2)]  <==
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_FHD            	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=13	[slave  keyboard (3)]

$ cat /proc/bus/input/devices
…
I: Bus=0011 Vendor=0002 Product=0005 Version=7326
N: Name="ImPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103
…

With the new 2.6.38.6-27.fc15.x86_64 the problem reappears, so I guess I'll be building another custom kernel tonight and run the old one until then.

BTW: With 2.6.38.5-24 sleep and hibernation would not work on this laptop (the system would resume to a blank screen, would not resume network and the consoles didn't work either), but with 2.6.38.6-27 they do. I'm mentioning this, because the submitter of the kernel patch mentioned suspend/resume issues which supposedly are also fixed by the patch (they were partly fixed in my custom build kernel, resume worked 80% of the time).

If you need more information, contact me.
Comment 2 Chuck Ebbert 2011-06-24 08:40:36 EDT
*** Bug 698461 has been marked as a duplicate of this bug. ***
Comment 3 Chuck Ebbert 2011-06-24 08:41:01 EDT
*** Bug 698805 has been marked as a duplicate of this bug. ***
Comment 4 Pádraig Brady 2011-06-24 11:09:38 EDT
I've been testing this patch for a while now without issues.
Comment 5 Bruno Rodrigues 2011-07-10 11:33:28 EDT
I've applied this patch and now the mouse is recognized as 
N: Name="ImPS/2 ALPS GlidePoint"
The horizontal scrolling is working fine but on Gnome System Settings > Mouse and Touchpad the Touchpad sheet didn't appears 
Anybody knows if did I need something extra to fix this problem ??
Comment 6 Matěj Cepl 2011-07-12 15:56:19 EDT
Created attachment 512509 [details]
Patch from http://thread.gmane.org/gmane.linux.kernel.input/16626

This patch has not been approved by the upstream (being too hardware specific hack, not a proper solution).
Comment 7 Matěj Cepl 2011-07-12 18:14:25 EDT
(In reply to comment #5)
> I've applied this patch and now the mouse is recognized as 
> N: Name="ImPS/2 ALPS GlidePoint"
> The horizontal scrolling is working fine but on Gnome System Settings > Mouse
> and Touchpad the Touchpad sheet didn't appears 
> Anybody knows if did I need something extra to fix this problem ??

Interesting, please attach

* your X server config file (/etc/X11/xorg.conf, and any other files in /etc/X11/xorg.conf.d/ if available), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 8 Bruno Rodrigues 2011-07-12 22:36:50 EDT
Created attachment 512551 [details]
Xorg config Files and Log

As requested attached my xorg config and xorg logs.
Comment 9 Bruno Rodrigues 2011-07-13 07:27:08 EDT
I forgot to mention my laptop is a Dell Vostro 3550

Please let me know if you need anything else.

Regards!
Comment 10 Paul Johnson 2011-07-23 01:21:33 EDT
Same as:

https://bugzilla.redhat.com/show_bug.cgi?id=590880

The resolution is that one must patch the psmouse driver in order to make the touchpad behave more acceptably.  No fully function multi touch driver exists, but I have been running the patch and it helps a lot.  It is all explained toward the end of that bug mentioned above.

This bug should be closed/merged with that one.
Comment 11 Josh Boyer 2011-09-27 15:27:21 EDT

*** This bug has been marked as a duplicate of bug 590880 ***

Note You need to log in before you can comment on or make changes to this bug.