Bug 698603 - [abrt] caribou-0.2.00-1.fc15: main.py:55:__init__:Exception: AT-SPI 1 or 2 needs to be enabled.
Summary: [abrt] caribou-0.2.00-1.fc15: main.py:55:__init__:Exception: AT-SPI 1 or 2 ne...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: caribou
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5626a106b35a907e70941109143...
: 690303 (view as bug list)
Depends On:
Blocks: F15Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2011-04-21 11:19 UTC by Sergei Nikulov
Modified: 2011-10-31 23:49 UTC (History)
9 users (show)

Fixed In Version: caribou-0.2.00-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-10 03:23:39 UTC


Attachments (Terms of Use)
File: backtrace (578 bytes, text/plain)
2011-04-21 11:19 UTC, Sergei Nikulov
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 645890 None None None Never

Description Sergei Nikulov 2011-04-21 11:19:31 UTC
abrt version: 2.0.1
comment: login to kde desktop
executable: /usr/bin/caribou
component: caribou
package: caribou-0.2.00-1.fc15
uid: 500
kernel: 2.6.38.2-9.fc15.x86_64
reason: main.py:55:__init__:Exception: AT-SPI 1 or 2 needs to be enabled.
architecture: x86_64
username: sergey
os_release: Fedora release 15 (Lovelock)
time: 1303384436

event_log
-----
2011-04-21-22:16:29> Empty login or password, please check your configuration
2011-04-21-22:16:29* (exited with 1)
2011-04-21-22:18:28> Empty login or password, please check your configuration
2011-04-21-22:18:28* (exited with 1)

backtrace
-----
main.py:55:__init__:Exception: AT-SPI 1 or 2 needs to be enabled.

Traceback (most recent call last):
  File "/usr/bin/caribou", line 76, in <module>
    caribou = main.Caribou()
  File "/usr/lib/python2.7/site-packages/caribou/ui/main.py", line 55, in __init__
    raise Exception, "AT-SPI 1 or 2 needs to be enabled."
Exception: AT-SPI 1 or 2 needs to be enabled.

Local variables in innermost frame:
self: <caribou.ui.main.Caribou instance at 0x165c6c8>
window_factory: <class 'caribou.ui.window.CaribouWindowEntry'>
kb_factory: <class 'caribou.ui.keyboard.CaribouKeyboard'>

Comment 1 Sergei Nikulov 2011-04-21 11:19:35 UTC
Created attachment 493788 [details]
File: backtrace

Comment 2 Jussi Eloranta 2011-04-21 17:31:11 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
It just appeared after I logged it (XFCE)

Comment 3 Igor Katalnikov 2011-04-22 19:25:57 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Tried to start up

Comment 4 Matthew Davis 2011-04-23 04:59:14 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Little to no configuration changes. Prevoiuslly used Gnome3, and switched to kde.

Comment 5 Parag Nemade 2011-04-25 03:17:41 UTC
*** Bug 690303 has been marked as a duplicate of this bug. ***

Comment 6 Parag Nemade 2011-04-25 03:18:23 UTC
I see the easiest solution for this bug for now is to execute following on
command line.
gsettings set org.gnome.desktop.interface toolkit-accessibility true

Above will enable accessibility support in F15 and you can then run caribou
without a problem.

Comment 7 Edoardo Patelli 2011-04-26 13:16:31 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I can not help you.

Comment 8 aj2005uk 2011-04-26 15:44:27 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
crash happens everytime user logs in

Comment 9 John 2011-04-29 09:46:50 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Isue taked on after: login screen -> kde loaded -> issue

Comment 10 Alexander Volovics 2011-04-29 21:37:02 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Had just installed xfce package group, logged out and logged in again
after selecting xfce

Comment 11 Fabio Canepa 2011-05-01 12:46:04 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Crash just after gnome or kde login

Comment 12 Ralf Corsepius 2011-05-03 13:38:43 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Problem occurred at first reboot after yum update,

Comment 13 Tom Horsley 2011-05-03 23:49:54 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Just tried logging into a kde session in fedora 15.

Comment 14 john.haxby@oracle.com 2011-05-04 12:21:06 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
This happens every time I log in with KDE

Comment 15 Adam Williamson 2011-05-04 23:30:02 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Crash notification appeared on first login to a KDE desktop after installing F15 with all four major desktops enabled.

Comment 16 Adam Williamson 2011-05-04 23:31:35 UTC
Nominating as a final release blocker, per criterion:

"In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login (see Blocker_Bug_FAQ) "

This notification popped up for me on first log in to KDE (a 'supported' desktop) after installing F15 Final TC1 DVD, with all desktop environments checked.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 17 Adam Williamson 2011-05-05 00:01:34 UTC
I get the same crash on login to Xfce.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 18 gcarter 2011-05-05 02:02:41 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Login to KDE

Comment 19 Kevin Kofler 2011-05-05 04:46:55 UTC
> I see the easiest solution for this bug for now is to execute following on
> command line.
> gsettings set org.gnome.desktop.interface toolkit-accessibility true
>
> Above will enable accessibility support in F15 and you can then run caribou
> without a problem.

That will have absolutely no effect under KDE, for 2 reasons:
* This is a GNOME setting. You have to set the GTK+ setting directly instead. (AFAIK, the easiest way is an environment variable.)
* There are few to no GTK+ apps running under KDE normally. For Qt, you need
qt-atspi2, which is not packaged in Fedora yet. (It became usable only very recently.) You also need to set yet another environment variable.

In addition, the toolkit developers must have a reason to disable accessibility by default, I don't think it's a good idea to have something installed by default (when installing from the DVD) enabling it. (If we really want that, we should do it in the toolkits themselves, but again, this should be discussed with upstream.)

Caribou should exit cleanly instead of throwing an exception if accessibility is disabled.

Another solution for the blocker might be to just make caribou's autostart file OnlyShowIn=GNOME; for now.

Comment 20 Kevin Kofler 2011-05-05 05:09:47 UTC
To sum up what we found on IRC: The problem is that /etc/xdg/autostart/caribou-autostart.desktop contains:
AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-keyboard-enabled
which is ignored by non-GNOME desktops, so Caribou gets autostarted unconditionally on them.

KDE has its own autostart condition implementation, which doesn't support this entry. (All the KDE .desktop files I see have their autostart conditions encoded with X-KDE-autostart-condition, which has a different syntax and always uses KConfig.) And XFCE probably doesn't support autostart conditions at all.

So it really looks like this should be OnlyShowIn=GNOME;.
echo "OnlyShowIn=GNOME;" >> $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/caribou-autostart.desktop
should fix this.

Comment 21 Christopher Archer 2011-05-05 05:29:05 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Start up F15 using LXDE

Comment 22 Manuel Trujillo 2011-05-05 06:09:02 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Problem with caribou when start a new KDE4 session in F15.

Comment 23 Fedora Update System 2011-05-05 06:38:10 UTC
caribou-0.2.00-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/caribou-0.2.00-2.fc15

Comment 24 Thomas Janssen 2011-05-05 15:13:35 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Just login to F15beta KDE plasma desktop.

Comment 25 Emmett Culley 2011-05-06 16:05:01 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Started KDE desktop via GDM.

Comment 26 Filipe Rosset 2011-05-07 01:11:47 UTC
Package: caribou-0.2.00-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Still crashing when called from terminal (GNOME3)

Comment 27 Adam Williamson 2011-05-07 01:21:06 UTC
well, yes, but that's not really a problem (though passing an exception to tell the user something is a bit inelegant). the problem was that it was being auto-started in non-GNOME environments.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 28 Othman Madjoudj 2011-05-07 16:49:31 UTC
Yes, caribou still crash when it launched from terminal, but after the last update it's no longer enabled by default on other desktops (tested with KDE).

Comment 29 Othman Madjoudj 2011-05-07 17:04:38 UTC
It seems that the new version of caribou require clutter which require hardware acceleration, this why its crash in fallback mode or other desktops.

Output before the python traceback:

Clutter-CRITICAL **: Unable to initialize Clutter: Unable to select the newly created GLX context

Comment 30 Kevin Kofler 2011-05-07 20:49:52 UTC
The problem on other desktops is actually not that Clutter is required, but that AT-SPI is required (see the text of the exception quoted in the subject of the bug report).

Clutter should work fine on other desktops if and only if OpenGL is working properly. Of course, since gnome-shell is actually based on Clutter, if your hardware cannot support gnome-shell, it likely cannot support other Clutter apps either. In your case, it looks like you don't have OpenGL working at all. (Is this a virtual machine?)

Comment 31 Othman Madjoudj 2011-05-07 21:06:59 UTC
(In reply to comment #30)
> The problem on other desktops is actually not that Clutter is required, but
> that AT-SPI is required (see the text of the exception quoted in the subject of
> the bug report).
> 
> Clutter should work fine on other desktops if and only if OpenGL is working
> properly. Of course, since gnome-shell is actually based on Clutter, if your
> hardware cannot support gnome-shell, it likely cannot support other Clutter
> apps either. In your case, it looks like you don't have OpenGL working at all.
> (Is this a virtual machine?)

Yes, it's a KVM guest, It's not an issue since I generally use KDE for testing (sometimes openbox), this was out of curiosity.

Comment 32 Fedora Update System 2011-05-08 04:08:32 UTC
caribou-0.2.00-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/caribou-0.2.00-3.fc15

Comment 33 Fedora Update System 2011-05-09 03:30:17 UTC
Package caribou-0.2.00-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing caribou-0.2.00-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/caribou-0.2.00-3.fc15
then log in and leave karma (feedback).

Comment 34 Matthias Runge 2011-05-09 06:52:01 UTC
Package: caribou-0.2.00-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
start caribou via shell
(to test bugfix)

Comment 35 Kevin Kofler 2011-05-09 07:08:00 UTC
Once again: It is expected that Caribou will still throw an exception if you run it manually without the requirements (working support for AT-SPI and OpenGL) being met. What the update fixes is that Caribou was getting autostarted by default on non-GNOME desktops.

Comment 36 Fedora Update System 2011-05-10 03:23:34 UTC
caribou-0.2.00-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 37 Felipe Contreras 2011-07-20 15:29:19 UTC
I have caribou-0.2.00-3.fc15, the problem is still there, but I can't reopen.

Comment 38 mdmpsyd@gmail.com 2011-10-31 23:49:20 UTC
I also have caribou-0.2.00-3.fc15 and continue to have this problem.


Note You need to log in before you can comment on or make changes to this bug.