Bug 690303 - [abrt] caribou-0.1.92-1.fc15: main.py:55:__init__:Exception: AT-SPI 1 or 2 needs to be enabled.
Summary: [abrt] caribou-0.1.92-1.fc15: main.py:55:__init__:Exception: AT-SPI 1 or 2 ne...
Keywords:
Status: CLOSED DUPLICATE of bug 698603
Alias: None
Product: Fedora
Classification: Fedora
Component: caribou
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:22fc5ada
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-03-23 20:26 UTC by jimmy
Modified: 2011-04-27 11:19 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-25 03:17:41 UTC


Attachments (Terms of Use)
File: backtrace (578 bytes, text/plain)
2011-03-23 20:26 UTC, jimmy
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 645890 None None None Never

Description jimmy 2011-03-23 20:26:41 UTC
abrt version: 1.1.17
architecture: i686
cmdline: /usr/bin/python /usr/bin/caribou
component: caribou
executable: /usr/bin/caribou
kernel: 2.6.38-1.fc15.i686
package: caribou-0.1.92-1.fc15
reason: main.py:55:__init__:Exception: AT-SPI 1 or 2 needs to be enabled.
release: Fedora release 15 (Lovelock)
How to reproduce: I have a fresh install of the Alpha running for testing/peek-lloking on my ASUS EEEPC 1000H with stock equipment. Sorry for not being able to give more details. I run look around in the release and check things out.
time: 1300911801
uid: 500

backtrace
-----
main.py:55:__init__:Exception: AT-SPI 1 or 2 needs to be enabled.

Traceback (most recent call last):
  File "/usr/bin/caribou", line 76, in <module>
    caribou = main.Caribou()
  File "/usr/lib/python2.7/site-packages/caribou/ui/main.py", line 55, in __init__
    raise Exception, "AT-SPI 1 or 2 needs to be enabled."
Exception: AT-SPI 1 or 2 needs to be enabled.

Local variables in innermost frame:
self: <caribou.ui.main.Caribou instance at 0x9844dcc>
window_factory: <class 'caribou.ui.window.CaribouWindowEntry'>
kb_factory: <class 'caribou.ui.keyboard.CaribouKeyboard'>

Comment 1 jimmy 2011-03-23 20:26:43 UTC
Created attachment 487141 [details]
File: backtrace

Comment 2 Parag Nemade 2011-03-24 03:23:11 UTC
This is a well known issues in caribou since last few releases (not sure if its there since its initial development). I already had a talk on this with upstream developer. I have requested him to put a dialog box to let user know that he needs first accessibility to be enabled.

I am sure this bug will get reported in future by many users. I will open a upstream bug for this now.

Comment 3 jimmy 2011-03-24 06:13:29 UTC
(In reply to comment #2)
> This is a well known issues in caribou since last few releases (not sure if its
> there since its initial development). I already had a talk on this with
> upstream developer. I have requested him to put a dialog box to let user know
> that he needs first accessibility to be enabled.
> 
> I am sure this bug will get reported in future by many users. I will open a
> upstream bug for this now.

Thank you for the feedback. I am 100% fresh on this reporting bug thing and I feel bad about not being able to describe the steps better whilst issuing the report. I know this is the wrong forum to ask but I will take my chance nevertheless. Is my report valuable even though I could not add any professorial details to the case? I strongly feel I want to contribute but I am uncertain if I actually help or just create administration.

Best regards
Jimmy

Comment 4 jimmy 2011-03-24 06:23:21 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > This is a well known issues in caribou since last few releases (not sure if its
> > there since its initial development). I already had a talk on this with
> > upstream developer. I have requested him to put a dialog box to let user know
> > that he needs first accessibility to be enabled.
> > 
> > I am sure this bug will get reported in future by many users. I will open a
> > upstream bug for this now.
> 
> Thank you for the feedback. I am 100% fresh on this reporting bug thing and I
> feel bad about not being able to describe the steps better whilst issuing the
> report. I know this is the wrong forum to ask but I will take my chance
> nevertheless. Is my report valuable even though I could not add any
> professorial details to the case? I strongly feel I want to contribute but I am
> uncertain if I actually help or just create administration.
> 
> Best regards
> Jimmy

Disregard and accept my apologies for ranting. :/ Found what I was looking for.

http://fedoraproject.org/wiki/BugsAndFeatureRequests

Comment 5 Horst H. von Brand 2011-03-24 12:06:12 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. Logged into my XFCE session
2.
3.

Comment 6 Neal Becker 2011-03-24 15:56:53 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. logged in
2.
3.


Comment
-----
This happened on login to kde

Comment 7 Thomas Woerner 2011-03-24 16:28:25 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. Unknown
2.
3.

Comment 8 Parag Nemade 2011-03-25 08:38:58 UTC
I see the easiest solution for this bug for now is to execute following on command line.
gsettings set org.gnome.desktop.interface toolkit-accessibility true

Above will enable accessibility support in F15 and you can then run caribou without a problem.

Comment 9 Alexander Novichkov 2011-03-25 19:55:01 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. Start computer
2.
3.

Comment 10 Iven Hsu 2011-03-26 10:14:15 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.Go to system config to enable screen keyboard.
2.It crashes.

Comment 11 dominique 2011-03-26 19:37:10 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.When I loggin, I have this ABRT alert
2.
3.

Comment 12 James Cape 2011-03-27 04:26:20 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. Tried just starting it from the command line.

Comment 13 Matthias Runge 2011-03-30 12:28:05 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
start xfce on freshly upgraded f15. (upgrade via rpm -i fedora-release, yum upgrade)
yum groupinstall "Xfce" 
yum groupinstall "GNOME Desktop Environment")

Start, log into xfce, bug/crash

Comment 14 G.Wolfe Woodbury 2011-03-31 14:35:29 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
XFCE login on FC15.BETA + updates-testing

Comment 15 Da_Silva 2011-04-03 12:30:54 UTC
Package: caribou-0.1.92-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Rawhide)


How to reproduce
-----
1.Using Rawhide (FC16)
2.
3.

Comment 16 Richard W.M. Jones 2011-04-04 08:41:11 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. Start up XFCE session on F15.
2.
3.


Comment
-----
Three processes, "caribou", "gnome-settings-daemon" and "gsettings-data-convert" always crash when I start a new session.

Comment 17 d. johnson 2011-04-13 17:13:45 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Installed today, updated, then logged in.  Abrt message happened before desktop was painted.

Comment 18 Parag Nemade 2011-04-14 05:48:05 UTC
Upstream has yet not fixed this problem though patch is available.

Comment 19 Mohammed Arafa 2011-04-15 11:30:27 UTC
Package: caribou-0.1.92-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.kde startup
2.
3.

Comment 20 Greg` 2011-04-17 08:10:53 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.reinstalled Fedora
2.
3.


Comment
-----
Gnome Crashed

Comment 21 DiEOrLivE 2011-04-17 11:30:46 UTC
Package: caribou-0.2.00-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
$ caribou
-> False
Traceback (most recent call last):
  File "/usr/bin/caribou", line 76, in <module>
    caribou = main.Caribou()
  File "/usr/lib/python2.7/site-packages/caribou/ui/main.py", line 55, in __init__
    raise Exception, "AT-SPI 1 or 2 needs to be enabled."
Exception: AT-SPI 1 or 2 needs to be enabled.

Comment 22 John Poelstra 2011-04-20 16:44:59 UTC
Package: caribou-0.2.00-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. run lxed in fedora 15 beta
2.
3.

Comment 23 Edwin Schepers 2011-04-20 21:42:31 UTC
Package: caribou-0.1.92-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. I just installed F15 beta
2. I installed kde packages
3. I logged in, in KDE
the crash happened

Comment 24 Parag Nemade 2011-04-25 03:17:41 UTC

*** This bug has been marked as a duplicate of bug 698603 ***

Comment 25 Parag Nemade 2011-04-27 02:59:52 UTC
*** Bug 699787 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.