Bug 698685 - Broken dependency on deprecated hal
Broken dependency on deprecated hal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-device-manager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 715703
  Show dependency treegraph
 
Reported: 2011-04-21 10:29 EDT by Nicola Soranzo
Modified: 2013-03-05 23:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-28 04:32:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicola Soranzo 2011-04-21 10:29:37 EDT
Description of problem:
Since HAL has been deprecated upstream for 3 years, Fedora is removing it from
the distribution:

https://fedoraproject.org/wiki/Features/HalRemoval

The hal package is already deprecated and blocked from composes for rawhide.

Therefore, there are some broken dependencies for your package now:

gnome-device-manager-0.2-6.fc15.i686 requires libhal.so.1
gnome-device-manager-devel-0.2-6.fc15.i686 requires hal-devel >= 0:0.5.10
gnome-device-manager-devel-0.2-6.fc15.i686 requires pkgconfig(hal)
gnome-device-manager-libs-0.2-6.fc15.i686 requires hal >= 0:0.5.10
gnome-device-manager-libs-0.2-6.fc15.i686 requires libhal.so.1

If these dependencies cannot be removed, this package should probably be deprecated as well:

https://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life

Version-Release number of selected component (if applicable):

gnome-device-manager-0.2-6.fc15
Comment 1 Nicola Soranzo 2011-04-21 10:35:04 EDT
Moreover, this package requires other packages which were deprecated upstream
(libgnome, libgnomeui and libbonoboui) and is probably dead upstream.
Comment 2 Nicola Soranzo 2011-06-08 05:25:47 EDT
Ping?
Comment 3 Nicola Soranzo 2011-07-28 04:32:47 EDT
Package has been deprecated today and removed from f16 and rawhide, closing this bug report.

Note You need to log in before you can comment on or make changes to this bug.