Bug 698833 - Unison GUI not working
Summary: Unison GUI not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: unison227
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 733938 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-21 21:48 UTC by Paul Finnigan
Modified: 2012-01-20 14:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-20 14:10:57 UTC
Type: ---


Attachments (Terms of Use)
Patch that fixes the problem for me, created with a little googling (786 bytes, patch)
2011-06-16 21:00 UTC, C Western
no flags Details | Diff
Unison spec file (1.82 KB, text/x-rpm-spec)
2011-08-19 11:10 UTC, Mat
no flags Details

Description Paul Finnigan 2011-04-21 21:48:51 UTC
Description of problem:

Start a synchronisation process by selecting a profile from the GUI and the "contacting server" is displayed. It never disappears until you quit.

Using the command line version is fine (I have to ssh into my client to do this otherwise unison assumes that you want to use the GUI). 

Version-Release number of selected component (if applicable):

unison227.x86_64 2.27.57-13.fc12


How reproducible:

Every time

Steps to Reproduce:
1. Start Unison GUI
2. Select Profile 
3. Wait
  
Actual results:

Nothing

Expected results:

A panel displayed to show the differences between the two machines you are syncing.

Additional info:

Comment 1 Richard W.M. Jones 2011-04-21 21:57:33 UTC
To save you any disappointment:

(1) Please apply for co-maint of unison if you would like to
fix bugs.

(2) See:
http://lists.fedoraproject.org/pipermail/devel/2011-April/150678.html

Comment 2 Paul Finnigan 2011-05-26 13:34:41 UTC
If anyone wants to know I have built Unison 2.40.63 (the current stable release) from source and it works on Fedora 14 and Fedora 15. 

What I did:

1. Install ocaml, the ocaml gtk libraries and development files. It is also best to install EMACS to avoid funny looking results. My system already had all other dependencies already installed.
2. Download the source from http://www.cis.upenn.edu/~bcpierce/unison/
3. Untar it (nautilus works fine)
4. Open a terninal and cd to the Untar'd source
5. Type Make
6. As root copy the executable file unison to /usr/bin

If I get a chance I will attempt to make an rpm spec file but I will not get around to doing this for at least a couple of months.

If people ask I will make the binary available (x86_64 only at present).

Comment 3 C Western 2011-06-16 21:00:54 UTC
Created attachment 505146 [details]
Patch that fixes the problem for me, created with a little googling

Comment 4 Mat 2011-08-19 11:10:58 UTC
Created attachment 519019 [details]
Unison spec file

This is a spec file for Unison 2.40.63. I obtained it from Seve and am posting it here with his kind permission. (Seve does not necessarily claim sole authorship of this spec file, but still, kudos to him for providing it.) The rpms are available from http://forums.fedoraforum.org/showthread.php?t=264197

I hope this will help to get Unison properly maintained again.

Comment 5 Gregor Tätzner 2012-01-20 12:26:33 UTC
*** Bug 733938 has been marked as a duplicate of this bug. ***

Comment 6 Gregor Tätzner 2012-01-20 14:10:57 UTC
fixed with unison240 in updates-testing


Note You need to log in before you can comment on or make changes to this bug.