Bug 733938 - Password dialog not showing in GUI
Summary: Password dialog not showing in GUI
Keywords:
Status: CLOSED DUPLICATE of bug 698833
Alias: None
Product: Fedora
Classification: Fedora
Component: unison227
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 19:11 UTC by Susi Lehtola
Modified: 2012-06-03 01:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-20 12:26:33 UTC


Attachments (Terms of Use)

Description Susi Lehtola 2011-08-28 19:11:58 UTC
I'm experiencing a long-standing problem on my laptop. Whenever I run unison in graphical mode and try to synchronize my laptop to my desktop over ssh, the program seems to hang. I don't get a GUI password dialog as on my desktop, so this must be the culprit.

However, when I run unison in the console, I get the (text) password dialog.

Might there be some missing dependency in unison?

Comment 1 Richard W.M. Jones 2011-08-30 11:43:08 UTC
I don't know off-hand.  Any idea what the missing dep would be?

Comment 2 Susi Lehtola 2011-08-30 11:56:25 UTC
No idea.

Running with "-debug all" the GUI version gets stuck at  

[remote] Shell connection: ssh (ssh, foobar, -e, none, unison, -server)

where foobar is the remote machine.

Comment 3 Susi Lehtola 2011-08-30 11:56:59 UTC
I have also tried getting rid of ~/.unison/, but that has no effect.

Comment 4 Mack Stanley 2011-12-21 22:04:01 UTC
This is to confirm the same problem in F16 (as well as earlier in F15), and the same problem with unison-2.13.  

There is a similar ubuntu bug

https://bugs.launchpad.net/ubuntu/+source/unison/+bug/696706 

that includes a 
small patch, which I haven't tried.  Judging by that bug report, the problem concerns interaction with openssh 5.6.  This is plausible since literally the same unison 2.13 executable shows the ssh password dialog in F8 (openssh-4.7p1) and in Scientific Linux 6 (openssh-5.3p1), but not in F15 or F16.

The ubuntu report mentioned above includes a link to a Debian unison 2.40.63 package that is reported to fix this problem.  It tried the Debian 2.13 package's unison executable, and found it did not fix the problem.

Comment 5 Gregor Tätzner 2012-01-20 12:26:33 UTC
dupe and should be fixed with the new unison240 in updates-testing

*** This bug has been marked as a duplicate of bug 698833 ***

Comment 6 Kevin R. Page 2012-06-03 01:43:41 UTC
The problem still exists for unison227 in Fedora 17. Please re-open against unison227.

(I appreciate packaging the incompatible versions is a pain, but if you're stuck talking to a 227 server...)


Note You need to log in before you can comment on or make changes to this bug.