Bug 69903 - current newt confuses speakup
current newt confuses speakup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: newt (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Jay Turner
:
Depends On:
Blocks: CambridgeBlocker 101028
  Show dependency treegraph
 
Reported: 2002-07-26 00:41 EDT by Chris Kloiber
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.51.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 14:43:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
listbox.patch (550 bytes, patch)
2003-07-15 21:41 EDT, Chris Kloiber
no flags Details | Diff

  None (edit)
Description Chris Kloiber 2002-07-26 00:41:25 EDT
When installing Limbo-re0725.1 using

boot: text speakup_synth=dtlk

The speakup screen reader is reading the line below the cursor instead of the
current line only on screens that use newt. To duplicate the problem post
install run setup on a speakup-enabled machine (There's one in my cube) and
select the '8' key on the numberic keypad. That should read the current line,
but has the effect of reading the line below the current one.

Testing has shown that backreving newt to 0.5.0.33-1 "fixes" this problem.
Comment 1 Jennifer E. Lamb 2002-10-03 16:50:37 EDT
Has there been any progress on this bug report? The problem is still present in
8.0.  It has been open for over three months...
Comment 2 Matt Wilson 2002-10-04 00:47:24 EDT
I've reproduced the problem (thanks Chris for the box), but I have been unable
to track it down.
Comment 5 Chris Kloiber 2003-07-15 21:41:28 EDT
Created attachment 92956 [details]
listbox.patch
Comment 6 Chris Kloiber 2003-07-15 21:44:06 EDT
New information from Bill Acker <wacker@octothorp.org>
Date: 	Tue, 15 Jul 2003 17:26:10 -0600 (MDT)	
Hi,

     Finally, a patch that fixes the off by one line cursor problem when
using Speakup.  As usual, please add me to the CC for the bug.

     RPMS will be at ftp://linux-speakup.org/disks/redhat/9/ Thanks as
     always.

-- 
Bill in Denver
Comment 7 Michael K. Johnson 2003-08-19 15:38:33 EDT
In this patch, the changes to vertical positioning seem to me to be
obviously correct, but the changes to horizontal positioning are more
opaque and do not seem to directly relate to this bug report.  I'd
like to see a description of why the horizontal positioning changes
are correct, as it is not obvious to me.
Comment 8 Michael K. Johnson 2003-08-19 16:28:53 EDT
Matt Wilson provided analysis.  newt-0.51.5 and later will have this
patch.
Comment 9 Dave Habben 2003-10-22 14:04:49 EDT
Is this still an issue? 

This is the version that is currently in rawhide:
$ rpm -q newt
newt-0.51.6-1

$ rpm -q newt --changelog | head
* Tue Aug 19 2003 Michael K. Johnson <johnsonm@redhat.com> 0.51.6-1

- rebuild

* Tue Aug 19 2003 Michael K. Johnson <johnsonm@redhat.com> 0.51.5-1

- incorporated listbox cursor location patch (#69903)
Comment 10 Bill Nottingham 2003-10-22 14:43:43 EDT
Yes, this should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.