Bug 699128 - FIXED_IN_GIT: systemd crashed on SIGABRT
Summary: FIXED_IN_GIT: systemd crashed on SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 700364 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-23 11:39 UTC by James Ettle
Modified: 2011-05-01 03:29 UTC (History)
7 users (show)

Fixed In Version: systemd-26-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-01 03:29:07 UTC


Attachments (Terms of Use)
script containing gdb backtrace (5.42 KB, text/plain)
2011-04-23 11:39 UTC, James Ettle
no flags Details

Description James Ettle 2011-04-23 11:39:26 UTC
Created attachment 494417 [details]
script containing gdb backtrace

Description of problem:
At some poiint, systemd crashed on SIGABRT. From the syslog:

Apr 23 11:51:51 tabitha systemd[1]: Assertion 'm' failed at src/dbus-manager.c:3
23, function bus_manager_append_n_jobs(). Aborting.
Apr 23 11:51:54 tabitha abrt[18842]: saved core dump of pid 18841 (/bin/systemd)
 to /var/spool/abrt/ccpp-2011-04-23-11:51:51-18841.new/coredump (12312576 bytes)
Apr 23 11:51:54 tabitha abrtd: Directory 'ccpp-2011-04-23-11:51:51-18841' creati
on detected
Apr 23 11:51:54 tabitha systemd[1]: Caught <ABRT>, dumped core as pid 18841.
Apr 23 11:51:54 tabitha systemd[1]: Freezing execution.

Backtrace from gdb attached below.

Version-Release number of selected component (if applicable):
systemd-25-1.fc15.i686

Comment 1 Lennart Poettering 2011-04-27 00:18:44 UTC
fixed in git

Comment 2 Lennart Poettering 2011-04-28 14:50:34 UTC
*** Bug 700364 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2011-04-30 02:57:34 UTC
systemd-26-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-26-1.fc15

Comment 4 Fedora Update System 2011-05-01 03:28:42 UTC
systemd-26-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.