Bug 69921 - Make xmms warn nicely about lack of mp3 support
Make xmms warn nicely about lack of mp3 support
Status: CLOSED DUPLICATE of bug 74856
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-26 09:23 EDT by Mattias Dahlberg
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-30 17:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Dahlberg 2002-07-26 09:23:09 EDT
Description of problem:

I had an mp3 song in my home dir. Double clicked it. Although no mp3 player 
turned up it started playing. Note, this is not the "preview" because it 
continued after I moved away the mouse pointer. Now I couldn't stop the song. I 
changed to "view as music", clicking stop did nothing. It continued to play. I 
exited Nautilus. It continued to play. I logged out. It continued to play. In 
desperation I selected "shut down computer". It continued to play while 
processes were terminated, then at last the song stopped and the computer 
turned off.

And all I expected when double clicking the mp3 was too see XMMS or some other 
mp3 player start and play my song. Now some "magic" background playing 
occured. :) My suggestion: Turn of mp3 previews if it's possible and make XMMS 
start by default when you double click an mp3 in Nautilus. Isn't that what 
you'd expect?

The preview works sometimes (although the playback is skipping) but the above 
scenario has happened more than once. Hard to reproduce to a 100% though.


Version-Release number of selected component (if applicable):
The one in Limbo


How reproducible:
Sometimes

Steps to Reproduce:
1. Double click an mp3 song in Nautilus
Comment 1 Havoc Pennington 2002-07-26 10:10:30 EDT
Hmm, not good. ;-)
Comment 2 Havoc Pennington 2002-07-26 10:12:14 EDT
cf. http://bugzilla.gnome.org/show_bug.cgi?id=89143
Comment 3 Warren Togami 2002-08-11 06:09:34 EDT
This is a problem in both Gnome 1.4.x and Gnome 2.x.  This can be a serious
problem because it will always run mpg123 in the background, with no apparent
way of stopping it.

Please remove mpg123 as a file association for MP3.  It causes far too much harm
and little good.  XMMS or one of the other media players can play it instead.

Although... We probably shouldn't be making assumptions that XMMS is installed.
 Perhaps a little script like Bero's "htmlview" should be written.  It would be
called "soundplay", and it would be used as a generic sound media players,
running whichever player is currently installed.  It could also potentially
autodetect if esd or arts is currently in use, choosing the appropriate player.

Good idea?  Bad idea?
Comment 4 Havoc Pennington 2002-08-14 18:33:17 EDT
mpg123 is no longer in gnome-vfs.keys; if I double-click an mp3 file I get xmms
this is gnome-mime-data 2.0.0-7
Comment 5 Jay Turner 2002-08-29 23:34:36 EDT
With gnome-mime-data-2.0.0-8, clicking on an mp3 file launches xmms.  But we
have removed decoding from the default release, so we need a dialog which tells
the user what is going on and that we don't have decoders in the release anymore.
Comment 6 Mattias Dahlberg 2002-08-30 03:03:04 EDT
Please make sure that such a text gets processed by the translation teams 
before release.
Comment 7 Alexander Larsson 2002-08-30 05:03:29 EDT
That would break if people install an external mp3 plugin for xmms though.
Comment 8 Havoc Pennington 2002-08-30 17:59:13 EDT
I think we should punt this from the current release, but to fix 
I would say xmms should just have a nice message when it sees an mp3. 
That way we kill two birds with one stone and also handle people who aren't
expecting xmms to have mp3 disabled.
Comment 9 Warren Togami 2002-08-31 04:29:30 EDT
Can that nice message have a link to a page with a complete explanation and
links to more information?  If so, I would be willing to help in organizing that
information.
Comment 10 Joerg Lehrke 2002-11-30 17:07:28 EST
Hi Folks,

nice that you planed to insert a plug-in to show a message. I needed to look in
the xmms.spec to sort out the missing support for MP3. There I also found the
bug why I never show this warning:
install -m 755 libzz_mp3.so %{buildroot}%{_datadir}/xmms/Input
The correct line is:
install -m 755 libzz_mp3.so %{buildroot}%{_libdir}/xmms/Input

Cheers,
J"org
Comment 11 Bill Nottingham 2002-12-02 12:51:43 EST

*** This bug has been marked as a duplicate of 74856 ***

Note You need to log in before you can comment on or make changes to this bug.