Bug 74856 - mpeg placeholder plugin does not get installed
Summary: mpeg placeholder plugin does not get installed
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 69921 75850 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 10:37 UTC by Håvard Kvålen
Modified: 2014-03-17 02:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 17:45:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Håvard Kvålen 2002-10-02 10:37:24 UTC
The xmms src rpm contains a dummy plugin that is supposed to inform users that
this version of xmms don't play mpeg audio.  Unfortunately this plugin does not
get installed due to an error in the spec file.

Pseudo patch:
-install -m 755 libzz_mp3.so %{buildroot}%{_datadir}/xmms/Input
+install -m 755 libzz_mp3.so %{buildroot}%{_libdir}/xmms/Input

While I'm at it, there are a couple of other issues with the spec file:
* It should have automake14 and autoconf213 in BuildRequires
* Having the skin subpackage depend on a specific xmms version seems a bit 
  unecessary

Comment 1 Bill Nottingham 2002-10-02 16:17:31 UTC
egg->face. 

The problem with requiring automake14 and autoconf213 means that it will break
on systems that have automake-1.4 and autoconf-2.13 installed. So it needs to
require /usr/bin/automake-1.4, etc.

Comment 2 Håvard Kvålen 2002-10-02 16:45:24 UTC
Most automake-1.4 packages won't work anyway since they usually don't have any
executables named automake-1.4.  But nevermind, it's a very minor issue.

Comment 3 Richard Allen 2002-10-03 11:58:44 UTC
This is prehaps a blessing ? :)  Now we dont get any file conflicts when
installing rpm's that contain the mp3 input files from the RH 7.3 version of xmms ;)


Comment 4 Bill Nottingham 2002-10-03 14:51:28 UTC
There aren't any file conflicts anyway.

Comment 5 Bill Nottingham 2002-10-14 20:22:22 UTC
*** Bug 75850 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2002-12-02 17:51:34 UTC
*** Bug 69921 has been marked as a duplicate of this bug. ***

Comment 7 Julien Olivier 2003-02-07 11:00:03 UTC
Hi

I just thought of a better solution to make everybody happy. Why not modify xmms
to make it download/install automatically any missing plugin. The user would of
course be warned about the legal issues and could accept or refuse the plugin.

Comment 8 Bill Nottingham 2003-02-07 17:45:45 UTC
This has been fixed in the rawhide xmms packages for a while.


Note You need to log in before you can comment on or make changes to this bug.