Bug 699275 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: munin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-24 16:46 EDT by Jóhann B. Guðmundsson
Modified: 2011-06-15 22:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-15 22:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for munin-node (204 bytes, text/plain)
2011-04-24 16:46 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file with directory and ownership creation.. (291 bytes, text/plain)
2011-04-26 19:27 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-24 16:46:11 EDT
Created attachment 494556 [details]
Native systemd service file for munin-node

Description of problem:

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-04-24 16:48:44 EDT
I do belive that this should be done in the package at install time not in the service  

mkdir -p /var/run/munin 2>/dev/null
chown munin /var/run/munin
Comment 2 Jóhann B. Guðmundsson 2011-04-24 16:56:49 EDT
To test this.

Copy the file into /lib/systemd/system/ directory 

Run systemctl daemon-reload

Then run

systemctl start/stop/restart/enable/disable munin-node.service
Comment 3 Kevin Fenzi 2011-04-24 19:41:46 EDT
(In reply to comment #1)
> I do belive that this should be done in the package at install time not in the
> service  
> 
> mkdir -p /var/run/munin 2>/dev/null
> chown munin /var/run/munin

Unless I am missing something, /var/run is a tmpfs now... so the init script or systemd unit file would need to create it? The package can't or it would disappear after a reboot, right?
Comment 4 Bill Nottingham 2011-04-26 13:35:57 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 5 Jóhann B. Guðmundsson 2011-04-26 19:27:50 EDT
Created attachment 495080 [details]
Native systemd service file with directory and ownership creation..

Real service create the dir from it's initialization code others need to result to this ;)
Comment 6 Kevin Fenzi 2011-05-07 19:41:07 EDT
*** Bug 702871 has been marked as a duplicate of this bug. ***
Comment 7 d. johnson 2011-06-01 23:48:06 EDT
munin-1.4.5-9 has a native service file.
Comment 8 Jóhann B. Guðmundsson 2011-06-15 18:06:42 EDT
Btw should not this part of the service file

ExecStartPre=/bin/mkdir -p /var/run/munin
ExecStartPre=/bin/chown munin /var/run/munin

be moved into a tmpfile see 

http://fedoraproject.org/wiki/Packaging:Tmpfiles.d

And please close bugs when FIXED ;)
Comment 9 d. johnson 2011-06-15 22:14:16 EDT
Added /etc/tmpfiles.d/munin.conf entry and changed version to F16.  For users that already have F15 init.d script converting to systemd.service file is problematic, and FPC decided not to change this method mid-release.

Note You need to log in before you can comment on or make changes to this bug.