Bug 699278 - Incorrect long option syntax in --help output
Summary: Incorrect long option syntax in --help output
Keywords:
Status: CLOSED DUPLICATE of bug 293531
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-24 21:01 UTC by Ville Skyttä
Modified: 2011-05-24 12:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-24 12:18:52 UTC


Attachments (Terms of Use)

Description Ville Skyttä 2011-04-24 21:01:47 UTC
rpm --help contains long option entries like:

  -e, --erase=<package>+           erase (uninstall) package
  -F, --freshen=<packagefile>+     upgrade package(s) if already installed
  -U, --upgrade=<packagefile>+     upgrade package(s)

...but the long option syntax does not actually work when invoked like the above, they need to be given like "--erase foo" or "--upgrade foo" instead, i.e. the "=" needs to be replaced by whitespace.  For some options the "=" appears to work (for example --rcfile=foo) but not for any of the above.

No idea if this is an upstream rpm or popt issue, so reporting it here.

Comment 1 Panu Matilainen 2011-05-24 12:18:52 UTC
It's an popt-issue indeed (and old one at that IIRC), supposedly fixed in popt >= 1.14 but there hasn't been a whole lot of activity in updating Fedora's popt to a more recent version... (see bug 448286)

*** This bug has been marked as a duplicate of bug 293531 ***


Note You need to log in before you can comment on or make changes to this bug.