Bug 6999 - Display becomes scrambled when using S3 Virge/GX server
Display becomes scrambled when using S3 Virge/GX server
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 11025 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-14 15:20 EST by s.harper
Modified: 2011-05-04 18:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-01 18:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description s.harper 1999-11-14 15:20:12 EST
I am trying to configure X Windows on a Compaq Deskpro 6000 with S3
Virge/GX graphics. When Xconfigurator probes the card the graphics become
scrambled. I checked the video chipset compatibility list and my 86C385
chipset is on the list. Also, I am using a Compaq P70 monitor. I couldn't
find any other reports on the S3 in the database.
Comment 1 Preston Brown 2000-05-08 09:56:59 EDT
*** Bug 11025 has been marked as a duplicate of this bug. ***
Comment 2 Angel M. Alonso 2000-07-01 18:18:44 EDT
I thing the problem is that the Xconfigurator tries the XF86_SVGA driver and the
correct was the XF86_S3V (i've tried to rename the XF86_SV3 with XF86_SVGA and
everithing works fine)
Comment 3 Preston Brown 2000-08-29 13:25:32 EDT
Some versions of the virge work better with the virge support in the SVGA
server, others still work better with the old S3V server.  The ViRGE is such a
bad chip that this will never get resolved -- S3 often made changes to the chip
and didn't even bump the PCI revision number or external number stamped onto the
chip, making support anything but easy.

Note You need to log in before you can comment on or make changes to this bug.