Bug 70000 - Openoffice applications exit unexpectedly
Summary: Openoffice applications exit unexpectedly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-28 12:39 UTC by Pavel
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 15:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pavel 2002-07-28 12:39:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020726

Description of problem:
I'm using openoffice 1.0.0-7 on RedHat Limbo. When I run any of openoffice
applications they exit few seconds after displaying a window. No error messages
printed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Remove user openoffice installation
2. Run oowriter. Select cancel in Autopilot dialog. Quit oowriter.
3. Run oowriter again. Select "already registered user" and click OK.. Quit oowriter
4. Run any openoffice app.
	

Actual Results:  Application displays main window then exits after few seconds.

Expected Results:  Continue work.

Additional info:

Comment 1 Jakub Jelinek 2002-07-29 18:17:19 UTC
Cannot reproduce this with openoffice 1.0.1-2.

Comment 2 Bernhard Rosenkraenzer 2002-07-30 16:37:22 UTC
Not reproducable here either. 
Please reopen this if you have more information on what's causing this for 
you.

Comment 3 Pavel 2002-08-01 10:37:47 UTC
I installed Limbo2 from the scratch, and problem still happens. I tried to run
soffice.bin with gdb, and it says "program exited normally".

Comment 4 Pavel 2002-08-01 10:59:15 UTC
It looks like every time an openoffice app opens without dialog, it exits
immediately. For example, if I open impress without a file, it displays a dialog
about a new presentation, and then continue to work. But if I open impress with
a file, it exits immediately.

Comment 5 Pavel 2002-08-01 16:17:02 UTC
Ok, I found 2 strange things about this problem.
1. Openoffice works under KDE and failsafe sessions (failsafe with twm, metacity
or without window manager), but it does not work under GNOME session.

2. It works under GNOME if I run it as different user (su anotheruser -c ...).
If I  log in as another user, then same problem happens.

Comment 6 Pavel 2002-08-08 08:47:48 UTC
I just noticed same problem reported on OOo discuss mailing list. My hardware
configuration (Celeron 300) is similar to the one reported there.

Comment 7 Pavel 2002-08-11 06:52:09 UTC
Please look at 
http://www.openoffice.org/issues/show_bug.cgi?id=4494

adding "unset SESSION_MANAGER" to /usr/bin/ooffice makes it work for me.


Comment 8 Mike A. Harris 2002-08-20 17:47:27 UTC
*** Bug 72002 has been marked as a duplicate of this bug. ***

Comment 9 Dan Williams 2004-02-27 15:47:34 UTC
Please try current OOo 1.1.0, and reopen if problem still occurs


Note You need to log in before you can comment on or make changes to this bug.