Bug 700001 - [abrt] Zim-0.51-1.fc14: notebook.py:260:<genexpr>:AttributeError: 'str' object has no attribute 'uri'
[abrt] Zim-0.51-1.fc14: notebook.py:260:<genexpr>:AttributeError: 'str' objec...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:0bf19528
:
: 700503 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 04:50 EDT by Petr Lautrbach
Modified: 2011-05-06 22:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: Zim-0.52-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-06 22:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (846 bytes, text/plain)
2011-04-27 04:50 EDT, Petr Lautrbach
no flags Details

  None (edit)
Description Petr Lautrbach 2011-04-27 04:50:22 EDT
abrt version: 1.1.17
architecture: x86_64
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.12-88.fc14.x86_64
package: Zim-0.51-1.fc14
reason: notebook.py:260:<genexpr>:AttributeError: 'str' object has no attribute 'uri'
release: Fedora release 14 (Laughlin)
time: 1303894176
uid: 13558

backtrace
-----
notebook.py:260:<genexpr>:AttributeError: 'str' object has no attribute 'uri'

Traceback (most recent call last):
  File "/usr/bin/zim", line 56, in <module>
    zim.main(argv)
  File "/usr/lib/python2.7/site-packages/zim/__init__.py", line 311, in main
    notebook = zim.gui.notebookdialog.prompt_notebook()
  File "/usr/lib/python2.7/site-packages/zim/gui/notebookdialog.py", line 47, in prompt_notebook
    list.write()
  File "/usr/lib/python2.7/site-packages/zim/notebook.py", line 260, in write
    lines.extend(info.uri + '\n' for info in self)
  File "/usr/lib/python2.7/site-packages/zim/notebook.py", line 260, in <genexpr>
    lines.extend(info.uri + '\n' for info in self)
AttributeError: 'str' object has no attribute 'uri'

Local variables in innermost frame:
info: 'file:///home/user/Notes'
.0: <listiterator object at 0x1b09e50>

How to reproduce
-----
1. run zim
2. press OK in "Add Notebook" dialog
3.
Comment 1 Petr Lautrbach 2011-04-27 04:50:25 EDT
Created attachment 495150 [details]
File: backtrace
Comment 2 Robin Lee 2011-04-28 11:17:30 EDT
*** Bug 700503 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2011-04-28 15:20:20 EDT
Zim-0.52-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/Zim-0.52-1.fc14
Comment 4 Fedora Update System 2011-04-28 23:20:24 EDT
Package Zim-0.52-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.52-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/Zim-0.52-1.fc14
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-05-06 22:56:05 EDT
Zim-0.52-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.