Bug 700503 - [abrt] Zim-0.51-1.fc15: notebook.py:260:<genexpr>:AttributeError: 'str' object has no attribute 'uri'
[abrt] Zim-0.51-1.fc15: notebook.py:260:<genexpr>:AttributeError: 'str' objec...
Status: CLOSED DUPLICATE of bug 700001
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:dd9859f39ec6489b95f21d93a96...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-28 10:42 EDT by Bruce Pieterse
Modified: 2011-04-28 11:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-28 11:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (856 bytes, text/plain)
2011-04-28 10:42 EDT, Bruce Pieterse
no flags Details

  None (edit)
Description Bruce Pieterse 2011-04-28 10:42:43 EDT
abrt version: 2.0.1
comment: Installed from add/remove software. I launched the application and selected a new location for my notebook, then pressed ok and it crashed.
executable: /usr/bin/zim
event_log: 2011-04-28-11:46:49> The report was appended to /tmp/abrt.log
component: Zim
architecture: i686
reported_to: file: /tmp/abrt.log
kernel: 2.6.38.3-18.fc15.i686
reason: notebook.py:260:<genexpr>:AttributeError: 'str' object has no attribute 'uri'
uid: 500
package: Zim-0.51-1.fc15
username: bruce
os_release: Fedora release 15 (Lovelock)
time: 1303983684

backtrace
-----
notebook.py:260:<genexpr>:AttributeError: 'str' object has no attribute 'uri'

Traceback (most recent call last):
  File "/usr/bin/zim", line 56, in <module>
    zim.main(argv)
  File "/usr/lib/python2.7/site-packages/zim/__init__.py", line 311, in main
    notebook = zim.gui.notebookdialog.prompt_notebook()
  File "/usr/lib/python2.7/site-packages/zim/gui/notebookdialog.py", line 47, in prompt_notebook
    list.write()
  File "/usr/lib/python2.7/site-packages/zim/notebook.py", line 260, in write
    lines.extend(info.uri + '\n' for info in self)
  File "/usr/lib/python2.7/site-packages/zim/notebook.py", line 260, in <genexpr>
    lines.extend(info.uri + '\n' for info in self)
AttributeError: 'str' object has no attribute 'uri'

Local variables in innermost frame:
info: 'file:///home/user/Documents/Notes'
.0: <listiterator object at 0xa3a4c2c>
Comment 1 Bruce Pieterse 2011-04-28 10:42:46 EDT
Created attachment 495558 [details]
File: backtrace
Comment 2 Robin Lee 2011-04-28 11:17:30 EDT

*** This bug has been marked as a duplicate of bug 700001 ***

Note You need to log in before you can comment on or make changes to this bug.