Bug 700085 - iSCSI login dialog allows unselecting all devices and continuing - unable to login to any iSCSI devices after
iSCSI login dialog allows unselecting all devices and continuing - unable to ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-04-27 08:24 EDT by James Laska
Modified: 2014-09-30 19:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-15.31-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 701220 (view as bug list)
Environment:
Last Closed: 2011-05-14 00:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-logs.tgz (/tmp/*log /tmp/anaconda-screenshots) (148.96 KB, application/x-gzip)
2011-04-27 08:24 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2011-04-27 08:24:18 EDT
Created attachment 495211 [details]
anaconda-logs.tgz (/tmp/*log /tmp/anaconda-screenshots)

Description of problem:

While adding an iSCSI device, if you forget to select any of the discovered iSCSI devices (or uncheck all of them), you can still click the "Login" button.  After that, you are unable to login to any iSCSI devices.

Version-Release number of selected component (if applicable):
 * anaconda-15.29-1

How reproducible:
 * pretty easy, and happens every time when entering incorrect data.

Steps to Reproduce:
1. Follow steps outlined at https://fedoraproject.org/wiki/QA:Testcase_Anaconda_ISCSI_No_Authentication
2. After iSCSI discovery finds available volumes, unselect all volumes and click 'Login'
  
Actual results:

THe user is able to click 'Login' and the dialog closes.  From that point, any attempts to re-add an iSCSI device fail.

Expected results:

The 'Login' button should be deactivated (unclickable) if no devices are selected.

Additional info:

* Nominating for a F15 nice-to-have fix since I suspect this won't be a disruptive change.
* See attached log files ...

-rw-r--r-- root/root     27432 2011-04-27 08:16 tmp/X.log
-rw-r--r-- root/root      4620 2011-04-27 08:18 tmp/anaconda.log
-rw-r--r-- root/root      2380 2011-04-27 08:17 tmp/ifcfg.log
-rw-r--r-- root/root      2425 2011-04-27 08:17 tmp/program.log
-rw-r--r-- root/root      5150 2011-04-27 08:17 tmp/storage.log
-rw-r--r-- root/root     55541 2011-04-27 08:18 tmp/syslog
-rw-r--r-- root/root     68515 2011-04-27 08:18 tmp/anaconda-screenshots/screenshot-0001.png

^^^ The error dialog

-rw-r--r-- root/root     72580 2011-04-27 08:17 tmp/anaconda-screenshots/screenshot-0000.png

^^^ Demonstrating deselecting all iSCSI devices
Comment 1 Ales Kozumplik 2011-04-27 12:05:55 EDT
Patch waiting here:

https://www.redhat.com/archives/anaconda-devel-list/2011-April/msg00280.html
Comment 2 Adam Williamson 2011-04-29 14:34:49 EDT
Discussed at 2011-04-29 NTH review meeting. Accepted as NTH: can't be fixed with an update, helps to prevent you shooting yourself in the foot. Low risk patch, per clumens.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Ales Kozumplik 2011-05-02 03:02:31 EDT
Fixed by 5ac783808cb015ea67006833fa8f9ef3fcbd350e.
Comment 4 James Laska 2011-05-02 10:55:11 EDT
Tested with an updates.img (http://jlaska.fedorapeople.org/updates/700085.img) on top of anaconda-15.29-1 (http://jlaska.fedorapeople.org/updates/anaconda-15.29-1/).  Confirmed that my non-root iSCSI volume gets mounted everytime on boot.  Thanks!
Comment 5 Fedora Update System 2011-05-02 15:30:50 EDT
anaconda-15.30-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.30-1.fc15
Comment 6 Fedora Update System 2011-05-03 00:28:13 EDT
Package anaconda-15.30-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.30-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.30-1.fc15
then log in and leave karma (feedback).
Comment 7 James Laska 2011-05-05 07:56:47 EDT
Verified using F15-Final-TC1 (anaconda-15.30-1)
Comment 8 Fedora Update System 2011-05-06 15:03:46 EDT
anaconda-15.31-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.31-1.fc15
Comment 9 Fedora Update System 2011-05-07 11:05:01 EDT
Package anaconda-15.31-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.31-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.31-1.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-05-14 00:05:12 EDT
anaconda-15.31-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Ales Kozumplik 2011-06-10 04:27:59 EDT
See bug 700085 for the same rhel6 issue.
Comment 12 Ales Kozumplik 2011-06-10 04:30:55 EDT
(In reply to comment #11)
> See bug 700085 for the same rhel6 issue.

I mean bug 701220.

Note You need to log in before you can comment on or make changes to this bug.