Bug 700323 - [PALM] Radeon 6310 with Gallium 0.4: GPU lockup CP stall with r600g
Summary: [PALM] Radeon 6310 with Gallium 0.4: GPU lockup CP stall with r600g
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jérôme Glisse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: [cat:lockup]
Depends On:
Blocks: 700220
TreeView+ depends on / blocked
 
Reported: 2011-04-28 06:52 UTC by Marcus Husar
Modified: 2018-04-11 19:11 UTC (History)
4 users (show)

Fixed In Version: kernel-2.6.38.5-24.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-09 03:56:27 UTC


Attachments (Terms of Use)
Xorg log (44.63 KB, text/plain)
2011-04-28 06:59 UTC, Marcus Husar
no flags Details
glxinfo (23.98 KB, text/plain)
2011-04-28 07:39 UTC, Marcus Husar
no flags Details
/var/log/messages (4.83 MB, text/plain)
2011-04-29 16:53 UTC, Marcus Husar
no flags Details
Output of dmesg (123.56 KB, text/plain)
2011-04-29 16:54 UTC, Marcus Husar
no flags Details

Description Marcus Husar 2011-04-28 06:52:43 UTC
Description of problem:

When using gnome-shell my system becomes unstable and crashes/restarts gnome-shell and other software like firefox, gedit, terminal, rhythmbox, firefox, gcalctool, nautilus.

I don't have any problems in fallback mode of Gnome 3. At least I haven't seen any, yet.

Version-Release number of selected component (if applicable):

6.14.0 (7.20110316gitcdfc007ec.fc15)

How reproducible:

Use some software under gnome-shell. It can take minutes or hours until gnome-shell restarts and/or firefox or some other software gets killed by signal 11.

Steps to Reproduce:
1. Start Fedora with gnome-shell
2. Work, watch videos, browse the internet
3. ...
  
Actual results:

Something is crashing.

Expected results:

Nothing is crashing.

Additional info:

Here is a bug I filed for gnome-shell with additional information:
https://bugzilla.redhat.com/show_bug.cgi?id=700220

Here is a dump on my system:

[  674.452319] radeon 0000:00:01.0: GPU lockup CP stall for more than 10000msec
[  674.458424] ------------[ cut here ]------------
[  674.458515] WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:248
radeon_fence_wait+0x2a8/0x32b [radeon]()
[  674.458524] Hardware name: 10382LG
[  674.458531] GPU lockup (waiting for 0x00000404 last fence id 0x00000403)
[  674.458538] Modules linked in: tun fuse sunrpc cpufreq_ondemand powernow_k8
freq_table mperf rfcomm sco bnep l2cap ip6t_REJECT nf_conntrack_ipv6
nf_defrag_ipv6 ip6table_filter ip6_tables vfat fat snd_hda_codec_conexant
snd_hda_codec_hdmi snd_hda_intel snd_hda_codec snd_hwdep snd_seq arc4
snd_seq_device snd_pcm rt2800pci snd_timer rt2800lib crc_ccitt uvcvideo
rt2x00pci snd videodev ideapad_laptop rt2x00lib mac80211 v4l2_compat_ioctl32
sparse_keymap btusb bluetooth sp5100_tco cfg80211 microcode r8169 soundcore wmi
snd_page_alloc rfkill joydev i2c_piix4 mii eeprom_93cx6 k10temp uinput ipv6
video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded:
scsi_wait_scan]
[  674.458763] Pid: 1922, comm: gnome-shell Not tainted 2.6.38.3-18.fc15.x86_64
#1
[  674.458777] Call Trace:
[  674.458802]  [<ffffffff81055116>] ? warn_slowpath_common+0x83/0x9b
[  674.458821]  [<ffffffff810551d1>] ? warn_slowpath_fmt+0x46/0x48
[  674.458900]  [<ffffffffa00d7ac2>] ? evergreen_gpu_is_lockup+0xbb/0xc3
[radeon]
[  674.458969]  [<ffffffffa009f8ec>] ? radeon_fence_wait+0x2a8/0x32b [radeon]
[  674.458991]  [<ffffffff8106f1f6>] ? autoremove_wake_function+0x0/0x3d
[  674.459084]  [<ffffffffa00b04fc>] ? radeon_ib_get+0xf1/0x178 [radeon]
[  674.459160]  [<ffffffffa00b1972>] ? radeon_cs_ioctl+0x96/0x1a6 [radeon]
[  674.459208]  [<ffffffffa0019861>] ? drm_ioctl+0x29e/0x37b [drm]
[  674.459229]  [<ffffffff811eb291>] ? inode_has_perm+0x76/0x8c
[  674.459302]  [<ffffffffa00b18dc>] ? radeon_cs_ioctl+0x0/0x1a6 [radeon]
[  674.459323]  [<ffffffff811eb34b>] ? file_has_perm+0xa4/0xc6
[  674.459346]  [<ffffffff8112f55c>] ? do_vfs_ioctl+0x47e/0x4bf
[  674.459363]  [<ffffffff8112f5f3>] ? sys_ioctl+0x56/0x7b
[  674.459382]  [<ffffffff81009bc2>] ? system_call_fastpath+0x16/0x1b
[  674.459397] ---[ end trace 318245572877088b ]---
[  674.461095] radeon 0000:00:01.0: GPU softreset 
[  674.461104] radeon 0000:00:01.0:   GRBM_STATUS=0xF5702828
[  674.461113] radeon 0000:00:01.0:   GRBM_STATUS_SE0=0xFC000005
[  674.461121] radeon 0000:00:01.0:   GRBM_STATUS_SE1=0x00000007
[  674.461129] radeon 0000:00:01.0:   SRBM_STATUS=0x20000040
[  674.461146] radeon 0000:00:01.0:   GRBM_SOFT_RESET=0x00007F6B
[  674.461256] radeon 0000:00:01.0:   GRBM_STATUS=0x00003828
[  674.461264] radeon 0000:00:01.0:   GRBM_STATUS_SE0=0x00000007
[  674.461272] radeon 0000:00:01.0:   GRBM_STATUS_SE1=0x00000007
[  674.461279] radeon 0000:00:01.0:   SRBM_STATUS=0x20000040
[  674.462292] radeon 0000:00:01.0: GPU reset succeed
[  674.482399] radeon 0000:00:01.0: WB enabled
[  674.498798] [drm] ring test succeeded in 1 usecs
[  674.498813] [drm] ib test succeeded in 2 usecs

There are lots of people having similar problems:
http://comments.gmane.org/gmane.comp.freedesktop.xorg.drivers.ati/17290
https://bugs.freedesktop.org/show_bug.cgi?id=36435
https://bugs.freedesktop.org/show_bug.cgi?id=34373
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/770146
http://phoronix.com/forums/showthread.php?35924-Problems-with-Northern-Island-with-radeon.

Comment 1 Marcus Husar 2011-04-28 06:59:01 UTC
Created attachment 495422 [details]
Xorg log

Comment 2 Marcus Husar 2011-04-28 07:39:14 UTC
Created attachment 495437 [details]
glxinfo

Comment 3 Matěj Cepl 2011-04-29 14:01:18 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Marcus Husar 2011-04-29 16:53:11 UTC
Created attachment 495814 [details]
/var/log/messages

This is a slightly censored version.

cat /var/log/messages | grep -v "ntpd" | grep -v "NetworkManager" | grep -v "dhclient" > messages.txt

Comment 5 Marcus Husar 2011-04-29 16:54:39 UTC
Created attachment 495815 [details]
Output of dmesg

Comment 6 Marcus Husar 2011-04-29 17:02:42 UTC
I added drm.debug=0x04 to the grub command line. /var/log/messages is really huge, because I compiled some alsa drivers with debug mode verbose. The system is also unstable without these new alsa drivers. There is no custom xorg.conf.

I have no problems in Gnome 3’s fallback mode. Everything is fine.

Thanks for your help,
Marcus

Comment 7 Dave Airlie 2011-05-04 10:08:56 UTC
can you try with latest xorg-x11-drv-ati and kernel from:

http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-ati/6.14.1/1.20110504gita6d2dba6.fc15/
and kernel
http://kojipkgs.fedoraproject.org/packages/kernel/2.6.38.5/23.fc15/

see if it helps.

Comment 8 Marcus Husar 2011-05-05 18:50:27 UTC
I testet both packages today and had no problems for a few hours. Also the performance seems to be much better.

I think this bug can be closed. Thanks a lot.

Marcus

Comment 9 Fedora Update System 2011-05-07 07:23:24 UTC
kernel-2.6.38.5-24.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.5-24.fc15

Comment 10 Fedora Update System 2011-05-07 15:05:56 UTC
Package kernel-2.6.38.5-24.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.38.5-24.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.38.5-24.fc15
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2011-05-09 03:56:20 UTC
kernel-2.6.38.5-24.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.